]> git.pld-linux.org Git - packages/dosbox.git/blob - dosbox.spec
- obsolete
[packages/dosbox.git] / dosbox.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA support for MIDI
4 #
5 %define ver_package 0.74.3
6 %define ver_tarball 0.74-3
7 Summary:        x86/DOS emulator with sound/graphics primarily for games
8 Summary(pl.UTF-8):      Emulator x86/DOS z dźwiękiem/grafiką głównie dla gier
9 Name:           dosbox
10 Version:        %{ver_package}
11 Release:        1
12 License:        GPL v2+
13 Group:          Applications/Emulators
14 Source0:        http://downloads.sourceforge.net/dosbox/%{name}-%{ver_tarball}.tar.gz
15 # Source0-md5:  759c75fffb59c542f80fb8391012911b
16 Source1:        %{name}.desktop
17 Source2:        %{name}.png
18 Source3:        %{name}.conf
19 URL:            http://dosbox.sourceforge.net/
20 BuildRequires:  OpenGL-devel
21 # because of SDL_opengl deps
22 BuildRequires:  OpenGL-GLU-devel
23 BuildRequires:  SDL-devel >= 1.2.0
24 BuildRequires:  SDL_net-devel
25 BuildRequires:  SDL_sound-devel
26 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  libpng-devel
30 BuildRequires:  libstdc++-devel
31 %{?debug:BuildRequires: ncurses-devel}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         specflags       -fmerge-all-constants -ffast-math
35
36 %description
37 DOSBox emulates a 286/386 realmode/protected mode CPU, Directory
38 FileSystem/XMS/EMS, Tandy/Hercules/CGA/EGA/VGA/VESA graphics, a
39 SoundBlaster/Gravis Ultra Sound card for excellent sound compatibility
40 with older games...
41
42 You can "re-live" the good old days with the help of DOSBox, it can
43 run plenty of the old classics that don't run on your new computer!
44
45 %description -l pl.UTF-8
46 DOSBox emuluje tryb rzeczywisty/chroniony procesora 286/386, system
47 plików z katalogami, pamięć XMS/EMS, karty graficzne
48 Tandy/Hercules/CGA/EGA/VGA/VESA oraz karty muzyczne
49 SoundBlaster/Gravis Ultra Sound w celu zapewnienia znakomitej
50 kompatybilności ze starymi grami.
51
52 Stare wspomnienia odżyją z pomocą DOSBoksa. Dzięki niemu można
53 uruchomić mnóstwo klasyków, które nie odpalają się na nowych
54 komputerach.
55
56 %prep
57 %setup -q -n %{name}-%{ver_tarball}
58
59 %build
60 # kill AM_PATH_SDL and AM_PATH_ALSA, leave only AH_{TOP,BOTTOM}
61 tail -n +306 acinclude.m4 > acinclude.m4.tmp
62 mv -f acinclude.m4.tmp acinclude.m4
63 %if !%{with alsa}
64 echo 'AC_DEFUN([AM_PATH_ALSA], [$3])' >> acinclude.m4
65 %endif
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 %configure \
71         --enable-shots \
72         %{?debug:--enable-debug}
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
84 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
85 install %{SOURCE3} .
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS NEWS README THANKS dosbox.conf
93 %attr(755,root,root) %{_bindir}/*
94 %{_mandir}/man1/dosbox.1.gz
95 %{_desktopdir}/*.desktop
96 %{_pixmapsdir}/dosbox.png
This page took 0.169458 seconds and 4 git commands to generate.