]> git.pld-linux.org Git - packages/domoticz.git/blob - domoticz.spec
disable auto updates
[packages/domoticz.git] / domoticz.spec
1 Summary:        Open source Home Automation System
2 Name:           domoticz
3 Version:        2020.2
4 Release:        3
5 License:        GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6 Group:          Base
7 URL:            http://www.domoticz.com
8 Source0:        https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9 # Source0-md5:  fd383a13d13d0976c72f332d6db1d24e
10 Source1:        %{name}.service
11 Source2:        %{name}.conf
12 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
13 Patch0:         %{name}-tinyxpath.patch
14 # Use system openzwave includes
15 Patch1:         %{name}-openzwave.patch
16 # Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
17 Patch2:         %{name}-python.patch
18 Patch3:         no-git.patch
19 Patch4:         boost-1.73.patch
20 Patch5:         %{name}-gpio.patch
21 Patch6:         python3.9.patch
22 Patch7:         %{name}-no_updates.patch
23 BuildRequires:  boost-devel >= 1.66.0
24 BuildRequires:  cereal-devel
25 BuildRequires:  cmake >= 3.16.0
26 BuildRequires:  curl-devel
27 BuildRequires:  jsoncpp-devel
28 BuildRequires:  libmosquitto-devel
29 BuildRequires:  libopenzwave-devel >= 1.5.0
30 BuildRequires:  libstdc++-devel >= 6:4.8.1
31 BuildRequires:  libusb-compat-devel
32 BuildRequires:  linux-libc-headers
33 BuildRequires:  lua53-devel
34 BuildRequires:  minizip-devel
35 BuildRequires:  openssl-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python3 >= 1:3.4
38 BuildRequires:  python3-devel >= 1:3.4
39 BuildRequires:  rpmbuild(macros) >= 1.644
40 BuildRequires:  sqlite3-devel
41 BuildRequires:  tinyxml-devel
42 BuildRequires:  tinyxpath-devel
43 BuildRequires:  zlib-devel
44 Requires(pre):  /usr/sbin/groupadd
45 Requires(pre):  /usr/sbin/useradd
46 Requires(post,preun,postun):    systemd-units >= 38
47 Requires:       fonts-TTF-Google-Droid
48 Requires:       fonts-TTF-OpenSans
49 Requires:       libopenzwave >= 1.5.0
50 Requires:       setup >= 2.10.1
51 Provides:       group(domoticz)
52 Provides:       user(domoticz)
53
54 %description
55 Domoticz is a Home Automation System that lets you monitor and
56 configure various devices like: Lights, Switches, various
57 sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
58 and much more. Notifications/Alerts can be sent to any mobile device
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65 %patch3 -p1
66 %patch4 -p1
67 %patch5 -p1
68 %patch6 -p1
69 %patch7 -p1
70
71 APPVERSION="%{version}"
72 echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
73 echo '#define APPHASH "%{snap}"' >> appversion.h
74 APPDATE=$(date --date="%{date}" "+%s")
75 echo "#define APPDATE ${APPDATE}" >> appversion.h
76
77 %{__rm} -r extern tinyxpath
78
79 %build
80 install -d build && cd build
81 %cmake \
82         -DUSE_BUILTIN_JSONCPP=NO \
83         -DUSE_BUILTIN_MINIZIP=NO \
84         -DUSE_BUILTIN_MQTT=NO \
85         -DUSE_BUILTIN_SQLITE=NO \
86         -DUSE_BUILTIN_TINYXPATH=NO \
87         -DUSE_LUA_STATIC=NO \
88         -DUSE_OPENSSL_STATIC=NO \
89         -DUSE_STATIC_BOOST=NO \
90         -DUSE_STATIC_LIBSTDCXX=NO \
91         -DUSE_STATIC_OPENZWAVE=NO \
92         -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
93         ..
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -C build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
104
105 # remove docs, we grab them in files below
106 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
107
108 # move binary to standard directory
109 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
110
111 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
112 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
113
114 # Unbundle DroidSans.ttf
115 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
116 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
117         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
118 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
119         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
120 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
121         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
122 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
123         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
124 ln -s %{_fontsdir}/TTF/DroidSans.ttf \
125         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
126 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
127         $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
128
129 # OpenZWave Control Panel temp file
130 ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
131         $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %pre
137 %groupadd -g 342 domoticz
138 %useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout,i2c -g domoticz domoticz
139
140 %post
141 %systemd_post %{name}.service
142
143 %preun
144 %systemd_preun %{name}.service
145
146 %postun
147 if [ "$1" = "0" ]; then
148         %userremove mpd
149         %groupremove mpd
150 fi
151 %systemd_reload
152
153 %files
154 %defattr(644,root,root,755)
155 %doc License.txt README.md History.txt
156 %attr(755,root,root) %{_bindir}/%{name}
157 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
158 %{_datadir}/%{name}
159 %dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
160 %{systemdunitdir}/%{name}.service
This page took 0.043507 seconds and 4 git commands to generate.