]> git.pld-linux.org Git - packages/docker-compose.git/blob - docker-compose.spec
Release 4 (by relup.sh)
[packages/docker-compose.git] / docker-compose.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module          compose
6 %define         egg_name        docker_compose
7 %define         pypi_name       docker-compose
8 Summary:        Multi-container orchestration for Docker
9 Name:           docker-compose
10 Version:        1.29.2
11 Release:        4
12 License:        Apache v2.0
13 Group:          Applications/System
14 # https://github.com/docker/compose/releases
15 Source0:        https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  95accbca655abf086a61b94d6c3d94ca
17 Patch0:         remove-requires-upper-bound.patch
18 URL:            https://docs.docker.com/compose/
19 %if %{with tests}
20 BuildRequires:  python3-PyYAML
21 BuildRequires:  python3-docker
22 BuildRequires:  python3-docopt
23 BuildRequires:  python3-paramiko
24 BuildRequires:  python3-requests
25 BuildRequires:  python3-setuptools
26 BuildRequires:  python3-texttable
27 BuildRequires:  python3-websocket-client
28 %endif
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 Requires:       docker(engine) >= 1.10.0
32 Requires:       python3-docker >= 4.4.4
33 Requires:       python3-paramiko >= 2.4.2
34 Requires:       python3-setuptools
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Multi-container orchestration for Docker
40
41 Docker-compose allows you to:
42 - Define your application's environment with Docker so it can be
43   reproduced anywhere.
44 - Define the services that make up your app so they can be run
45   together in an isolated environment.
46 - Run 'docker-compose up', and docker-compose will start and run your
47   entire app.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52
53 rm -r docker_compose.egg-info
54
55 %build
56 %py3_build
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %py3_install
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc CHANGELOG.md CONTRIBUTING.md README.md SWARM.md LICENSE
68 %attr(755,root,root) %{_bindir}/%{name}
69 %{py3_sitescriptdir}/%{module}
70 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.134907 seconds and 4 git commands to generate.