]> git.pld-linux.org Git - packages/dislocker.git/blob - dislocker.spec
- explicit LIB_INSTALL_DIR (required for x32 builds)
[packages/dislocker.git] / dislocker.spec
1 #
2 # Conditional build:
3 %bcond_without  ruby    # Ruby binding in library, dislocker-find utility
4
5 Summary:        Read BitLocker encrypted volumes under Linux
6 Summary(pl.UTF-8):      Odczyt wolumenów szyfrowanych BitLockerem spod Linuksa
7 Name:           dislocker
8 Version:        0.7.1
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/File
12 #Source0Download: https://github.com/Aorimn/dislocker/releases
13 Source0:        https://github.com/Aorimn/dislocker/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  df1454a1631d6c171d2d01610f83b344
15 URL:            https://github.com/Aorimn/dislocker
16 BuildRequires:  cmake >= 2.6
17 BuildRequires:  libfuse-devel
18 BuildRequires:  mbedtls-devel
19 %{?with_ruby:BuildRequires:     ruby-devel >= 1:1.8}
20 BuildRequires:  rpmbuild(macros) >= 1.605
21 BuildRequires:  sed >= 4.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This software has been designed to read BitLocker encrypted partitions
26 under a Linux system. The driver has the capability to read/write on:
27 - Windows Vista, 7, 8, 8.1 and 10 encrypted partitions - that's
28   AES-CBC, AES-XTS, 128 or 256 bits, with or without the Elephant
29   diffuser, encrypted partitions;
30 - BitLocker-To-Go encrypted partitions - that's USB/FAT32 partitions.
31
32 %description -l pl.UTF-8
33 To oprogramowanie powstało w celu odczytu spod systemu Linux partycji
34 zaszyfrowanych BitLockerem. Sterownik potrafi czytać i zapisywać na
35 partycjach szyfrowanych:
36 - Windows Vista, 7, 8, 8.1 oraz 10 - czyli AES-CBC, AES-XTS, 128 lub 256
37   bitów, z lub bez dyfuzora Elephant
38 - BitLocker-To-Go, czyli USB/FAT32
39
40 %package fuse
41 Summary:        Read/write BitLocker encrypted volumes under Linux
42 Summary(pl.UTF-8):      Odczyt/zapis wolumenów szyfrowanych BitLockerem spod Linuksa
43 Group:          Applications/File
44 Requires:       %{name} = %{version}-%{release}
45
46 %description fuse
47 FUSE driver to mount BitLocker volume and create a virtual NTFS
48 partition, which can be mounted as any other NTFS partition.
49
50 %description fuse -l pl.UTF-8
51 Sterownik FUSE do montowania wolumenów BitLockera i tworzenia
52 wirtualnych partycji NTFS, które można zamontować tak, jak inne
53 partycje NTFS.
54
55 %prep
56 %setup -q
57
58 %{__sed} -i -e '1s,/usr/bin/env ruby,/usr/bin/ruby,' src/dislocker-find.rb.in
59
60 %build
61 install -d build
62 cd build
63 %cmake .. \
64         -DLIB_INSTALL_DIR=%{_libdir} \
65         %{!?with_ruby:-DRUBY_OLD_VERSION=ON}
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 # workaround race during recompression/symlink conversion
76 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/dislocker.1.gz
77 echo '.so dislocker-fuse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/dislocker.1
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc CHANGELOG.md README.md
88 %attr(755,root,root) %{_bindir}/dislocker-bek
89 %attr(755,root,root) %{_bindir}/dislocker-file
90 %attr(755,root,root) %{_bindir}/dislocker-metadata
91 %attr(755,root,root) %{_libdir}/libdislocker.so.*.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libdislocker.so.0.7
93 # symlink required for ruby
94 %attr(755,root,root) %{_libdir}/libdislocker.so
95 %{_mandir}/man1/dislocker-file.1*
96 %if %{with ruby}
97 %attr(755,root,root) %{_bindir}/dislocker-find
98 %{_mandir}/man1/dislocker-find.1*
99 %endif
100
101 %files fuse
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/dislocker
104 %attr(755,root,root) %{_bindir}/dislocker-fuse
105 %{_mandir}/man1/dislocker.1*
106 %{_mandir}/man1/dislocker-fuse.1*
This page took 0.077891 seconds and 3 git commands to generate.