]> git.pld-linux.org Git - packages/dico.git/blob - dico.spec
Release 5 (by relup.sh)
[packages/dico.git] / dico.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        GNU Dico - flexible implementation of DICT server
6 Summary(pl.UTF-8):      GNU Dico - elastyczna implementacja serwera DICT
7 Name:           dico
8 Version:        2.11
9 Release:        5
10 License:        GPL v3+
11 Group:          Applications/Text
12 Source0:        https://ftp.gnu.org/gnu/dico/%{name}-%{version}.tar.xz
13 # Source0-md5:  f55fe3917abeb6fd74eccd3b0327d0d7
14 Patch0:         %{name}-nolibs.patch
15 Patch1:         %{name}-info.patch
16 URL:            http://www.gnu.org/software/dico/
17 BuildRequires:  WordNet-devel
18 BuildRequires:  autoconf >= 2.64
19 BuildRequires:  automake >= 1:1.15
20 BuildRequires:  gettext-tools >= 0.19
21 BuildRequires:  gsasl-devel >= 0.2.5
22 BuildRequires:  guile-devel >= 5:2.2.0
23 BuildRequires:  libltdl-devel >= 2:2.4
24 BuildRequires:  libtool >= 2:2.4
25 BuildRequires:  ncurses-devel
26 BuildRequires:  openldap-devel
27 BuildRequires:  pam-devel
28 BuildRequires:  pcre-devel
29 BuildRequires:  python3-devel >= 1:3.2
30 BuildRequires:  readline-devel
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  texinfo
33 BuildRequires:  xz
34 BuildRequires:  zlib-devel
35 Requires:       %{name}-libs = %{version}-%{release}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Dico is a flexible implementation of DICT server (RFC 2229). The
40 server is modular: the daemon itself (dicod) provides only the server
41 functionality, and knows nothing about database formats. Actual
42 searches are performed by functions supplied in loadable modules. A
43 single module can handle any number of database instances. 
44
45 The package includes several modules for searching in different
46 dictionary databases, such as dict.org, WordNet and others.
47
48 %description -l pl.UTF-8
49 Dico do elastyczna implementacja serwera DICT (RFC 2229). Serwer jest
50 modularny - sam demon (dicod) zapewnia jedynie funkcjonalność serwera,
51 natomiast nie zna żadnego formatu bazy danych. Właściwe wyszukiwanie
52 jest wykonywane przez funkcje dostarczane w ładowanych modułach.
53 Pojedynczy moduł może obsłużyć dowolną liczbę instancji bazy danych.
54
55 Pakiet zawiera kilka modułów do wyszukiwania w różnych bazach danych
56 słowników, takich jak dict.org, WordNet i inne.
57
58 %package libs
59 Summary:        GNU Dico shared library
60 Summary(pl.UTF-8):      Biblioteka współdzielona GNU Dico
61 Group:          Libraries
62
63 %description libs
64 GNU Dico shared library.
65
66 %description libs -l pl.UTF-8
67 Biblioteka współdzielona GNU Dico.
68
69 %package devel
70 Summary:        Header files for GNU Dico library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU Dico
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74
75 %description devel
76 Header files for GNU Dico library.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe biblioteki GNU Dico.
80
81 %package static
82 Summary:        Static GNU Dico library
83 Summary(pl.UTF-8):      Statyczna biblioteka GNU Dico
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Statices for GNU Dico library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka GNU Dico.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97
98 %build
99 %{__libtoolize}
100 %{__aclocal} -I m4 -I am -I grecs/am -I gint -I imprimatur
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         WISH=/usr/bin/wish \
106         --disable-silent-rules \
107         %{!?with_static_libs:--disable-static}
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdico.la \
117         $RPM_BUILD_ROOT%{_libdir}/dico/*.la
118 %if %{with static_libs}
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/dico/*.a
120 %endif
121
122 %find_lang %{name}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/postshell
128 -/usr/sbin/fix-info-dir -c %{_infodir}
129
130 %postun -p /sbin/postshell
131 -/usr/sbin/fix-info-dir -c %{_infodir}
132
133 %post   libs -p /sbin/ldconfig
134 %postun libs -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog* NEWS README THANKS TODO
139 %attr(755,root,root) %{_bindir}/dico
140 %attr(755,root,root) %{_bindir}/dicod
141 %attr(755,root,root) %{_bindir}/gcider
142 %attr(755,root,root) %{_libexecdir}/idxgcide
143 %dir %{_libdir}/dico
144 %attr(755,root,root) %{_libdir}/dico/dictorg.so
145 %attr(755,root,root) %{_libdir}/dico/echo.so
146 %attr(755,root,root) %{_libdir}/dico/gcide.so
147 %attr(755,root,root) %{_libdir}/dico/guile.so
148 %attr(755,root,root) %{_libdir}/dico/ldap.so
149 %attr(755,root,root) %{_libdir}/dico/metaphone2.so
150 %attr(755,root,root) %{_libdir}/dico/nprefix.so
151 %attr(755,root,root) %{_libdir}/dico/outline.so
152 %attr(755,root,root) %{_libdir}/dico/pam.so
153 %attr(755,root,root) %{_libdir}/dico/pcre.so
154 %attr(755,root,root) %{_libdir}/dico/python.so
155 %attr(755,root,root) %{_libdir}/dico/stratall.so
156 %attr(755,root,root) %{_libdir}/dico/substr.so
157 %attr(755,root,root) %{_libdir}/dico/word.so
158 %attr(755,root,root) %{_libdir}/dico/wordnet.so
159 %{_datadir}/dico
160 %{_infodir}/dico.info*
161 %{_mandir}/man1/dico.1*
162 %{_mandir}/man5/dicod.conf.5*
163 %{_mandir}/man8/dicod.8*
164
165 %files libs -f %{name}.lang
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libdico.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libdico.so.2
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libdico.so
173 %{_includedir}/dico
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libdico.a
179 %endif
This page took 0.300398 seconds and 4 git commands to generate.