]> git.pld-linux.org Git - packages/diamond.git/commitdiff
Comments and not used macros removed.
authorMateusz Korniak <matkor@pld-linux.org>
Wed, 2 Dec 2015 21:51:08 +0000 (22:51 +0100)
committerMateusz Korniak <matkor@pld-linux.org>
Wed, 2 Dec 2015 21:51:08 +0000 (22:51 +0100)
diamond.spec

index b736469d22a73f1dc5307bf029cee25e2aba4c0a..6a13c1dcd760bd7f2e053b3e01bbe87b56f5a4ad 100644 (file)
@@ -1,8 +1,4 @@
-# Conditional build:
-# %bcond_with  doc     # don't build doc
-# %bcond_with  tests   # do not perform "make test"
-%bcond_without python2 # CPython 2.x module
-# %bcond_with  python3 # CPython 3.x module
+%bcond_with    tests   # do not perform "make test"
 
 %define        module  diamond
 Summary:       Python daemon that collects system metrics and publishes them to Graphite (and others).
@@ -10,7 +6,7 @@ Summary(pl.UTF-8):     Demon napisany w Pythonie, zbierajÄ…cy statystyki i publikuj
 # Name must match the python module/package name (as in 'import' statement)
 Name:          diamond
 Version:       4.0.195
-Release:       0.6
+Release:       1
 License:       MIT
 Group:         Libraries/Python
 # https://github.com/python-diamond/Diamond/archive/v4.0.tar.gz
@@ -26,17 +22,7 @@ URL:         https://github.com/python-diamond/Diamond
 BuildRequires: rpm-pythonprov
 # for the py_build, py_install macros
 BuildRequires: rpmbuild(macros) >= 1.710
-%if %{with python2}
 BuildRequires: python-modules
-#BuildRequires:        python-setuptools
-%endif
-# %if %{with python3}
-# #BuildRequires:      python3-setuptools
-# BuildRequires:       python3-modules
-# %endif
-# when using /usr/bin/env or other in-place substitutions
-#BuildRequires:        sed >= 4.0
-# replace with other requires if defined in setup.py
 Requires:      python-configobj >= 5.0.6
 Requires:      python-modules
 Suggests:      python-setproctitle
@@ -67,50 +53,24 @@ Zbieracz statystyk dla bazdy danych Postgresql
 %prep
 %setup -q -n %{module}-%{version}
 
-# fix #!%{_bindir}/env python -> #!%{_bindir}/python:
-#%{__sed} -i -e '1s,^#!.*python,#!%{__python},' %{name}.py
-
 %build
-%if %{with python2}
 %py_build %{?with_tests:test}
-%endif
-
-# %if %{with python3}
-# %%py3_build %{?with_tests:test}
-# %endif
-
-# %if %{with doc}
-# cd docs
-# %{__make} -j1 html
-# rm -rf _build/html/_sources
-# %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with python2}
 %py_install
 %py_postclean
-%endif
-# %if %{with python3}
-# %%py3_install
-# %endif
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{module}
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{module}/collectors
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{module}/handlers
 ## install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{module}/configs
 install -p %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/%{module}/diamond.conf
-
 install -d $RPM_BUILD_ROOT%{_localstatedir}/log/%{module}
-# install -d $RPM_BUILD_ROOT%{_localstatedir}/run/carbon
-# install -d $RPM_BUILD_ROOT%{_sharedstatedir}/carbon
-
 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/diamond
-
 install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/%{module}/collectors
 
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -120,24 +80,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/chkconfig --add diamond
-## %systemd_post diamond.service 
 
 %preun
 if [ "$1" = "0" ]; then
        %service diamond stop
        /sbin/chkconfig --del diamond
 fi
-%systemd_preun diamond.service
 
 %postun
 if [ "$1" = "0" ]; then
        %userremove diamond
        %groupremove diamond
 fi
-%systemd_reload
 
-
-%if %{with python2}
 %files
 %defattr(644,root,root,755)
 %doc README.md LICENSE
@@ -148,7 +103,6 @@ fi
 %attr(755,root,root) %{_bindir}/diamond
 %attr(755,root,root) %{_bindir}/diamond-setup
 %{py_sitescriptdir}/%{module}
-# %{py_sitescriptdir}/%{module}/collectors
 %{_datadir}/diamond/
 %attr(750,diamond,diamond) /var/log/diamond
 %attr(754,root,root) /etc/rc.d/init.d/diamond
@@ -156,22 +110,6 @@ fi
 %if "%{py_ver}" > "2.4"
 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
 %endif
-%endif
-
-# %if %{with python3}
-# %files -n python3-%{module}
-# %defattr(644,root,root,755)
-# %doc AUTHORS CHANGES LICENSE
-# %{py3_sitescriptdir}/%{module}
-# %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
-# %{_examplesdir}/python3-%{module}-%{version}
-# %endif
-#
-# %if %{with doc}
-# %files apidocs
-# %defattr(644,root,root,755)
-# %doc docs/_build/html/*
-# %endif
 
 %files -n %{module}-collector-postgresql
 %defattr(644,root,root,755)
This page took 0.168786 seconds and 4 git commands to generate.