]> git.pld-linux.org Git - packages/dehydrated.git/blame - dehydrated.spec
update config dir to be dehydrated
[packages/dehydrated.git] / dehydrated.spec
CommitLineData
1780cc1f 1Summary: letsencrypt/acme client implemented as a shell-script
0b9f695c
ER
2Name: dehydrated
3Version: 0.3.1
4Release: 0.1
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
0b9f695c
ER
7Source0: https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: 7a3b92b963da6469c4a53f051d6efa24
eb6aa75d
ER
9Source1: apache.conf
10Source2: lighttpd.conf
3c33d40b 11Source3: config.sh
8f670f9f 12Source4: domains.txt
5765eca7 13Source5: hook.sh
a0535a11 14Source6: crontab
f5fc6721 15Patch0: pld.patch
0b9f695c 16URL: https://github.com/lukas2511/dehydrated
1780cc1f 17BuildRequires: rpmbuild(macros) >= 1.713
a0535a11 18Requires: crondaemon
1780cc1f
ER
19Requires: curl
20Requires: grep
21Requires: mktemp
60120665 22Requires: openssl-tools
1780cc1f 23Requires: sed
eb6aa75d 24Requires: webapps
9f9f4d8c
ER
25Suggests: webserver(access)
26Suggests: webserver(alias)
0b9f695c
ER
27Provides: letsencrypt.sh = %{version}
28Obsoletes: letsencrypt.sh < 0.3
1780cc1f
ER
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
eb6aa75d
ER
32%define _webapps /etc/webapps
33%define _webapp %{name}
34%define _sysconfdir %{_webapps}/%{_webapp}
35%define _appdir %{_datadir}/%{_webapp}
2e509387 36%define challengedir /var/lib/%{name}
eb6aa75d 37
1780cc1f
ER
38%description
39This is a client for signing certificates with an ACME-server
40(currently only provided by letsencrypt) implemented as a relatively
41simple bash-script.
42
43Current features:
44- Signing of a list of domains
45- Signing of a CSR
46- Renewal if a certificate is about to expire or SAN (subdomains)
47 changed
48- Certificate revocation
49
50%prep
51%setup -q
f5fc6721 52%patch0 -p1
1780cc1f
ER
53
54%install
55rm -rf $RPM_BUILD_ROOT
2e509387 56install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/cron.d,%{challengedir}}
eb6aa75d 57
0b9f695c 58install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
eb6aa75d
ER
59cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
60cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
3c33d40b 61cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
8f670f9f 62cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
0b9f695c 63cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/%{name}
5765eca7 64install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 65cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
eb6aa75d
ER
70%triggerin -- apache1 < 1.3.37-3, apache1-base
71%webapp_register apache %{_webapp}
72
73%triggerun -- apache1 < 1.3.37-3, apache1-base
74%webapp_unregister apache %{_webapp}
75
76%triggerin -- apache < 2.2.0, apache-base
77%webapp_register httpd %{_webapp}
78
79%triggerun -- apache < 2.2.0, apache-base
80%webapp_unregister httpd %{_webapp}
81
82%triggerin -- lighttpd
83%webapp_register lighttpd %{_webapp}
84
85%triggerun -- lighttpd
86%webapp_unregister lighttpd %{_webapp}
87
1780cc1f
ER
88%files
89%defattr(644,root,root,755)
90%doc README.md CHANGELOG LICENSE
0b9f695c 91%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
7410a329 92%dir %attr(750,root,http) %{_sysconfdir}
a113aaf6 93%dir %attr(700,root,root) %{_sysconfdir}/certs
eb6aa75d
ER
94%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
95%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
96%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
3c33d40b 97%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
8f670f9f 98%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 99%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
0b9f695c 100%attr(755,root,root) %{_sbindir}/%{name}
2e509387
ER
101# challenges written here, need to be readable by webserver
102%dir %attr(751,root,root) %{challengedir}
This page took 0.77513 seconds and 4 git commands to generate.