]> git.pld-linux.org Git - packages/dehydrated.git/blame - letsencrypt.sh.spec
own certs dir
[packages/dehydrated.git] / letsencrypt.sh.spec
CommitLineData
1780cc1f
ER
1Summary: letsencrypt/acme client implemented as a shell-script
2Name: letsencrypt.sh
3Version: 0.1.0
a113aaf6 4Release: 0.7
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
7Source0: https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
eb6aa75d
ER
8# Source0-md5: eadd134cc5365753c03929dd70db341d
9Source1: apache.conf
10Source2: lighttpd.conf
3c33d40b 11Source3: config.sh
8f670f9f 12Source4: domains.txt
f5fc6721 13Patch0: pld.patch
1780cc1f
ER
14URL: https://github.com/lukas2511/letsencrypt.sh
15BuildRequires: rpmbuild(macros) >= 1.713
16Requires: curl
17Requires: grep
18Requires: mktemp
19Requires: openssl
20Requires: sed
eb6aa75d
ER
21Requires: webapps
22Requires: webserver(access)
23Requires: webserver(alias)
1780cc1f
ER
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
eb6aa75d
ER
27%define _webapps /etc/webapps
28%define _webapp %{name}
29%define _sysconfdir %{_webapps}/%{_webapp}
30%define _appdir %{_datadir}/%{_webapp}
31
1780cc1f
ER
32%description
33This is a client for signing certificates with an ACME-server
34(currently only provided by letsencrypt) implemented as a relatively
35simple bash-script.
36
37Current features:
38- Signing of a list of domains
39- Signing of a CSR
40- Renewal if a certificate is about to expire or SAN (subdomains)
41 changed
42- Certificate revocation
43
44%prep
45%setup -q
f5fc6721 46%patch0 -p1
1780cc1f
ER
47
48%install
49rm -rf $RPM_BUILD_ROOT
a113aaf6 50install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{acme-challenges,certs}}
eb6aa75d
ER
51
52install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
53
54cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
55cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
3c33d40b 56cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
8f670f9f 57cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 58cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
eb6aa75d
ER
63%triggerin -- apache1 < 1.3.37-3, apache1-base
64%webapp_register apache %{_webapp}
65
66%triggerun -- apache1 < 1.3.37-3, apache1-base
67%webapp_unregister apache %{_webapp}
68
69%triggerin -- apache < 2.2.0, apache-base
70%webapp_register httpd %{_webapp}
71
72%triggerun -- apache < 2.2.0, apache-base
73%webapp_unregister httpd %{_webapp}
74
75%triggerin -- lighttpd
76%webapp_register lighttpd %{_webapp}
77
78%triggerun -- lighttpd
79%webapp_unregister lighttpd %{_webapp}
80
1780cc1f
ER
81%files
82%defattr(644,root,root,755)
83%doc README.md CHANGELOG LICENSE
7410a329 84%dir %attr(750,root,http) %{_sysconfdir}
a113aaf6 85%dir %attr(700,root,root) %{_sysconfdir}/certs
eb6aa75d
ER
86%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
87%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
88%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
3c33d40b 89%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
8f670f9f 90%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
eb6aa75d
ER
91# challenges written here from letsencrypt.sh, need to be readable by webserver
92%dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
7410a329
ER
93
94%attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.121481 seconds and 4 git commands to generate.