]> git.pld-linux.org Git - packages/daemon.git/blob - daemon.spec
97bf54edd74c31a4e074021169eb22ac54863735
[packages/daemon.git] / daemon.spec
1 #
2 # Conditional build
3 %bcond_without  systemd # systemd-logind support
4 %bcond_with     elogind # elogind support
5
6 Summary:        Daemon turns other process into daemons
7 Summary(pl.UTF-8):      Daemon - zamiana innych procesów w demony
8 Name:           daemon
9 Version:        0.8.4
10 Release:        1
11 License:        GPL v2
12 Group:          Daemons
13 #Source0Download: https://libslack.org/daemon/#download
14 Source0:        https://libslack.org/daemon/download/%{name}-%{version}.tar.gz
15 # Source0-md5:  871ff0cc66b1eafbb17965b5ec164509
16 URL:            https://libslack.org/daemon/
17 %{?with_elogind:BuildRequires:  elogind-devel}
18 BuildRequires:  perl-tools-pod
19 %{?with_systemd:BuildRequires:  systemd-devel >= 1:209}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Daemon turns other process into daemons. There are many tasks that
24 need to be performed to correctly set up a daemon process. This can be
25 tedious. Daemon performs these tasks for other processes.
26
27 %description -l pl.UTF-8
28 Daemon zamienia inne procesy w demony. Jest wiele zadań, które trzeba
29 wykonać, aby poprawnie uruchomić demona. Może to być męczące. Daemon
30 wykonuje te zadania dla innych procesów.
31
32 %prep
33 %setup -q
34
35 %build
36 # not autoconf configure
37 CC="%{__cc}" \
38 ./configure \
39         --destdir=$RPM_BUILD_ROOT \
40         --prefix=%{_prefix} \
41 %if %{with elogind} || %{with systemd}
42         --enable-logind \
43 %endif
44         --disable-mail-test
45
46 %{__make} \
47         CC="%{__cc}" \
48         CCFLAGS="%{rpmcflags} -Wall -pedantic" \
49         APP_INSDIR="%{_sbindir}"
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         APP_INSDIR=%{_sbindir} \
56         MAN_GZIP=0
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc CHANGELOG README.md REFERENCES
64 %attr(755,root,root) %{_sbindir}/daemon
65 %{_mandir}/man1/daemon.1*
66 %{_mandir}/man5/daemon.conf.5*
This page took 0.048458 seconds and 2 git commands to generate.