]> git.pld-linux.org Git - packages/cups.git/commitdiff
- rel 4 auto/th/cups-1_5_0-4
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 5 Aug 2011 19:59:04 +0000 (19:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix client authentication, empty auth -> try again, and ignore HTML
  content in server response

Changed files:
    cups-auth.patch -> 1.1
    cups.spec -> 1.305

cups-auth.patch [new file with mode: 0644]
cups.spec

diff --git a/cups-auth.patch b/cups-auth.patch
new file mode 100644 (file)
index 0000000..1db4d0a
--- /dev/null
@@ -0,0 +1,43 @@
+diff -ur cups-1.5.0/cups/auth.c cups-1.5.0-auth/cups/auth.c
+--- cups-1.5.0/cups/auth.c     2011-05-20 20:22:33.000000000 +0200
++++ cups-1.5.0-auth/cups/auth.c        2011-08-05 19:39:19.587496832 +0200
+@@ -276,8 +278,7 @@
+   {
+     DEBUG_printf(("1cupsDoAuthentication: Unknown auth type: \"%s\"",
+                   http->fields[HTTP_FIELD_WWW_AUTHENTICATE]));
+-    http->status = HTTP_AUTHORIZATION_CANCELED;
+-    return (-1);
++    return (1);
+   }
+   DEBUG_printf(("1cupsDoAuthentication: authstring=\"%s\"", http->authstring));
+diff -ur cups-1.5.0/cups/request.c cups-1.5.0-auth/cups/request.c
+--- cups-1.5.0/cups/request.c  2011-05-20 05:49:49.000000000 +0200
++++ cups-1.5.0-auth/cups/request.c     2011-08-05 19:40:37.981496819 +0200
+@@ -396,7 +396,7 @@
+   {
+     status = httpUpdate(http);
+   }
+-  while (status != HTTP_ERROR && http->state == HTTP_POST_RECV);
++  while (http->state == HTTP_POST_RECV);
+   DEBUG_printf(("2cupsGetResponse: status=%d", status));
+@@ -448,7 +449,7 @@
+       DEBUG_puts("2cupsGetResponse: Need authorization...");
+-      if (!cupsDoAuthentication(http, "POST", resource))
++      if (cupsDoAuthentication(http, "POST", resource) >= 0)
+         httpReconnect(http);
+       else
+         status = HTTP_AUTHORIZATION_CANCELED;
+@@ -780,7 +781,7 @@
+           return (status);
+       case HTTP_UNAUTHORIZED :
+-          if (cupsDoAuthentication(http, "POST", resource))
++          if (cupsDoAuthentication(http, "POST", resource) < 0)
+           return (HTTP_AUTHORIZATION_CANCELED);
+         if (httpReconnect(http))
index 1f0edc244dbc3db0a328e3a676acba13c569a19c..61eb33a5e8acc2bda9d26f9abd918fe408ed0672 100644 (file)
--- a/cups.spec
+++ b/cups.spec
@@ -17,7 +17,7 @@ Summary(pl.UTF-8):    Ogólny system druku dla Uniksa
 Summary(pt_BR.UTF-8):  Sistema Unix de Impressão
 Name:          cups
 Version:       1.5.0
-Release:       3
+Release:       4
 Epoch:         1
 License:       LGPL v2 (libraries), GPL v2 (the rest) + openssl exception
 Group:         Applications/Printing
@@ -43,6 +43,7 @@ Patch10:      %{name}-peercred.patch
 Patch11:       %{name}-usb.patch
 Patch12:       %{name}-desktop.patch
 Patch13:       %{name}-ssl-segfault.patch
+Patch14:       %{name}-auth.patch
 URL:           http://www.cups.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf >= 2.60
@@ -313,6 +314,7 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
 #%patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 
 %build
 %{__aclocal} -I config-scripts
This page took 0.119047 seconds and 4 git commands to generate.