]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blob - crossmingw32-fontconfig.spec
- updated to 2.12.4
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
1 %define         realname   fontconfig
2 Summary:        Font configuration and customization tools - cross MinGW32 versoin
3 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.12.4
6 Release:        1
7 License:        MIT
8 Group:          Development/Libraries
9 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  29105662c7d319720e0088a0ac53f494
11 Patch0:         %{realname}-bitstream-cyberbit.patch
12 URL:            http://fontconfig.org/
13 BuildRequires:  autoconf >= 2.61
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  crossmingw32-expat
16 BuildRequires:  crossmingw32-freetype >= 2.1.5
17 BuildRequires:  crossmingw32-gcc
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  pkgconfig >= 1:0.15
20 BuildRequires:  sed >= 4.0
21 Requires:       crossmingw32-expat
22 Requires:       crossmingw32-freetype >= 2.1.5
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38 %define         __pkgconfig_requires    %{nil}
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker, most of -f options are Linux-specific
45 %define         filterout_ld    -Wl,-z,.*
46 %define         filterout_c     -f[-a-z0-9=]*
47
48 %description
49 Fontconfig is designed to locate fonts within the system and select
50 them according to requirements specified by applications.
51
52 This package contains the cross version for Win32.
53
54 %description -l pl.UTF-8
55 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
56 systemie i wybierania ich w zależności od potrzeb aplikacji.
57
58 Paket ten zawiera wersję skrośną dla Win32.
59
60 %package static
61 Summary:        Static freetype library (cross MinGW32 version)
62 Summary(pl.UTF-8):      Statyczna biblioteka freetype (wersja skrośna MinGW32)
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description static
67 Static freetype library (cross MinGW32 version).
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka freetype (wersja skrośna MinGW32).
71
72 %package dll
73 Summary:        DLL freetype library for Windows
74 Summary(pl.UTF-8):      Biblioteka DLL freetype dla Windows
75 Group:          Applications/Emulators
76 Requires:       crossmingw32-expat-dll
77 Requires:       crossmingw32-freetype-dll >= 2.1.5
78 Requires:       wine
79
80 %description dll
81 DLL freetype library for Windows.
82
83 %description dll -l pl.UTF-8
84 Biblioteka DLL freetype dla Windows.
85
86 %prep
87 %setup -q -n %{realname}-%{version}
88 %patch0 -p1
89
90 # uses POSIX-specific dirent interfaces
91 %{__sed} -i -e 's/test-migration//' test/Makefile.am
92
93 %build
94 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
95 %{__libtoolize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --target=%{target} \
102         --host=%{target} \
103         --with-arch=%{target} \
104         --with-freetype-config="pkg-config freetype2" \
105         --disable-docs \
106         --disable-silent-rules \
107         --enable-static
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 # fc_cachedir=/dummy is to avoid creating ${DESTDIR}LOCAL_APPDATA_FONTCONFIG_CACHE dir
115 %{__make} -j1 install \
116         DESTDIR=$RPM_BUILD_ROOT \
117         fc_cachedir=/dummy
118
119 install -d $RPM_BUILD_ROOT%{_dlldir}
120 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122 %if 0%{!?debug:1}
123 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
124 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125 %endif
126
127 # runtime
128 %{__rm} -r $RPM_BUILD_ROOT/etc/fonts \
129         $RPM_BUILD_ROOT%{_datadir}/{fontconfig,xml/fontconfig}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS COPYING ChangeLog README
137 %{_libdir}/libfontconfig.dll.a
138 %{_libdir}/libfontconfig.la
139 %{_libdir}/fontconfig.def
140 %dir %{_includedir}/fontconfig
141 %{_includedir}/fontconfig/*.h
142 %{_pkgconfigdir}/fontconfig.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libfontconfig.a
147
148 %files dll
149 %defattr(644,root,root,755)
150 %{_dlldir}/libfontconfig-*.dll
This page took 0.06819 seconds and 3 git commands to generate.