]> git.pld-linux.org Git - packages/crossmingw32-bzip2.git/blob - crossmingw32-bzip2.spec
- updated to 1.0.5 (fixes CVE-2005-1260 CVE-2008-1372)
[packages/crossmingw32-bzip2.git] / crossmingw32-bzip2.spec
1 %define         realname                bzip2
2 Summary:        Extremely powerful file compression utility - Ming32 cross version
3 Summary(es.UTF-8):      Un compresor de archivos con un nuevo algoritmo
4 Summary(fr.UTF-8):      Utilitaire de compression de fichier extrêmement puissant
5 Summary(pl.UTF-8):      Kompresor plików bzip2 - wersja skrośna dla Ming32
6 Summary(pt_BR.UTF-8):   Compactador de arquivo extremamente poderoso
7 Summary(uk.UTF-8):      Компресор файлів на базі алгоритму блочного сортування
8 Summary(ru.UTF-8):      Компрессор файлов на основе алгоритма блочной сортировки
9 Name:           crossmingw32-%{realname}
10 Version:        1.0.5
11 Release:        1
12 License:        BSD-like
13 Group:          Applications/Archiving
14 Source0:        http://www.bzip.org/%{version}/%{realname}-%{version}.tar.gz
15 # Source0-md5:  3c15a0c8d1d3ee1c46a1634d00617b1a
16 Patch0:         %{name}.patch
17 URL:            http://www.bzip.org/
18 BuildRequires:  crossmingw32-gcc
19 Requires:       crossmingw32-runtime
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         no_install_post_strip   1
23
24 %define         target                  i386-mingw32
25 %define         target_platform         i386-pc-mingw32
26
27 %define         _sysprefix              /usr
28 %define         _prefix                 %{_sysprefix}/%{target}
29 %define         _libdir                 %{_prefix}/lib
30 %define         _dlldir                 /usr/share/wine/windows/system
31 %define         __cc                    %{target}-gcc
32 %define         __cxx                   %{target}-g++
33
34 %ifnarch %{ix86}
35 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
36 %define         optflags        -O2
37 %endif
38
39 %description
40 Bzip2 compresses files using the Burrows-Wheeler block-sorting text
41 compression algorithm, and Huffman coding. Compression is generally
42 considerably better than that achieved by more conventional
43 LZ77/LZ78-based compressors, and approaches the performance of the PPM
44 family of statistical compressors. The command-line options are
45 deliberately very similar to those of GNU Gzip, but they are not
46 identical.
47
48 %description -l es.UTF-8
49 Bzip2 es un programa de compresión/descompresión. Típicamente el
50 archivo compactado queda entre 20 la 30 por ciento menor de que se
51 fuera compactado con gzip. Observa que bzip2 no entiende los archivos
52 del bzip original, ni los archivos del gzip.
53
54 %description -l fr.UTF-8
55 Bzip2 compresse des fichiers en utilisant l'algorithme de compression
56 en tri de blocks de texte Burrows-Wheeler, et le codage Huffman. La
57 compression est considérablement meilleure que celle effectuée par les
58 plus conventionels compresseurs basés sur LZ77/LZ78, et approche la
59 performance de la famille PPM de compresseurs statistiques.
60
61 %description -l pl.UTF-8
62 Kompresor bzip2 używa algorytmu Burrows-Wheelera do kompresji danych i
63 metody Huffmana do ich kodowania. Kompresja pliku czy archiwum tar
64 jest z reguły lepsza niż w przypadku stosowania klasycznych
65 kompresorów LZ77/LZ78. Opcje linii poleceń są bardzo podobne do
66 poleceń GNU Gzip ale nie są identyczne.
67
68 %description -l pt_BR.UTF-8
69 Bzip2 é um programa de compressão/descompressão. Tipicamente o arquivo
70 compactado fica 20 a 30 por cento menor do que se fosse compactado com
71 o gzip.
72
73 Note que o bzip2 não entende os arquivos do bzip original, nem os
74 arquivos do gzip.
75
76 %description -l ru.UTF-8
77 bzip2 компрессирует файлы используя компрессирующий текстовый алгоритм
78 блочной сортировки Burrows-Wheeler и кодирование Huffman'а.
79 Достигаемая компрессия обычно существенно лучше достигаемой более
80 привычными компрессорами на основе LZ77/LZ78 и приближается к той,
81 которую обеспечивает семейство статистических компрессоров PPM.
82
83 %description -l uk.UTF-8
84 bzip2 компресує файли використовуючи текстовий алгоритм блочного
85 сортування Burrows-Wheeler та кодування Huffman'а. Компресія, яка
86 досягається bzip2, як правило краща за ту, що забезпечують
87 розповсюджені компресори на базі LZ77/LZ78 і наближається до тої, що
88 її забезпечує сімейство статистичних компресорів PPM.
89
90 %package static
91 Summary:        Static bzip2 library (cross mingw32 version)
92 Summary(pl.UTF-8):      Statyczna biblioteka bzip2 (wersja skrośna mingw32)
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95
96 %description static
97 Static bzip2 library (cross mingw32 version).
98
99 %description static -l pl.UTF-8
100 Statyczna biblioteka bzip2 (wersja skrośna mingw32).
101
102 %package dll
103 Summary:        %{realname} - DLL library for Windows
104 Summary(pl.UTF-8):      %{realname} - biblioteka DLL dla Windows
105 Group:          Applications/Emulators
106
107 %description dll
108 %{realname} - DLL library for Windows.
109
110 %description dll -l pl.UTF-8
111 %{realname} - biblioteka DLL dla Windows.
112
113 %prep
114 %setup -q -n %{realname}-%{version}
115 %patch0 -p1
116
117 %build
118 AR=%{target}-ar
119 RANLIB=%{target}-ranlib
120
121 %{__make} \
122         AR="$AR" \
123         RANLIB="$RANLIB" \
124         CC="%{__cc}" \
125         CFLAGS="%{rpmcflags} -Wall \$(BIGFILES)"
126
127 rm -f libbz2.a libbz2.dll
128
129 $AR cru libbzip2.a blocksort.o huffman.o crctable.o randtable.o compress.o decompress.o bzlib.o
130 $RANLIB libbzip2.a
131
132 %{__cc} --shared libbzip2.a blocksort.o huffman.o crctable.o randtable.o compress.o decompress.o bzlib.o -Wl,--enable-auto-image-base -o bzip2.dll -Wl,--out-implib,libbzip2.dll.a
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir}}
137
138 install *.h $RPM_BUILD_ROOT%{_includedir}
139 install *.a $RPM_BUILD_ROOT%{_libdir}
140 install *.dll $RPM_BUILD_ROOT%{_dlldir}
141
142 %if 0%{!?debug:1}
143 %{target}-strip $RPM_BUILD_ROOT%{_dlldir}/*.dll
144 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
145 %endif
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %{_libdir}/libbzip2.dll.a
153 %{_includedir}/bzlib*.h
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libbzip2.a
158
159 %files dll
160 %defattr(644,root,root,755)
161 %{_dlldir}/bzip2.dll
This page took 0.089761 seconds and 4 git commands to generate.