]> git.pld-linux.org Git - packages/crossmingw32-bzip2.git/blob - crossmingw32-bzip2.spec
- filter out some compiler and linker flags
[packages/crossmingw32-bzip2.git] / crossmingw32-bzip2.spec
1 %define         realname                bzip2
2 Summary:        Extremely powerful file compression utility - MinGW32 cross version
3 Summary(es.UTF-8):      Un compresor de archivos con un nuevo algoritmo
4 Summary(fr.UTF-8):      Utilitaire de compression de fichier extrêmement puissant
5 Summary(pl.UTF-8):      Kompresor plików bzip2 - wersja skrośna dla MinGW32
6 Summary(pt_BR.UTF-8):   Compactador de arquivo extremamente poderoso
7 Summary(uk.UTF-8):      Компресор файлів на базі алгоритму блочного сортування
8 Summary(ru.UTF-8):      Компрессор файлов на основе алгоритма блочной сортировки
9 Name:           crossmingw32-%{realname}
10 Version:        1.0.6
11 Release:        1
12 License:        BSD-like
13 Group:          Applications/Archiving
14 Source0:        http://www.bzip.org/%{version}/%{realname}-%{version}.tar.gz
15 # Source0-md5:  00b516f4704d4a7cb50a1d97e6e8e15b
16 Patch0:         %{name}.patch
17 URL:            http://www.bzip.org/
18 BuildRequires:  crossmingw32-gcc
19 Requires:       crossmingw32-runtime
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         no_install_post_strip   1
23
24 %define         target                  i386-mingw32
25 %define         target_platform         i386-pc-mingw32
26
27 %define         _sysprefix              /usr
28 %define         _prefix                 %{_sysprefix}/%{target}
29 %define         _libdir                 %{_prefix}/lib
30 %define         _dlldir                 /usr/share/wine/windows/system
31 %define         __cc                    %{target}-gcc
32 %define         __cxx                   %{target}-g++
33 %define         filterout_ld    -Wl,-z,.*
34 %define         filterout_c     -gdwarf-3
35
36 %ifnarch %{ix86}
37 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
38 %define         optflags        -O2
39 %endif
40
41 %description
42 Bzip2 compresses files using the Burrows-Wheeler block-sorting text
43 compression algorithm, and Huffman coding. Compression is generally
44 considerably better than that achieved by more conventional
45 LZ77/LZ78-based compressors, and approaches the performance of the PPM
46 family of statistical compressors. The command-line options are
47 deliberately very similar to those of GNU Gzip, but they are not
48 identical.
49
50 %description -l es.UTF-8
51 Bzip2 es un programa de compresión/descompresión. Típicamente el
52 archivo compactado queda entre 20 la 30 por ciento menor de que se
53 fuera compactado con gzip. Observa que bzip2 no entiende los archivos
54 del bzip original, ni los archivos del gzip.
55
56 %description -l fr.UTF-8
57 Bzip2 compresse des fichiers en utilisant l'algorithme de compression
58 en tri de blocks de texte Burrows-Wheeler, et le codage Huffman. La
59 compression est considérablement meilleure que celle effectuée par les
60 plus conventionels compresseurs basés sur LZ77/LZ78, et approche la
61 performance de la famille PPM de compresseurs statistiques.
62
63 %description -l pl.UTF-8
64 Kompresor bzip2 używa algorytmu Burrows-Wheelera do kompresji danych i
65 metody Huffmana do ich kodowania. Kompresja pliku czy archiwum tar
66 jest z reguły lepsza niż w przypadku stosowania klasycznych
67 kompresorów LZ77/LZ78. Opcje linii poleceń są bardzo podobne do
68 poleceń GNU Gzip ale nie są identyczne.
69
70 %description -l pt_BR.UTF-8
71 Bzip2 é um programa de compressão/descompressão. Tipicamente o arquivo
72 compactado fica 20 a 30 por cento menor do que se fosse compactado com
73 o gzip.
74
75 Note que o bzip2 não entende os arquivos do bzip original, nem os
76 arquivos do gzip.
77
78 %description -l ru.UTF-8
79 bzip2 компрессирует файлы используя компрессирующий текстовый алгоритм
80 блочной сортировки Burrows-Wheeler и кодирование Huffman'а.
81 Достигаемая компрессия обычно существенно лучше достигаемой более
82 привычными компрессорами на основе LZ77/LZ78 и приближается к той,
83 которую обеспечивает семейство статистических компрессоров PPM.
84
85 %description -l uk.UTF-8
86 bzip2 компресує файли використовуючи текстовий алгоритм блочного
87 сортування Burrows-Wheeler та кодування Huffman'а. Компресія, яка
88 досягається bzip2, як правило краща за ту, що забезпечують
89 розповсюджені компресори на базі LZ77/LZ78 і наближається до тої, що
90 її забезпечує сімейство статистичних компресорів PPM.
91
92 %package static
93 Summary:        Static bzip2 library (cross MinGW32 version)
94 Summary(pl.UTF-8):      Statyczna biblioteka bzip2 (wersja skrośna MinGW32)
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97
98 %description static
99 Static bzip2 library (cross MinGW32 version).
100
101 %description static -l pl.UTF-8
102 Statyczna biblioteka bzip2 (wersja skrośna MinGW32).
103
104 %package dll
105 Summary:        %{realname} - DLL library for Windows
106 Summary(pl.UTF-8):      %{realname} - biblioteka DLL dla Windows
107 Group:          Applications/Emulators
108
109 %description dll
110 %{realname} - DLL library for Windows.
111
112 %description dll -l pl.UTF-8
113 %{realname} - biblioteka DLL dla Windows.
114
115 %prep
116 %setup -q -n %{realname}-%{version}
117 %patch0 -p1
118
119 %build
120 AR=%{target}-ar
121 RANLIB=%{target}-ranlib
122
123 %{__make} \
124         AR="$AR" \
125         RANLIB="$RANLIB" \
126         CC="%{__cc}" \
127         CFLAGS="%{rpmcflags} -Wall \$(BIGFILES)"
128
129 rm -f libbz2.a libbz2.dll
130
131 $AR cru libbzip2.a blocksort.o huffman.o crctable.o randtable.o compress.o decompress.o bzlib.o
132 $RANLIB libbzip2.a
133
134 %{__cc} --shared libbzip2.a blocksort.o huffman.o crctable.o randtable.o compress.o decompress.o bzlib.o -Wl,--enable-auto-image-base -o bzip2.dll -Wl,--out-implib,libbzip2.dll.a
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir}}
139
140 install *.h $RPM_BUILD_ROOT%{_includedir}
141 install *.a $RPM_BUILD_ROOT%{_libdir}
142 install *.dll $RPM_BUILD_ROOT%{_dlldir}
143
144 %if 0%{!?debug:1}
145 %{target}-strip $RPM_BUILD_ROOT%{_dlldir}/*.dll
146 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
147 %endif
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %defattr(644,root,root,755)
154 %{_libdir}/libbzip2.dll.a
155 %{_includedir}/bzlib*.h
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libbzip2.a
160
161 %files dll
162 %defattr(644,root,root,755)
163 %{_dlldir}/bzip2.dll
This page took 0.042297 seconds and 4 git commands to generate.