]> git.pld-linux.org Git - packages/cronie.git/commitdiff
- add support for -m and -s options via sysconfig; rel 3 auto/th/cronie-1_4_4-3
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 2 Mar 2010 21:27:57 +0000 (21:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cron.sysconfig -> 1.2
    cronie.init -> 1.6
    cronie.spec -> 1.28

cron.sysconfig
cronie.init
cronie.spec

index 7c4eeae1617369c569f479304aba9a39bb761c7c..af6bff777d2bdd7428e5f1fdfb3a1549c8219937 100644 (file)
@@ -1,4 +1,19 @@
-# Customized settings for cron
+# Customized settings for cronie crond
 
-# Define nice level for cron
+# Define nice level for crond
 SERVICE_RUN_NICE_LEVEL="+0"
+
+# This option will direct cron to send job output to the system log using syslog(3).
+# This is useful if your system has no sendmail(8), or if mail is disabled using "off".
+#CROND_SYSLOG_RESULT="yes"
+
+# This option allows you to specify a shell command string to use
+# for sending cron mail output instead of sendmail(8).
+# This command must accept a fully formatted mail message (with headers) on
+# stdin and send it as a mail message to the recipients specified in the mail
+# headers.
+# As a special case, the string "off" will disable sending mail.
+#CROND_MAIL_PROG="sendmail"
+
+# Extra arguments to crond(8)
+#CROND_ARGS=""
index 56c2de506237e57988c0380efcfe6f3354531c00..f86537bac61fdddcc61802df4462d82fc6c21334 100644 (file)
@@ -16,6 +16,8 @@
 # Source function library.
 . /etc/rc.d/init.d/functions
 
+CROND_ARGS=""
+
 # Get service config
 [ -f /etc/sysconfig/cron ] && . /etc/sysconfig/cron
 
@@ -26,8 +28,17 @@ start() {
                return
        fi
 
+       if is_yes "$CROND_SYSLOG_RESULT"; then
+               CROND_ARGS="$CROND_ARGS -s"
+       fi
+
+       if [ -n "$CROND_MAIL_PROG" ]; then
+               # XXX: should we handle spaces in $CROND_MAIL_PROG?
+               CROND_ARGS="$CROND_ARGS -m $CROND_MAIL_PROG"
+       fi
+
        msg_starting "cronie crond"
-       daemon /usr/sbin/crond
+       daemon /usr/sbin/crond $CROND_ARGS
        RETVAL=$?
        [ $RETVAL -eq 0 ] && touch /var/lock/subsys/crond
 }
index 67aa53a8e2de9db1cc960c148e6f2ca7efccccff..485a77074f601377c3af3adc056af09c04aa5563 100644 (file)
@@ -15,7 +15,7 @@
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
 Version:       1.4.4
-Release:       2
+Release:       3
 License:       MIT and BSD and GPL v2
 Group:         Daemons
 Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
This page took 0.039679 seconds and 4 git commands to generate.