]> git.pld-linux.org Git - packages/crda.git/blob - crda.spec
upstream patch to fix build
[packages/crda.git] / crda.spec
1 #
2 # Conditional build:
3 %bcond_with     verify  # database verification
4 %bcond_without  verbose # verbose build (V=1)
5
6 Summary:        udev helper: Central Regulatory Domain Agent
7 Summary(pl.UTF-8):      Program pomocniczy udev: Central Regulatory Domain Agent
8 Name:           crda
9 Version:        3.18
10 Release:        2
11 License:        ISC
12 Group:          Networking/Daemons
13 Source0:        https://www.kernel.org/pub/software/network/crda/%{name}-%{version}.tar.xz
14 # Source0-md5:  0431fef3067bf503dfb464069f06163a
15 Patch0:         %{name}-regdb.patch
16 Patch1:         %{name}-destdir.patch
17 Patch2:         %{name}-link.patch
18 Patch3:         build.patch
19 URL:            http://wireless.kernel.org/en/developers/Regulatory/CRDA
20 BuildRequires:  libgcrypt-devel
21 BuildRequires:  libnl-devel >= 1:3.2
22 BuildRequires:  pkgconfig
23 BuildRequires:  python
24 BuildRequires:  python-M2Crypto
25 BuildRequires:  python-modules
26 %{?with_verify:BuildRequires:   wireless-regdb}
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       %{name}-libs = %{version}-%{release}
30 Requires:       udev-core
31 Requires:       wireless-regdb
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 CRDA acts as the udev helper for communication between the kernel and
36 userspace for wireless regulatory compliance. It relies on nl80211 for
37 communication. CRDA is intended to be run only through udev
38 communication from the kernel. The user should never have to run it
39 manually except if debugging udev issues.
40
41 %description -l pl.UTF-8
42 CRDA działa jako program pomocniczy udev do komunikacji między jądrem
43 a przestrzenią użytkownika w celu zgodności łączności bezprzewodowej z
44 przepisami. Na potrzeby komunikacji polega na nl80211. CRDA jest
45 przeznaczone do uruchamiania wyłącznie poprzez udev. Użytkownik nigdy
46 nie powinien wywoływać go ręcznie, chyba że w celach diagnostyki udev.
47
48 %package libs
49 Summary:        CRDA libreg shared library
50 Summary(pl.UTF-8):      Biblioteka współdzielona CRDA libreg
51 Group:          Libraries
52
53 %description libs
54 CRDA libreg shared library.
55
56 %description libs -l pl.UTF-8
57 Biblioteka współdzielona CRDA libreg.
58
59 %package devel
60 Summary:        Header files for CRDA libreg library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CRDA libreg
62 Group:          Development/Libraries
63 Requires:       %{name}-libs = %{version}-%{release}
64
65 %description devel
66 Header files for CRDA libreg library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki CRDA libreg.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77
78 %build
79 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
80 %{__make} \
81         CC="%{__cc}" \
82         %{?with_verbose:V=1} \
83 %if %{with verify}
84         REG_BIN=%{_datadir}/crda/regulatory.bin \
85 %else
86         all_noverify \
87 %endif
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} install \
92         %{?with_verbose:V=1} \
93         DESTDIR=$RPM_BUILD_ROOT \
94         LIBDIR=/%{_lib}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   libs -p /sbin/ldconfig
100 %postun libs -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc LICENSE README
105 %attr(755,root,root) /sbin/crda
106 %attr(755,root,root) /sbin/regdbdump
107 %{_mandir}/man8/crda.8*
108 %{_mandir}/man8/regdbdump.8*
109 /lib/udev/rules.d/85-regulatory.rules
110
111 %files libs
112 %defattr(644,root,root,755)
113 %attr(755,root,root) /%{_lib}/libreg.so
114
115 %files devel
116 %defattr(644,root,root,755)
117 %{_includedir}/reglib
This page took 0.056938 seconds and 4 git commands to generate.