]> git.pld-linux.org Git - packages/crash.git/commitdiff
- added x32 patch (builds now, not tested otherwise) auto/th/crash-7.1.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Oct 2015 13:12:51 +0000 (15:12 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Oct 2015 13:12:51 +0000 (15:12 +0200)
crash-x32.patch [new file with mode: 0644]
crash.spec

diff --git a/crash-x32.patch b/crash-x32.patch
new file mode 100644 (file)
index 0000000..d44731d
--- /dev/null
@@ -0,0 +1,70 @@
+--- crash-7.1.3/unwind_x86_64.h.orig   2015-09-02 21:38:32.000000000 +0200
++++ crash-7.1.3/unwind_x86_64.h        2015-10-24 14:57:49.632888183 +0200
+@@ -10,10 +10,14 @@
+  * GNU General Public License for more details.
+  */
++#ifdef __LP64__
+ #define CONFIG_64BIT 1
++typedef unsigned long size_t;
++#else
++typedef unsigned int size_t;
++#endif
+ #define NULL ((void *)0)
+-typedef unsigned long size_t;
+ typedef unsigned char u8;
+ typedef signed short s16;
+ typedef unsigned short u16;
+@@ -22,30 +26,30 @@
+ typedef unsigned long long u64;
+ struct pt_regs {
+-        unsigned long r15;
+-        unsigned long r14;
+-        unsigned long r13;
+-        unsigned long r12;
+-        unsigned long rbp;
+-        unsigned long rbx;
++        u64 r15;
++        u64 r14;
++        u64 r13;
++        u64 r12;
++        u64 rbp;
++        u64 rbx;
+ /* arguments: non interrupts/non tracing syscalls only save upto here*/
+-        unsigned long r11;
+-        unsigned long r10;
+-        unsigned long r9;
+-        unsigned long r8;
+-        unsigned long rax;
+-        unsigned long rcx;
+-        unsigned long rdx;
+-        unsigned long rsi;
+-        unsigned long rdi;
+-        unsigned long orig_rax;
++        u64 r11;
++        u64 r10;
++        u64 r9;
++        u64 r8;
++        u64 rax;
++        u64 rcx;
++        u64 rdx;
++        u64 rsi;
++        u64 rdi;
++        u64 orig_rax;
+ /* end of arguments */
+ /* cpu exception frame or undefined */
+-        unsigned long rip;
+-        unsigned long cs;
+-        unsigned long eflags;
+-        unsigned long rsp;
+-        unsigned long ss;
++        u64 rip;
++        u64 cs;
++        u64 eflags;
++        u64 rsp;
++        u64 ss;
+ /* top of stack page */
+ };
index 061cd1deb103d5daf2df8e0e718db5e806c1dc87..49b1b9a37b08fa2d985abe2e0fbfd18675bd22fa 100644 (file)
@@ -34,6 +34,7 @@ Source0:      http://people.redhat.com/anderson/%{pname}-%{version}.tar.gz
 # git clone https://code.google.com/p/eppic
 Source1:       eppic.tar.xz
 # Source1-md5: a9f80ad71de9d6f5b77534a7ebdbed8e
+Patch0:                %{name}-x32.patch
 URL:           http://people.redhat.com/anderson/
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -43,7 +44,7 @@ BuildRequires:        readline-devel
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %endif
-ExclusiveArch: %{ix86} %{x8664} alpha arm ia64 ppc64 s390 s390x
+ExclusiveArch: %{ix86} %{x8664} x32 alpha arm ia64 ppc64 s390 s390x
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -113,6 +114,7 @@ Ten pakiet zawiera sterownik pamiÄ™ci /dev/crash do sesji crash na\
 
 %prep
 %setup -q -a1 -n %{pname}-%{version}
+%patch0 -p1
 
 %{__mv} eppic extensions
 
This page took 0.064985 seconds and 4 git commands to generate.