]> git.pld-linux.org Git - packages/cppzmq.git/blob - cppzmq.spec
- disable tests (need Catch2, downloaded if not present); release 2
[packages/cppzmq.git] / cppzmq.spec
1 Summary:        CPP-ZMQ library
2 Summary(pl.UTF-8):      Biblioteka CPP-ZMQ
3 Name:           cppzmq
4 Version:        4.9.0
5 Release:        2
6 License:        MIT
7 Group:          Development/Libraries
8 #Source0Download: https://github.com/zeromq/cppzmq/releases
9 Source0:        https://github.com/zeromq/cppzmq/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  80f3400f5d6cc48cee0fe1a045d78718
11 URL:            https://github.com/zeromq/cppzmq
12 # Catch2 for tests
13 BuildRequires:  cmake >= 3.11
14 BuildRequires:  pkgconfig
15 BuildRequires:  zeromq-devel >= 4
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 CPP-ZMQ is the C++ interface for 0MQ library.
21
22 %description -l pl.UTF-8
23 CPP-ZMQ to interfejs C++ do biblioteki ØMQ.
24
25 %package devel
26 Summary:        CPP-ZMQ header files
27 Summary(pl.UTF-8):      Pliki nagłówkowe CPP-ZMQ
28 Group:          Development/Libraries
29 Requires:       zeromq-devel >= 4
30
31 %description devel
32 Header files which constitute CPP-ZMQ library.
33
34 CPP-ZMQ is the C++ interface for 0MQ library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe stanowiące bibliotekę CPP-ZMQ.
38
39 CPP-ZMQ to interfejs C++ do biblioteki ØMQ.
40
41 %prep
42 %setup -q
43
44 %build
45 install -d build
46 cd build
47 %cmake .. \
48         -DCPPZMQ_BUILD_TESTS=OFF
49
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} -C build install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 # use arch-independent pkg-config dir, so package can be noarch
59 install -d $RPM_BUILD_ROOT%{_npkgconfigdir}
60 %{__mv} $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc $RPM_BUILD_ROOT%{_npkgconfigdir}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files devel
66 %defattr(644,root,root,755)
67 %doc LICENSE README.md
68 %{_includedir}/zmq.hpp
69 %{_includedir}/zmq_addon.hpp
70 %{_npkgconfigdir}/cppzmq.pc
71 %{_datadir}/cmake/cppzmq
This page took 0.129815 seconds and 4 git commands to generate.