]> git.pld-linux.org Git - packages/conky.git/commitdiff
- up to 1.8.1 auto/th/conky-1_8_1-1
authorlisu <lisu@pld-linux.org>
Wed, 13 Oct 2010 07:50:03 +0000 (07:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- drop obsolete -ncurses.patch
- add -I/usr/include/ncurses to CFLAGS
- link with -ltinfo

Changed files:
    conky-ncurses.patch -> 1.2
    conky.spec -> 1.32

conky-ncurses.patch
conky.spec

index 599a73c5a7ff36eed7986bc7a49dfd7d13ed0c46..a1658cbb675834f4bd165ae048046aa170882ac9 100644 (file)
@@ -1,119 +1,3 @@
-diff -burNp conky-1.8.0/configure.ac.in conky-1.8.0-dud/configure.ac.in
---- conky-1.8.0/configure.ac.in        2010-03-30 19:47:30.000000000 +0200
-+++ conky-1.8.0-dud/configure.ac.in    2010-04-08 22:13:46.056130555 +0200
-@@ -1011,6 +1011,7 @@ dnl  OpenMP:           $want_openmp
-   ALSA mixer:       $want_alsa
-   apcupsd:          $want_apcupsd
-   I/O stats:        $want_iostats
-+  ncurses:          $want_ncurses
-  * Lua ($want_lua) bindings:
-   Cairo:            $want_lua_cairo
-diff -burNp conky-1.8.0/src/conky.c conky-1.8.0-dud/src/conky.c
---- conky-1.8.0/src/conky.c    2010-03-25 21:27:32.000000000 +0100
-+++ conky-1.8.0-dud/src/conky.c        2010-04-08 22:25:15.789443783 +0200
-@@ -3119,36 +3119,48 @@ int draw_each_line_inner(char *s, int sp
-                                               if (seconds != 0) {
-                                                       timeunits = seconds / 86400; seconds %= 86400;
-                                                       if (timeunits > 0) {
--                                                              asprintf(&tmp_day_str, "%dd", timeunits);
-+                                                              if (asprintf(&tmp_day_str, "%dd", timeunits) < 0) {
-+                                                                      tmp_day_str = 0;
-+                                                              }
-                                                       } else {
-                                                               tmp_day_str = strdup("");
-                                                       }
-                                                       timeunits = seconds / 3600; seconds %= 3600;
-                                                       if (timeunits > 0) {
--                                                              asprintf(&tmp_hour_str, "%dh", timeunits);
-+                                                              if (asprintf(&tmp_hour_str, "%dh", timeunits) < 0) {
-+                                                                      tmp_day_str = 0;
-+                                                              }       
-                                                       } else {
-                                                               tmp_hour_str = strdup("");
-                                                       }
-                                                       timeunits = seconds / 60; seconds %= 60;
-                                                       if (timeunits > 0) {
--                                                              asprintf(&tmp_min_str, "%dm", timeunits);
-+                                                              if (asprintf(&tmp_min_str, "%dm", timeunits) < 0) {
-+                                                                      tmp_min_str = 0;
-+                                                              }
-                                                       } else {
-                                                               tmp_min_str = strdup("");
-                                                       }
-                                                       if (seconds > 0) {
--                                                              asprintf(&tmp_sec_str, "%ds", seconds);
-+                                                              if (asprintf(&tmp_sec_str, "%ds", seconds) < 0) {
-+                                                                      tmp_sec_str = 0;
-+                                                              }
-                                                       } else {
-                                                               tmp_sec_str = strdup("");
-                                                       }
--                                                      asprintf(&tmp_str, "%s%s%s%s", tmp_day_str, tmp_hour_str, tmp_min_str, tmp_sec_str);
--                                                      free(tmp_day_str); free(tmp_hour_str); free(tmp_min_str); free(tmp_sec_str);
-+                                                      if (asprintf(&tmp_str, "%s%s%s%s", tmp_day_str, tmp_hour_str, tmp_min_str, tmp_sec_str) < 0) {
-+                                                              tmp_str = 0;
-+                                                      }
-+#define FREE(a) if ((a)) free((a));
-+                                                      FREE(tmp_day_str); FREE(tmp_hour_str); FREE(tmp_min_str); FREE(tmp_sec_str);
-                                               } else {
--                                                      asprintf(&tmp_str, "Range not possible"); // should never happen, but better safe then sorry
-+                                                      tmp_str = strdup("Range not possible"); /* should never happen, but better safe then sorry */
-                                               }
-                                               cur_x += (w / 2) - (font_ascent() * (strlen(tmp_str) / 2));
-                                               cur_y += font_h / 2;
-                                               draw_string(tmp_str);
--                                              free(tmp_str);
-+                                              FREE(tmp_str);
-+#undef FREE
-                                               cur_x = tmp_x;
-                                               cur_y = tmp_y;
-                                       }
-@@ -4518,13 +4530,13 @@ void setalignment(int* ltext_alignment,
-               int a = string_to_alignment(value);
-               if (a <= 0) {
--                      if(setbyconffile == true) {
-+                      if (setbyconffile) {
-                               CONF_ERR;
-                       } else NORM_ERR("'%s' is not a alignment setting", value);
-               } else {
-                       *ltext_alignment = a;
-               }
--      } else if(setbyconffile == true) {
-+      } else if (setbyconffile) {
-               CONF_ERR;
-       }
- }
-@@ -4573,7 +4585,7 @@ char load_config_file(const char *f)
-                       }
-               }
-               CONF("alignment") {
--                      setalignment(&text_alignment, window.type, value, f, line, true);
-+                      setalignment(&text_alignment, window.type, value, f, line, 1);
-               }
-               CONF("background") {
-                       fork_to_background = string_to_bool(value);
-@@ -5696,7 +5708,7 @@ void initialisation(int argc, char **arg
-                               set_first_font(optarg);
-                               break;
-                       case 'a':
--                              setalignment(&text_alignment, window.type, optarg, NULL, 0, false);
-+                              setalignment(&text_alignment, window.type, optarg, NULL, 0, 0);
-                               break;
- #ifdef OWN_WINDOW
-@@ -5895,7 +5907,9 @@ int main(int argc, char **argv)
-                               current_config = strndup(optarg, max_user_text);
-                               break;
-                       case 'q':
--                              freopen("/dev/null", "w", stderr);
-+                              if (!freopen("/dev/null", "w", stderr)) {
-+                                      NORM_ERR("unable to redirect stderr to /dev/null");
-+                              }
-                               break;
-                       case 'h':
-                               print_help(argv[0]);
 diff -burNp conky-1.8.0/src/conky.c conky-1.8.0-dud/src/conky.c
 --- conky-1.8.0/src/conky.c    2010-03-25 21:27:32.000000000 +0100
 +++ conky-1.8.0-dud/src/conky.c        2010-04-08 22:30:40.745051008 +0200
index 647ed8c4515dac383461b19e432085cd16fd1912..5c97b9eebb32db3e10dbbd32d43cf29f3f2fc79f 100644 (file)
@@ -1,13 +1,12 @@
 Summary:       A light-weight system monitor
 Summary(pl.UTF-8):     Monitor systemu dla środowiska graficznego
 Name:          conky
-Version:       1.8.0
+Version:       1.8.1
 Release:       1
 License:       Distributable (see COPYING doc)
 Group:         X11/Applications
-Source0:       http://dl.sourceforge.net/conky/%{name}-%{version}.tar.bz2
-# Source0-md5: 494cbaf1108cfdb977fc80454d9b13e2
-Patch0:                %{name}-ncurses.patch
+Source0:       http://downloads.sourceforge.net/conky/%{name}-%{version}.tar.bz2
+# Source0-md5: 366dc6a5c2ebebfbe6f53da25061b5d6
 URL:           http://conky.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -32,15 +31,14 @@ from i2c, MPD info, and anything else you desire) to the root window
 in X11.
 
 %description -l pl.UTF-8
-Conky jest niewielkim monitorem systemu opartym na kodzie torsmo.
-Może wyświetlać takie informacje, jak:
+Conky jest niewielkim monitorem systemu opartym na kodzie torsmo. Może
+wyświetlać takie informacje, jak:
 - data
 - temperatura CPU
 - ilość miejsca na dysku itp.
 
 %prep
 %setup -q
-%patch0 -p1
 %{__sed} -i 's,lua5.1,lua51,' configure.ac
 
 %build
@@ -49,7 +47,9 @@ Może wyświetlać takie informacje, jak:
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-%configure
+%configure \
+       CFLAGS="`pkg-config ncurses --cflags`" \
+       LIBS="-ltinfo"
 %{__make}
 
 %install
@@ -68,5 +68,5 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_sysconfdir}/conky
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}_no_x11.conf
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/%{name}
 %{_mandir}/man1/%{name}.1*
This page took 0.091386 seconds and 4 git commands to generate.