]> git.pld-linux.org Git - packages/composer.git/commitdiff
cleanup unneeded patches
authorElan Ruusamäe <glen@delfi.ee>
Wed, 25 Nov 2015 22:16:38 +0000 (00:16 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 25 Nov 2015 22:16:38 +0000 (00:16 +0200)
autoload-config.patch [deleted file]
composer.spec
no-vendors.patch [deleted file]
nogit.patch [deleted file]

diff --git a/autoload-config.patch b/autoload-config.patch
deleted file mode 100644 (file)
index bab02ee..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- composer-1.0.0-14.alpha11/vendor/composer/autoload_namespaces.php~ 2015-11-25 18:29:26.000000000 +0200
-+++ composer-1.0.0-14.alpha11/vendor/composer/autoload_namespaces.php  2015-11-25 18:29:59.220529712 +0200
-@@ -4,6 +4,16 @@
- $vendorDir = dirname(dirname(__FILE__));
- $baseDir = dirname($vendorDir);
-+$pearDir = defined('PEAR_INSTALL_DIR') && PEAR_INSTALL_DIR ? PEAR_INSTALL_DIR . '/' : '/usr/share/pear/';
-+$phpDir = defined('PHP_DATADIR') && PHP_DATADIR ? PHP_DATADIR . '/php/' : '/usr/share/php/';
- return array(
-+    'Symfony\\Component\\Process\\' => array($pearDir),
-+    'Symfony\\Component\\Finder' => array($pearDir),
-+    'Symfony\\Component\\Console\\' => array($pearDir),
-+    'Composer\\Spdx\\' => array($phpDir),
-+    'Composer\\Semver\\' => array($phpDir),
-+    'Seld\\JsonLint' => array($phpDir),
-+    'Seld\\PharUtils\\' => array($phpDir),
-+    'JsonSchema' => array($phpDir),
- );
index f05c6af7d8ec980bb69e1e9e742110f174a6a107..94f74aa5244ead79ad41d6488518f97bc62b4ecb 100644 (file)
@@ -20,12 +20,9 @@ Source0:     https://github.com/composer/composer/archive/%{version}-%{subver}/%{nam
 Source2:       https://raw.githubusercontent.com/iArren/%{name}-bash-completion/86a8129/composer
 # Source2-md5: cdeebf0a0da1fd07d0fd886d0461642e
 Source3:       autoload.php
-Patch0:                nogit.patch
-Patch1:                no-vendors.patch
-Patch2:                autoload-config.patch
-Patch3:                update-memory-limit.patch
-Patch4:                svn-ignore-externals.patch
-Patch10:       autoload.patch
+Patch0:                autoload.patch
+Patch1:                update-memory-limit.patch
+Patch2:                svn-ignore-externals.patch
 URL:           http://www.getcomposer.org/
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.673
@@ -81,7 +78,9 @@ Pakiet ten dostarcza bashowe uzupełnianie nazw dla Composera.
 %prep
 %setup -qc -n %{name}-%{version}-%{release}
 mv composer-*/* .
-%patch10 -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 mv composer.lock{,.disabled}
 # NOTE: do not use %{__php} macro here, need unversioned php binary
diff --git a/no-vendors.patch b/no-vendors.patch
deleted file mode 100644 (file)
index 2118c89..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
---- composer-1.0.0-14.alpha11/src/Composer/Compiler.php~       2015-11-25 17:43:47.000000000 +0200
-+++ composer-1.0.0-14.alpha11/src/Composer/Compiler.php        2015-11-25 17:44:50.973366000 +0200
-@@ -104,28 +104,6 @@
-         foreach ($finder as $file) {
-             $this->addFile($phar, $file, false);
-         }
--        $this->addFile($phar, new \SplFileInfo(__DIR__ . '/../../vendor/seld/cli-prompt/res/hiddeninput.exe'), false);
--
--        $finder = new Finder();
--        $finder->files()
--            ->ignoreVCS(true)
--            ->name('*.php')
--            ->name('LICENSE')
--            ->exclude('Tests')
--            ->exclude('tests')
--            ->exclude('docs')
--            ->in(__DIR__.'/../../vendor/symfony/')
--            ->in(__DIR__.'/../../vendor/seld/jsonlint/')
--            ->in(__DIR__.'/../../vendor/seld/cli-prompt/')
--            ->in(__DIR__.'/../../vendor/justinrainbow/json-schema/')
--            ->in(__DIR__.'/../../vendor/composer/spdx-licenses/')
--            ->in(__DIR__.'/../../vendor/composer/semver/')
--            ->sort($finderSort)
--        ;
--
--        foreach ($finder as $file) {
--            $this->addFile($phar, $file);
--        }
-         $this->addFile($phar, new \SplFileInfo(__DIR__.'/../../vendor/autoload.php'));
-         $this->addFile($phar, new \SplFileInfo(__DIR__.'/../../vendor/composer/autoload_namespaces.php'));
---- composer-1.0.0-14.alpha11/composer.json~   2015-11-14 18:21:07.000000000 +0200
-+++ composer-1.0.0-14.alpha11/composer.json    2015-11-25 17:45:33.515574668 +0200
-@@ -22,17 +22,7 @@
-         "issues": "https://github.com/composer/composer/issues"
-     },
-     "require": {
--        "php": "^5.3.2 || ^7.0",
--        "justinrainbow/json-schema": "^1.4.4",
--        "composer/spdx-licenses": "^1.0",
--        "composer/semver": "^1.0",
--        "seld/jsonlint": "^1.0",
--        "symfony/console": "^2.5 || ^3.0",
--        "symfony/finder": "^2.2 || ^3.0",
--        "symfony/process": "^2.1 || ^3.0",
--        "symfony/filesystem": "^2.5 || ^3.0",
--        "seld/phar-utils": "^1.0",
--        "seld/cli-prompt": "^1.0"
-+        "php": "^5.3.2 || ^7.0"
-     },
-     "require-dev": {
-         "phpunit/phpunit": "^4.5 || ^5.0.5",
diff --git a/nogit.patch b/nogit.patch
deleted file mode 100644 (file)
index 12726d8..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
---- composer-1.0.x-5744981/src/Composer/Compiler.php~  2015-02-18 00:33:55.000000000 +0200
-+++ composer-1.0.x-5744981/src/Composer/Compiler.php   2015-02-18 00:34:38.952650516 +0200
-@@ -40,13 +40,13 @@
-             unlink($pharFile);
-         }
--        $process = new Process('git log --pretty="%H" -n1 HEAD', __DIR__);
-+        $process = new Process('echo $PACKAGE_VERSION', __DIR__);
-         if ($process->run() != 0) {
-             throw new \RuntimeException('Can\'t run git log. You must ensure to run compile from composer git repository clone and that git binary is available.');
-         }
-         $this->version = trim($process->getOutput());
--        $process = new Process('git log -n1 --pretty=%ci HEAD', __DIR__);
-+        $process = new Process('echo $RELEASE_DATE', __DIR__);
-         if ($process->run() != 0) {
-             throw new \RuntimeException('Can\'t run git log. You must ensure to run compile from composer git repository clone and that git binary is available.');
-         }
-@@ -55,7 +55,7 @@
-         $date->setTimezone(new \DateTimeZone('UTC'));
-         $this->versionDate = $date->format('Y-m-d H:i:s');
--        $process = new Process('git describe --tags --exact-match HEAD');
-+        $process = new Process('echo $PACKAGE_VERSION; exit $DEV_VERSION');
-         if ($process->run() == 0) {
-             $this->version = trim($process->getOutput());
-         } else {
---- composer-1.0.0-14.alpha11/bin/compile      2015-11-25 18:32:33.718541181 +0200
-+++ composer-1.0.0-14.alpha11/bin/compile      2015-11-25 19:04:02.596489328 +0200
-@@ -1,20 +1,6 @@
- #!/usr/bin/php
- <?php
--$cwd = getcwd();
--chdir(__DIR__.'/../');
--$ts = rtrim(shell_exec('git log -n1 --pretty=%ct HEAD'));
--if (!is_numeric($ts)) {
--    echo 'Could not detect date using "git log -n1 --pretty=%ct HEAD"'.PHP_EOL;
--    exit(1);
--}
--// Install with the current version to force it having the right ClassLoader version
--// Install without dev packages to clean up the included classmap from phpunit classes
--shell_exec('php bin/composer config autoloader-suffix ComposerPhar' . $ts);
--shell_exec('php bin/composer install -q --no-dev');
--shell_exec('php bin/composer config autoloader-suffix --unset');
--chdir($cwd);
--
- require __DIR__.'/../src/bootstrap.php';
- use Composer\Compiler;
This page took 0.081014 seconds and 4 git commands to generate.