]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
rpm version for noarch subpackage
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 %bcond_without  gdkpixbuf       # gdk-pixbuf for image loading [instead of stb_image]
5 %bcond_without  gles1           # OpenGL-ES 1.1 driver support
6 %bcond_without  gles2           # OpenGL-ES 2.0 driver support
7 %bcond_without  kms             # KMS EGL platform support
8 %bcond_without  gstreamer       # GStreamer support
9 %bcond_with     mir             # Mir EGL platform support (conflicts with wayland)
10 %bcond_with     sdl1            # SDL 1.x winsys support (conflicts with sdl2)
11 %bcond_with     sdl2            # SDL2 winsys support (conflicts with sdl1)
12 %bcond_without  wayland         # Wayland EGL platform and server support
13
14 Summary:        A library for using 3D graphics hardware to draw pretty pictures
15 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
16 Name:           cogl
17 Version:        1.22.8
18 Release:        1
19 License:        LGPL v2+
20 Group:          Libraries
21 Source0:        https://download.gnome.org/sources/cogl/1.22/%{name}-%{version}.tar.xz
22 # Source0-md5:  7dd8b2e24171ef7399f851cea144b569
23 Patch0:         %{name}-link.patch
24 URL:            http://www.clutter-project.org/
25 BuildRequires:  EGL-devel
26 BuildRequires:  Mesa-libEGL-devel
27 %{?with_kms:BuildRequires:      Mesa-libgbm-devel}
28 BuildRequires:  OpenGL-GLX-devel
29 %{?with_gles1:BuildRequires:    OpenGLESv1-devel >= 1.1}
30 %{?with_sdl1:BuildRequires:     SDL-devel >= 1.2}
31 %{?with_sdl2:BuildRequires:     SDL2-devel >= 2}
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake >= 1:1.14
34 BuildRequires:  cairo-devel >= 1.10
35 %{?with_gdkpixbuf:BuildRequires:        gdk-pixbuf2-devel >= 2.0}
36 BuildRequires:  gettext-tools >= 0.19
37 BuildRequires:  glib2-devel >= 1:2.32.0
38 BuildRequires:  gobject-introspection-devel >= 0.9.5
39 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0}
40 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0}
41 BuildRequires:  gtk-doc >= 1.13
42 BuildRequires:  libdrm-devel
43 BuildRequires:  libtool >= 2:2.2.6
44 # pkgconfig(mirclient)
45 %{?with_mir:BuildRequires:      mir-devel >= 0.9.0}
46 BuildRequires:  pango-devel >= 1:1.20
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpm-build >= 4.6
49 BuildRequires:  tar >= 1:1.22
50 # wayland-client >= 1.0.0, wayland-server >= 1.1.90
51 %{?with_wayland:BuildRequires:  wayland-devel >= 1.2.0}
52 %{?with_wayland:BuildRequires:  wayland-egl-devel >= 1.0.0}
53 BuildRequires:  xorg-lib-libX11-devel
54 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
55 BuildRequires:  xorg-lib-libXdamage-devel
56 BuildRequires:  xorg-lib-libXext-devel
57 BuildRequires:  xorg-lib-libXfixes-devel >= 3
58 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
59 BuildRequires:  xz
60 Requires:       cairo >= 1.10
61 Requires:       glib2 >= 1:2.32.0
62 Requires:       pango >= 1:1.20
63 %{?with_wayland:Requires:       wayland >= 1.2.0}
64 Requires:       xorg-lib-libXcomposite >= 0.4
65 Requires:       xorg-lib-libXfixes >= 3
66 Requires:       xorg-lib-libXrandr >= 1.2
67 Suggests:       OpenGL
68 %{?with_gles1:Provides: cogl(gles1) = %{version}-%{release}}
69 %{?with_gles2:Provides: cogl(gles2) = %{version}-%{release}}
70 %{?with_kms:Provides:   cogl(kms) = %{version}-%{release}}
71 %{?with_wayland:Provides:       cogl(wayland) = %{version}-%{release}}
72 Conflicts:      clutter < 1.8.0
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 Cogl is a small open source library for using 3D graphics hardware to
77 draw pretty pictures. The API departs from the flat state machine
78 style of OpenGL and is designed to make it easy to write orthogonal
79 components that can render without stepping on each others toes.
80
81 %description -l pl.UTF-8
82 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
83 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
84 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
85 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
86 przeszkadzania sobie nawzajem.
87
88 %package devel
89 Summary:        Header files for cogl library
90 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93 %{?with_wayland:Requires:       EGL-devel}
94 %{?with_kms:Requires:   Mesa-libgbm-devel}
95 %{?with_wayland:Requires:       wayland-egl-devel >= 1.0.0}
96 Requires:       cairo-devel >= 1.10
97 %{?with_gdkpixbuf:Requires:     gdk-pixbuf2-devel >= 2.0}
98 Requires:       glib2-devel >= 1:2.32.0
99 Requires:       gobject-introspection-devel >= 0.9.5
100 Requires:       libdrm-devel
101 Requires:       pango-devel >= 1:1.20
102 %{?with_wayland:Requires:       wayland-devel >= 1.2.0}
103 Requires:       xorg-lib-libXcomposite-devel >= 0.4
104 Requires:       xorg-lib-libXdamage-devel
105 Requires:       xorg-lib-libXext-devel
106 Requires:       xorg-lib-libXfixes-devel >= 3
107 Requires:       xorg-lib-libXrandr-devel >= 1.2
108 %{?with_gles1:Provides: cogl-devel(gles1) = %{version}-%{release}}
109 %{?with_gles2:Provides: cogl-devel(gles2) = %{version}-%{release}}
110 %{?with_kms:Provides:   cogl-devel(kms) = %{version}-%{release}}
111 %{?with_wayland:Provides:       cogl-devel(wayland) = %{version}-%{release}}
112 Conflicts:      clutter-devel < 1.8.0
113
114 %description devel
115 Header files for building and developing applications with cogl.
116
117 %description devel -l pl.UTF-8
118 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
119
120 %package static
121 Summary:        Static cogl libraries
122 Summary(pl.UTF-8):      Statyczne biblioteki cogl
123 Group:          Development/Libraries
124 Requires:       %{name}-devel = %{version}-%{release}
125 %{?with_gles1:Provides: cogl-static(gles1) = %{version}-%{release}}
126 %{?with_gles2:Provides: cogl-static(gles2) = %{version}-%{release}}
127 %{?with_kms:Provides:   cogl-static(kms) = %{version}-%{release}}
128 %{?with_wayland:Provides:       cogl-static(wayland) = %{version}-%{release}}
129 Conflicts:      clutter-static < 1.8.0
130
131 %description static
132 Static cogl libraries.
133
134 %description static -l pl.UTF-8
135 Statyczne biblioteki cogl.
136
137 %package doc
138 Summary:        API documentation for cogl
139 Summary(pl.UTF-8):      Dokumentacja API cogl
140 Group:          Documentation
141
142 %description doc
143 This package contains API documentation for cogl.
144
145 %description doc -l pl.UTF-8
146 Ten pakiet zawiera dokumentację API cogl.
147
148 %package gles2
149 Summary:        Cogl frontend library for OpenGL-ES 2.0
150 Summary(pl.UTF-8):      Biblioteka frontendowa Cogl dla OpenGL-ES 2.0
151 Group:          Libraries
152 Requires:       %{name}(gles2) = %{version}-%{release}
153
154 %description gles2
155 Cogl frontend library for OpenGL-ES 2.0.
156
157 %description gles2 -l pl.UTF-8
158 Biblioteka frontendowa Cogl dla OpenGL-ES 2.0.
159
160 %package gles2-devel
161 Summary:        Header files for cogl-gles2 library
162 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gles2
163 Group:          Development/Libraries
164 Requires:       %{name}-devel(gles2) = %{version}-%{release}
165 Requires:       %{name}-gles2 = %{version}-%{release}
166
167 %description gles2-devel
168 Header files for cogl-gles2 library.
169
170 %description gles2-devel -l pl.UTF-8
171 Pliki nagłówkowe biblioteki cogl-gles2.
172
173 %package gles2-static
174 Summary:        Static cogl-gles2 library
175 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gles2
176 Group:          Development/Libraries
177 Requires:       %{name}-gles2-devel = %{version}-%{release}
178
179 %description gles2-static
180 Static cogl-gles2 library.
181
182 %description gles2-static -l pl.UTF-8
183 Statyczna biblioteka cogl-gles2.
184
185 %package gst
186 Summary:        GStreamer integration library for Cogl
187 Summary(pl.UTF-8):      Biblioteka integrująca GStreamera z Cogl
188 Group:          Libraries
189 Requires:       %{name} = %{version}-%{release}
190
191 %description gst
192 GStreamer integration library for Cogl.
193
194 %description gst -l pl.UTF-8
195 Biblioteka integrująca GStreamera z Cogl.
196
197 %package gst-devel
198 Summary:        Header files for cogl-gst library
199 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gst
200 Group:          Development/Libraries
201 Requires:       %{name}-devel = %{version}-%{release}
202 Requires:       %{name}-gst = %{version}-%{release}
203 Requires:       gstreamer-devel >= 1.0
204 Requires:       gstreamer-plugins-base-devel >= 1.0
205
206 %description gst-devel
207 Header files for cogl-gst library.
208
209 %description gst-devel -l pl.UTF-8
210 Pliki nagłówkowe biblioteki cogl-gst.
211
212 %package gst-static
213 Summary:        Static cogl-gst library
214 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gst
215 Group:          Development/Libraries
216 Requires:       %{name}-gst-devel = %{version}-%{release}
217
218 %description gst-static
219 Static cogl-gst library.
220
221 %description gst-static -l pl.UTF-8
222 Statyczna biblioteka cogl-gst.
223
224 %package gst-apidocs
225 Summary:        API documentation for cogl-gst library
226 Summary(pl.UTF-8):      Dokumentacja API biblioteki cogl-gst
227 Group:          Documentation
228 BuildArch:      noarch
229
230 %description gst-apidocs
231 API documentation for cogl-gst library.
232
233 %description gst-apidocs -l pl.UTF-8
234 Dokumentacja API biblioteki cogl-gst.
235
236 %prep
237 %setup -q
238 %patch0 -p1
239
240 %build
241 %{__gettextize}
242 %{__libtoolize}
243 %{__aclocal} -I build/autotools
244 %{__autoconf}
245 %{__autoheader}
246 %{__automake}
247 %configure \
248         %{!?with_gdkpixbuf:--disable-gdk-pixbuf} \
249         --disable-silent-rules \
250         --enable-cairo \
251         %{?with_gstreamer:--enable-cogl-gst} \
252         --enable-cogl-pango \
253         %{?with_gles1:--enable-gles1 --with-gles1-libname=libGLESv1_CM.so.1} \
254         %{?with_gles2:--enable-gles2 --with-gles2-libname=libGLESv2.so.2} \
255         --enable-glx \
256         --enable-gtk-doc \
257         --enable-introspection \
258         --enable-kms-egl-platform \
259         %{?with_mir:--enable-mir-egl-platform} \
260         %{?with_sdl1:--enable-sdl} \
261         %{?with_sdl2:--enable-sdl2} \
262         %{?with_static_libs:--enable-static} \
263         %{?with_wayland:--enable-wayland-egl-platform} \
264         %{?with_wayland:--enable-wayland-egl-server} \
265         --enable-xlib-egl-platform \
266         --with-html-dir=%{_gtkdocdir}
267 %{__make}
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271
272 %{__make} -j1 install \
273         DESTDIR=$RPM_BUILD_ROOT
274
275 %if %{with gstreamer}
276 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.la
277 %if %{with static_libs}
278 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.a
279 %endif
280 %endif
281 # obsoleted by pkg-config
282 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl*.la
283
284 %find_lang %{name}
285
286 %clean
287 rm -rf $RPM_BUILD_ROOT
288
289 %post   -p /sbin/ldconfig
290 %postun -p /sbin/ldconfig
291
292 %post   gles2 -p /sbin/ldconfig
293 %postun gles2 -p /sbin/ldconfig
294
295 %post   gst -p /sbin/ldconfig
296 %postun gst -p /sbin/ldconfig
297
298 %files -f %{name}.lang
299 %defattr(644,root,root,755)
300 %doc ChangeLog NEWS README
301 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
302 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.20
303 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
304 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.20
305 %attr(755,root,root) %{_libdir}/libcogl-path.so.*.*.*
306 %attr(755,root,root) %ghost %{_libdir}/libcogl-path.so.20
307 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
308 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
309 %{_libdir}/girepository-1.0/Cogl-2.0.typelib
310 %{_libdir}/girepository-1.0/CoglPango-2.0.typelib
311
312 %files devel
313 %defattr(644,root,root,755)
314 %attr(755,root,root) %{_libdir}/libcogl.so
315 %attr(755,root,root) %{_libdir}/libcogl-pango.so
316 %attr(755,root,root) %{_libdir}/libcogl-path.so
317 %dir %{_includedir}/cogl
318 %{_includedir}/cogl/cogl
319 %{_includedir}/cogl/cogl-pango
320 %{_includedir}/cogl/cogl-path
321 %{_pkgconfigdir}/cogl-1.0.pc
322 %{_pkgconfigdir}/cogl-2.0-experimental.pc
323 %{_pkgconfigdir}/cogl-gl-1.0.pc
324 %{_pkgconfigdir}/cogl-pango-1.0.pc
325 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
326 %{_pkgconfigdir}/cogl-path-1.0.pc
327 %{_pkgconfigdir}/cogl-path-2.0-experimental.pc
328 %{_datadir}/gir-1.0/Cogl-1.0.gir
329 %{_datadir}/gir-1.0/CoglPango-1.0.gir
330 %{_datadir}/gir-1.0/Cogl-2.0.gir
331 %{_datadir}/gir-1.0/CoglPango-2.0.gir
332
333 %if %{with static_libs}
334 %files static
335 %defattr(644,root,root,755)
336 %{_libdir}/libcogl.a
337 %{_libdir}/libcogl-pango.a
338 %{_libdir}/libcogl-path.a
339 %endif
340
341 %files doc
342 %defattr(644,root,root,755)
343 %{_gtkdocdir}/cogl
344 %{_gtkdocdir}/cogl-2.0-experimental
345
346 %if %{with gles2}
347 %files gles2
348 %defattr(644,root,root,755)
349 %attr(755,root,root) %{_libdir}/libcogl-gles2.so.*.*.*
350 %attr(755,root,root) %ghost %{_libdir}/libcogl-gles2.so.20
351
352 %files gles2-devel
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/libcogl-gles2.so
355 %{_includedir}/cogl/cogl-gles2
356 %{_pkgconfigdir}/cogl-gles2-1.0.pc
357 %{_pkgconfigdir}/cogl-gles2-2.0-experimental.pc
358
359 %if %{with static_libs}
360 %files gles2-static
361 %defattr(644,root,root,755)
362 %{_libdir}/libcogl-gles2.a
363 %endif
364 %endif
365
366 %if %{with gstreamer}
367 %files gst
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_libdir}/libcogl-gst.so.*.*.*
370 %attr(755,root,root) %ghost %{_libdir}/libcogl-gst.so.20
371 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstcogl.so
372 %{_libdir}/girepository-1.0/CoglGst-2.0.typelib
373
374 %files gst-devel
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{_libdir}/libcogl-gst.so
377 %{_includedir}/cogl/cogl-gst
378 %{_pkgconfigdir}/cogl-gst-1.0.pc
379 %{_pkgconfigdir}/cogl-gst-2.0-experimental.pc
380 %{_datadir}/gir-1.0/CoglGst-2.0.gir
381
382 %if %{with static_libs}
383 %files gst-static
384 %defattr(644,root,root,755)
385 %{_libdir}/libcogl-gst.a
386 %endif
387
388 %files gst-apidocs
389 %defattr(644,root,root,755)
390 %{_gtkdocdir}/cogl-gst
391 %endif
This page took 0.106117 seconds and 4 git commands to generate.