]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- release 6 (by relup.sh)
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 # - sub-package for kde4 stuff (or nuke them):
5 #        /usr/share/kde4/services/clementine-feed.protocol
6 #        /usr/share/kde4/services/clementine-itms.protocol
7 #        /usr/share/kde4/services/clementine-itpc.protocol
8 #        /usr/share/kde4/services/clementine-zune.protocol
9 #
10 # Conditional build:
11 %bcond_with     static_projectm # with static projectM
12 %bcond_with     libspotify      # build with system libspotify instead of downloading blob
13 %bcond_with     tests           # build without tests
14
15 %define         qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
16 %define         sqlitever       3.14.0-2
17 Summary:        A music player and library organiser
18 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
19 Name:           clementine
20 Version:        1.3.1
21 Release:        6
22 License:        GPL v3 and GPL v2+
23 Group:          X11/Applications/Multimedia
24 Source0:        https://github.com/clementine-player/Clementine/releases/download/%{version}/%{name}-%{version}.tar.xz
25 # Source0-md5:  18cc5f66aa5fbb2781198a65439bd38a
26 Patch1:         unbundle-po.patch
27 Patch2:         %{name}-udisks-headers.patch
28 Patch3:         %{name}-mygpo.patch
29 Patch4:         moc.patch
30 URL:            http://www.clementine-player.org/
31 BuildRequires:  QtCore-devel >= %{qtver}
32 BuildRequires:  QtDBus-devel >= %{qtver}
33 BuildRequires:  QtGui-devel >= %{qtver}
34 BuildRequires:  QtIOCompressor-devel >= 2.3
35 BuildRequires:  QtNetwork-devel >= %{qtver}
36 BuildRequires:  QtOpenGL-devel >= %{qtver}
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel >= %{qtver}
39 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
40 BuildRequires:  QtXml-devel >= %{qtver}
41 BuildRequires:  boost-devel
42 BuildRequires:  cmake >= 2.6
43 BuildRequires:  cryptopp-devel >= 5.6.1-4
44 BuildRequires:  desktop-file-utils
45 BuildRequires:  gettext-tools
46 %{?with_static_projectm:BuildRequires:  glew-devel}
47 BuildRequires:  glib2-devel
48 BuildRequires:  gstreamer-devel
49 BuildRequires:  gstreamer-plugins-base-devel
50 BuildRequires:  gtest-devel
51 BuildRequires:  libcdio-devel
52 BuildRequires:  libchromaprint-devel
53 BuildRequires:  libechonest-devel
54 BuildRequires:  libgpod-devel >= 0.7.92
55 BuildRequires:  libimobiledevice-devel >= 1.1.5
56 BuildRequires:  liblastfm-devel >= 0.3.3
57 BuildRequires:  libmtp-devel >= 1.0
58 BuildRequires:  libmygpo-qt-devel >= 1.0.7
59 BuildRequires:  libplist-devel
60 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
61 BuildRequires:  libqxt-devel
62 %{?with_libspotify:BuildRequires:       libspotify-devel >= 12.1.45}
63 BuildRequires:  libusbmuxd-devel
64 BuildRequires:  libxml2-devel
65 BuildRequires:  pkgconfig
66 BuildRequires:  pkgconfig
67 BuildRequires:  protobuf-devel
68 BuildRequires:  qjson-devel
69 BuildRequires:  qt4-build >= %{qtver}
70 BuildRequires:  qt4-linguist
71 BuildRequires:  qt4-qmake
72 BuildRequires:  rpmbuild(find_lang) >= 1.38
73 BuildRequires:  rpmbuild(macros) >= 1.596
74 BuildRequires:  sed >= 4.0
75 BuildRequires:  sparsehash-devel
76 BuildRequires:  sqlite3-devel >= %{sqlitever}
77 BuildRequires:  taglib-devel >= 1.8
78 BuildRequires:  tar >= 1:1.22
79 BuildRequires:  xz
80 Requires(post,postun):  desktop-file-utils
81 Requires(post,postun):  gtk-update-icon-cache
82 Requires(post,postun):  hicolor-icon-theme
83 BuildRequires:  sqlite3 >= %{sqlitever}
84 Requires:       QtSingleApplication >= 2.6-4
85 Requires:       QtSql-sqlite3 >= %{qtver}
86 Requires:       gstreamer-audio-effects-base
87 Requires:       gstreamer-mad
88 Suggests:       gstreamer-flac
89 # if we do not link, we use datafiles
90 %{!?with_static_projectm:Requires:      libprojectM}
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 # see libprojectM.spec for explanation
94 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
95
96 %description
97 Clementine is a modern music player and library organiser. It is
98 largely a port of Amarok 1.4, with some features rewritten to take
99 advantage of Qt4.
100
101 %description -l hu.UTF-8
102 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
103 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
104 a Qt4 előnyeit.
105
106 %prep
107 %setup -q
108 %patch1 -p1
109 %patch2 -p1
110 #%patch3 -p1
111 %patch4 -p1
112
113 # cleanup vendor. keep only needed libraries.
114 mv 3rdparty 3rdparty.dist
115 vendor() {
116         local path dir
117         for path; do
118                 dir=$(dirname $path)
119                 test -d 3rdparty/$dir || mkdir -p 3rdparty/$dir
120                 mv 3rdparty.dist/$path 3rdparty/$path
121         done
122 }
123 vendor sha2 qocoa
124 vendor qsqlite
125 %{?with_static_projectm:vendor libprojectm}
126 # missing in pld
127 vendor vreen
128 # requires 1.0.9, but only 1.0.8 is released
129 vendor libmygpo-qt
130
131 # Don't build tests. They require gmock
132 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
133 # remove -Wall
134 sed -i -e 's/-Wall//' src/CMakeLists.txt
135
136 %build
137 install -d build
138 install -d build/src/translations
139 cd build
140 # as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~135
141 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
142 %cmake \
143         -DBUILD_WERROR:BOOL=OFF \
144         -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
145         -DCMAKE_INCLUDE_PATH=%{_includedir}/qt4 \
146         -DBUNDLE_PROJECTM_PRESETS=OFF \
147         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
148         -DUSE_SYSTEM_QXT=ON \
149         -DUSE_SYSTEM_PROJECTM=ON \
150         -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions \
151         ..
152 %{__make}
153
154 desktop-file-validate ../dist/%{name}.desktop
155
156 %if %{with tests}
157 %endif
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 %{__make} -C build install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/kde4/services
165
166 # not in our glibc?
167 rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
168 rm -r $RPM_BUILD_ROOT%{_localedir}/he_IL
169 rm -r $RPM_BUILD_ROOT%{_localedir}/mk_MK
170 rm -r $RPM_BUILD_ROOT%{_localedir}/si_LK
171
172 %find_lang %{name} --with-qm
173
174 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
175 cp -p dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
176 cp -p dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post
182 %update_desktop_database_post
183 %update_icon_cache hicolor
184
185 %postun
186 %update_desktop_database_postun
187 %update_icon_cache hicolor
188
189 %files -f %{name}.lang
190 %defattr(644,root,root,755)
191 %doc Changelog
192 %attr(755,root,root) %{_bindir}/clementine
193 %attr(755,root,root) %{_bindir}/clementine-tagreader
194 %{_desktopdir}/clementine.desktop
195 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
196 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
197 %{_iconsdir}/hicolor/*/apps/clementine.png
198 %{_iconsdir}/hicolor/*/apps/clementine.svg
199 %{_datadir}/appdata/clementine.appdata.xml
This page took 0.21561 seconds and 4 git commands to generate.