]> git.pld-linux.org Git - packages/clamav.git/blob - clamav.spec
- rewrited
[packages/clamav.git] / clamav.spec
1 Summary:        A Mail Virus Scanner
2 Summary(pl):    Antywirusowy skaner poczty elektronicznej
3 Name:           clamav
4 Version:        0.11
5 Release:        4
6 URL:            http://www.konarski.edu.pl/~zolw/clam.html
7 Source0:        http://www.konarski.edu.pl/~zolw/clam/%{name}-%{version}.tar.gz
8 Patch0:         %{name}-am_ac.patch
9 License:        GPL
10 Group:          Applications/Mail
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Clam Antivirus is a powerful anti-virus scanner for Unix. It supports
17 AMaViS, compressed files, uses the virus database from
18 OpenAntivirus.org, and includes a program for auto-updating. The
19 scanner is multithreaded, written in C, and POSIX compliant.
20
21 %description -l pl
22 Clam Antivirus jest potê¿nym skanerem antywirusowym dla systemów
23 uniksowych. Wspiera on AMaViSa, skompresowane pliki, u¿ywa bazy
24 wirusów z OpenAntivirus.org, i posiada system automatycznej
25 aktualizacji. Skaner jest wielow±tkowy, napisany w C i zgodny z
26 POSIXem.
27
28 %prep
29 %setup -q
30 %patch0 -p1
31
32 %build
33 rm -f missing
34 aclocal
35 autoconf
36 automake -a -c -f
37 %configure \
38         --disable-clamav
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
44 install -d $RPM_BUILD_ROOT%{_var}/log/
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 echo -e '#!/bin/sh\n%{_bindir}/freshclam --quiet -l %{_var}/log/%{name}.log' \
50         > $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/%{name}
51
52 touch $RPM_BUILD_ROOT%{_var}/log/%{name}.log
53
54 gzip -9nf AUTHORS ChangeLog FAQ NEWS README TODO
55
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %pre
61 if [ -n "`getgid clamav`" ]; then
62         if [ "`getgid clamav`" != "43" ]; then
63                 echo "Warning: group clamav doesn't have gid=43. Correct this before installing clamav" 1>&2
64                 exit 1
65         fi
66 else
67         /usr/sbin/groupadd -g 43 -r -f clamav
68 fi
69 if [ -n "`id -u clamav 2>/dev/null`" ]; then
70         if [ "`id -u clamav`" != "43" ]; then
71                 echo "Warning: user clamav doesn't have uid=43. Correct this before installing clamav" 1>&2
72                 exit 1
73         fi
74 else
75         /usr/sbin/useradd -u 43 -r -d /tmp  -s /bin/false -c "Clam Anti Virus Checker" -g clamav clamav 1>&2
76 fi
77
78 %postun
79 if [ "$1" = "0" ]; then
80         /usr/sbin/userdel clamav
81         /usr/sbin/groupdel clamav
82 fi
83
84 %post
85 touch %{_var}/log/%{name}.log && chmod 640 %{_var}/log/%{name}.log && chown clamav %{_var}/log/%{name}.log
86
87 %files
88 %defattr(644,root,root,755)
89 %doc *.gz docs/*.pdf
90 %attr(755,root,root) %{_bindir}/*
91 %attr(755,clamav,root) %dir %{_datadir}/clam
92 %attr(644,clamav,root) %verify(not md5 size mtime) %{_datadir}/clam/*.db
93 %attr(640,clamav,root) %ghost %{_var}/log/%{name}.log
94 %attr(750,root,root) %{_sysconfdir}/cron.daily/%{name}
95 %{_mandir}/man?/*
This page took 0.087954 seconds and 3 git commands to generate.