]> git.pld-linux.org Git - packages/ckeditor.git/blob - ckeditor.spec
add kama skin - The default CKEditor 3 skin ported to CKEditor 4.
[packages/ckeditor.git] / ckeditor.spec
1 # NOTES:
2 # - check for new releases here: http://ckeditor.com/download/releases
3 Summary:        The text editor for Internet
4 Summary(pl.UTF-8):      Edytor tekstowy dla Internetu
5 Name:           ckeditor
6 Version:        4.3.2
7 Release:        1
8 License:        LGPL v2.1+ / GPL v2+ / MPL
9 Group:          Applications/WWW
10 Source0:        http://download.cksource.com/CKEditor/CKEditor/CKEditor%20%{version}/%{name}_%{version}_full.tar.gz
11 # Source0-md5:  650ccbfbd51153261dc9be9bdc9ef5c0
12 # http://ckeditor.com/addon/kama - The default CKEditor 3 skin ported to CKEditor 4.
13 Source1:        http://download.ckeditor.com/kama/releases/kama_%{version}.zip
14 # Source1-md5:  a57baab966aa228b85927cc07a7f95a1
15 URL:            http://www.ckeditor.com/
16 Source2:        apache.conf
17 Source3:        lighttpd.conf
18 Source4:        find-lang.sh
19 BuildRequires:  rpmbuild(macros) >= 1.553
20 BuildRequires:  sed >= 4.0
21 Requires:       webapps
22 Requires:       webserver
23 Requires:       webserver(access)
24 Requires:       webserver(alias)
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _webapps        /etc/webapps
29 %define         _webapp         %{name}
30 %define         _sysconfdir     %{_webapps}/%{_webapp}
31 %define         _appdir         %{_datadir}/%{name}
32
33 %define         find_lang       sh %{SOURCE4}
34
35 %description
36 This HTML text editor brings to the web many of the powerful
37 functionalities of desktop editors like MS Word. It's lightweight and
38 doesn't require any kind of installation on the client computer.
39
40 %description -l pl.UTF-8
41 Ten edytor tekstu HTML udostępnia stronom WWW wiele potężnych funkcji
42 edytorów biurowych, takich jak MS Word. Jest lekki i nie wymaga żadnej
43 inicjalizacji na komputerze klienckim.
44
45 %prep
46 %setup -qc -a1
47 mv ckeditor/* .
48 mv kama skins
49
50 find -name _translationstatus.txt -print -delete
51
52 # undos the files
53 %undos -f js,css,txt,html,md
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_appdir}
58
59 cp -a ckeditor.js config.js styles.js contents.css $RPM_BUILD_ROOT%{_appdir}
60 cp -a adapters plugins skins lang $RPM_BUILD_ROOT%{_appdir}
61
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 install -d $RPM_BUILD_ROOT%{_sysconfdir}
66 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
67 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
68 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
69
70 %find_lang %{name}.lang
71
72 # always include
73 %{__sed} -i -e '/en\.js/d' %{name}.lang
74
75 # already listed by plugin dir
76 %{__sed} -i -e '/plugins/d' %{name}.lang
77
78 %triggerin -- apache1 < 1.3.37-3, apache1-base
79 %webapp_register apache %{_webapp}
80
81 %triggerun -- apache1 < 1.3.37-3, apache1-base
82 %webapp_unregister apache %{_webapp}
83
84 %triggerin -- apache < 2.2.0, apache-base
85 %webapp_register httpd %{_webapp}
86
87 %triggerun -- apache < 2.2.0, apache-base
88 %webapp_unregister httpd %{_webapp}
89
90 %triggerin -- lighttpd
91 %webapp_register lighttpd %{_webapp}
92
93 %triggerun -- lighttpd
94 %webapp_unregister lighttpd %{_webapp}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files -f %{name}.lang
100 %defattr(644,root,root,755)
101 %doc README.md CHANGES.md LICENSE.md
102 %dir %attr(750,root,http) %{_sysconfdir}
103 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
104 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
105 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
106 %dir %{_appdir}
107 %{_appdir}/*.js
108 %{_appdir}/lang/en.js
109 %{_appdir}/*.css
110
111 %dir %{_appdir}/adapters
112 %{_appdir}/adapters/jquery.js
113
114 %dir %{_appdir}/skins
115 %{_appdir}/skins/moono
116 %{_appdir}/skins/kama
117
118 %dir %{_appdir}/plugins
119 %{_appdir}/plugins/icons.png
120 %{_appdir}/plugins/icons_hidpi.png
121
122 %{_appdir}/plugins/a11yhelp
123 %{_appdir}/plugins/about
124 %{_appdir}/plugins/clipboard
125 %{_appdir}/plugins/colordialog
126 %{_appdir}/plugins/dialog
127 %{_appdir}/plugins/div
128 %{_appdir}/plugins/fakeobjects
129 %{_appdir}/plugins/find
130 %{_appdir}/plugins/flash
131 %{_appdir}/plugins/forms
132 %{_appdir}/plugins/iframe
133 %{_appdir}/plugins/image
134 %{_appdir}/plugins/link
135 %{_appdir}/plugins/liststyle
136 %{_appdir}/plugins/magicline
137 %{_appdir}/plugins/pagebreak
138 %{_appdir}/plugins/pastefromword
139 %{_appdir}/plugins/preview
140 %{_appdir}/plugins/scayt
141 %{_appdir}/plugins/showblocks
142 %{_appdir}/plugins/smiley
143 %{_appdir}/plugins/specialchar
144 %{_appdir}/plugins/table
145 %{_appdir}/plugins/tabletools
146 %{_appdir}/plugins/templates
147 %{_appdir}/plugins/wsc
148
149 %{_examplesdir}/%{name}-%{version}
This page took 0.62487 seconds and 3 git commands to generate.