]> git.pld-linux.org Git - packages/chrony.git/blob - chrony.spec
- fix "status" in initscript (don't wait for sleep to finish)
[packages/chrony.git] / chrony.spec
1 %define         nettle_ver      3.9
2
3 Summary:        An NTP client/server
4 Summary(pl.UTF-8):      Klient/serwer NTP
5 Name:           chrony
6 Version:        4.5
7 Release:        2
8 License:        GPL v2
9 Group:          Daemons
10 Source0:        http://download.tuxfamily.org/chrony/%{name}-%{version}.tar.gz
11 # Source0-md5:  fa50d026df54f9919e6a37fae1258c61
12 Source1:        %{name}.conf
13 Source2:        %{name}.keys
14 Source3:        %{name}d.sysconfig
15 Source4:        %{name}d.init
16 Source5:        %{name}.logrotate
17 Patch0:         fix-seccomp-build.patch
18 Patch1:         conf.d.patch
19 URL:            http://chrony.tuxfamily.org/
20 BuildRequires:  asciidoc
21 BuildRequires:  bison
22 BuildRequires:  gnutls-devel
23 BuildRequires:  libcap-devel
24 BuildRequires:  libedit-devel
25 BuildRequires:  libseccomp-devel
26 # for hashing; can be also nss 3.x, libtomcrypt, gnutls
27 BuildRequires:  nettle-devel >= %{nettle_ver}
28 BuildRequires:  pkgconfig
29 BuildRequires:  pps-tools-devel
30 BuildRequires:  rpmbuild(macros) >= 1.453
31 Requires(postun):       /usr/sbin/groupdel
32 Requires(postun):       /usr/sbin/userdel
33 Requires(pre):  /bin/id
34 Requires(pre):  /usr/bin/getgid
35 Requires(pre):  /usr/sbin/groupadd
36 Requires(pre):  /usr/sbin/useradd
37 Provides:       group(ntp)
38 Provides:       ntpdaemon
39 Provides:       user(ntp)
40 Requires:       nettle >= %{nettle_ver}
41 Obsoletes:      ntpdaemon
42 Conflicts:      logrotate < 3.8.0
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sysconfdir     /etc/ntp
46
47 # assume gcc 3.4 has it
48 %if "%{cc_version}" >= "3.4"
49 %define         specflags       -pie -fpie
50 %endif
51
52 %description
53 A client/server for the Network Time Protocol, this program keeps your
54 computer's clock accurate. It was specially designed to support
55 systems with dial-up Internet connections, and also supports computers
56 in permanently connected environments.
57
58 %description -l pl.UTF-8
59 Klient/serwer protokołu NTP (Network Time Protocol), pozwalający
60 utrzymać zegar komputera dokładnym. Został zaprojektowany w
61 szczególności do obsłużenia systemów z wdzwanianym połączeniem do
62 Internetu, obsługuje także komputery na stałym łączu.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68
69 %build
70 # NOTE: It is not autoconf generated configre
71 CC="%{__cc}" \
72 CFLAGS="%{rpmcflags} -Wmissing-prototypes -Wall" \
73 CPPFLAGS="%{rpmcppflags}" \
74 ./configure \
75         --enable-debug \
76         --enable-ntp-signd \
77         --enable-scfilter \
78         --prefix=%{_prefix} \
79         --sysconfdir=%{_sysconfdir} \
80         --docdir=%{_docdir} \
81         --with-ntp-era=$(date -d '1970-01-01 00:00:00+00:00' +'%s') \
82         --with-hwclockfile=%{_sysconfdir}/adjtime \
83         --with-sendmail=%{_sbindir}/sendmail
84
85 %{__make} getdate all docs \
86         ADOC=asciidoc
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d} \
91         $RPM_BUILD_ROOT{%{_sysconfdir}/chrony.d,/var/{lib/ntp,log/chrony}}
92
93 %{__make} install install-docs \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
97
98 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
99 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/keys
100 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/chronyd
101 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/chrony
102 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/chronyd
103
104 touch $RPM_BUILD_ROOT%{_localstatedir}/lib/ntp/{drift,rtc}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %pre
110 %groupadd -g 246 ntp
111 %useradd -u 246 -d %{_localstatedir}/lib/ntp -g ntp -c "NTP Daemon" ntp
112
113 %post
114 /sbin/chkconfig --add chronyd
115 %service chronyd restart
116
117 %preun
118 if [ "$1" = "0" ]; then
119         %service chronyd stop
120         /sbin/chkconfig --del chronyd
121 fi
122
123 %postun
124 if [ "$1" = "0" ]; then
125         %userremove ntp
126         %groupremove ntp
127 fi
128
129 %files
130 %defattr(644,root,root,755)
131 %doc NEWS README FAQ examples/* doc/{faq,installation}.html
132 %dir %{_sysconfdir}
133 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chrony.conf
134 %attr(750,root,root) %dir %{_sysconfdir}/chrony.d
135 %attr(640,root,ntp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/keys
136 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/chronyd
137 %config(noreplace) /etc/logrotate.d/chrony
138 %attr(754,root,root) /etc/rc.d/init.d/chronyd
139 %attr(755,root,root) %{_bindir}/chronyc
140 %attr(755,root,root) %{_sbindir}/chronyd
141 %{_mandir}/man1/chronyc.1*
142 %{_mandir}/man5/chrony.conf.5*
143 %{_mandir}/man8/chronyd.8*
144
145 %dir %attr(770,root,ntp) /var/lib/ntp
146 %attr(640,ntp,ntp) %ghost /var/lib/ntp/drift
147 %attr(640,ntp,ntp) %ghost /var/lib/ntp/rtc
148
149 %dir %attr(770,ntp,ntp) /var/log/chrony
This page took 0.118267 seconds and 4 git commands to generate.