]> git.pld-linux.org Git - packages/check.git/blob - check.spec
- new URLs, updated to 0.12.0
[packages/check.git] / check.spec
1 #
2 # Conditional build:
3 %bcond_without  subunit # support for subunit test protocol
4
5 Summary:        Check - unit testing framework for C
6 Summary(pl.UTF-8):      Check - szkielet testów jednostkowych dla C
7 Name:           check
8 Version:        0.12.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 #Source0Download: https://github.com/libcheck/check/releases
13 Source0:        https://github.com/libcheck/check/releases/download/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  31b17c6075820a434119592941186f70
15 Patch0:         %{name}-info.patch
16 URL:            https://libcheck.github.io/check/
17 # aclocal required for %{_aclocaldir}
18 BuildRequires:  automake >= 1:1.11.2
19 BuildRequires:  libtool >= 2:2
20 BuildRequires:  pkgconfig
21 %{?with_subunit:BuildRequires:  subunit-devel}
22 BuildRequires:  texinfo >= 4.2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %undefine       __cxx
26
27 %description
28 Check is a unit test framework for C. It features a simple interface
29 for defining unit tests, putting little in the way of the developer.
30 Tests are run in a separate address space, so Check can catch both
31 assertion failures and code errors that cause segmentation faults or
32 other signals. The output from unit tests can be used within source
33 code editors and IDEs.
34
35 This package contains only shared library.
36
37 %description -l pl.UTF-8
38 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
39 definiowania testów jednostkowych, nie przeszkadzający zbytnio
40 programiście. Testy są uruchamiane w wydzielonej przestrzeni
41 adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
42 zapewnień (assert), jak i błędy w kodzie powodujące naruszenie ochrony
43 pamięci lub inne sygnały. Wyjście z testów jednostkowych może być
44 używane z poziomu edytorów kodu źródłowego i IDE.
45
46 Ten pakiet zawiera tylko bibliotekę współdzieloną.
47
48 %package devel
49 Summary:        Headers for developing programs with check library
50 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów przy użyciu biblioteki checka
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 %{?with_subunit:Requires:       subunit-devel}
54
55 %description devel
56 Headers for developing programs with check library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe do tworzenia programów przy użyciu biblioteki checka.
60
61 %package static
62 Summary:        Static check library
63 Summary(pl.UTF-8):      Biblioteka statyczna check
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static check library.
69
70 %description static -l pl.UTF-8
71 Biblioteka statyczna check.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 CFLAGS="%{rpmcflags} -fPIC"
79 %configure \
80         %{!?with_subunit:--disable-subunit}
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         exampledir=%{_examplesdir}/%{name}-%{version} \
88         examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
89         exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcheck.la
94 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %post   devel -p /sbin/postshell
103 -/usr/sbin/fix-info-dir -c %{_infodir}
104
105 %postun devel -p /sbin/postshell
106 -/usr/sbin/fix-info-dir -c %{_infodir}
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS NEWS README THANKS TODO
111 %attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libcheck.so.0
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_bindir}/checkmk
117 %attr(755,root,root) %{_libdir}/libcheck.so
118 %{_includedir}/check.h
119 %{_includedir}/check_stdint.h
120 %{_aclocaldir}/check.m4
121 %{_pkgconfigdir}/check.pc
122 %{_mandir}/man1/checkmk.1*
123 %{_infodir}/check.info*
124 %{_examplesdir}/%{name}-%{version}
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libcheck.a
This page took 0.133978 seconds and 4 git commands to generate.