]> git.pld-linux.org Git - packages/cereal.git/blob - cereal.spec
- updated to 1.3.2; no longer noarch due to cmake configs path
[packages/cereal.git] / cereal.spec
1 #
2 # Conditional build
3 %bcond_without  tests   # unit tests
4
5 Summary:        A header-only C++11 serialization library
6 Summary(pl.UTF-8):      Składająca się z samych nagłówków biblioteka C++11 do serializacji
7 Name:           cereal
8 Version:        1.3.2
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        https://github.com/USCiLab/cereal/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  ab6070fadc7c50072ef4153fb1c46a87
14 URL:            http://uscilab.github.io/cereal/
15 BuildRequires:  boost-devel
16 BuildRequires:  cmake >= 3.6
17 BuildRequires:  libstdc++-devel >= 6:4.7
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _enable_debug_packages  0
21
22 %description
23 cereal is a header-only C++11 serialization library. cereal takes
24 arbitrary data types and reversibly turns them into different
25 representations, such as compact binary encodings, XML, or JSON.
26 cereal was designed to be fast, light-weight, and easy to extend - it
27 has no external dependencies and can be easily bundled with other code
28 or used standalone.
29
30 %description -l pl.UTF-8
31 cereal to składająca się z samych nagłówków biblioteka C++11 do
32 serializacji. Przyjmuje dowolne typy danych i odwracalnie zamienia je
33 na różne reprezentacje, takie jak zwięzłe kodowania binarne, XML czy
34 JSON. careal jest zaprojektowana jako szybka, lekka i łatwa do
35 rozszerzania - nie ma zewnętrznych zależności i może być łatwo
36 dołączona do innego kodu lub używana samodzielnie.
37
38 %package devel
39 Summary:        A header-only C++11 serialization library
40 Summary(pl.UTF-8):      Składająca się z samych nagłówków biblioteka C++11 do serializacji
41 Group:          Development/Libraries
42
43 %description devel
44 cereal is a header-only C++11 serialization library. cereal takes
45 arbitrary data types and reversibly turns them into different
46 representations, such as compact binary encodings, XML, or JSON.
47 cereal was designed to be fast, light-weight, and easy to extend - it
48 has no external dependencies and can be easily bundled with other code
49 or used standalone.
50
51 %description devel -l pl.UTF-8
52 cereal to składająca się z samych nagłówków biblioteka C++11 do
53 serializacji. Przyjmuje dowolne typy danych i odwracalnie zamienia je
54 na różne reprezentacje, takie jak zwięzłe kodowania binarne, XML czy
55 JSON. careal jest zaprojektowana jako szybka, lekka i łatwa do
56 rozszerzania - nie ma zewnętrznych zależności i może być łatwo
57 dołączona do innego kodu lub używana samodzielnie.
58
59 %prep
60 %setup -q
61
62 %build
63 install -d build
64 cd build
65 %cmake .. \
66         -DSKIP_PORTABILITY_TEST=ON \
67         -DWITH_WERROR=OFF
68
69 %{__make}
70
71 %{?with_tests:%{__make} test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -C build install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files devel
83 %defattr(644,root,root,755)
84 %doc README.md
85 %{_includedir}/cereal
86 %{_libdir}/cmake/cereal
This page took 0.196217 seconds and 4 git commands to generate.