]> git.pld-linux.org Git - packages/cdcat.git/blob - cdcat.spec
- added segfault fix patch
[packages/cdcat.git] / cdcat.spec
1 Summary:        Hyper's CdCatalog
2 Summary(pl.UTF-8):      Katalog CDków Hypera
3 Name:           cdcat
4 Version:        1.01b
5 Release:        2
6 License:        GPL
7 Group:          Applications
8 Source0:        http://cdcat.sourceforge.net/%{name}-%{version}.tar.bz2
9 # Source0-md5:  59b321ff3848b34cb6862fd2a408cb44
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-gcc4.patch
12 Patch1:         %{name}-fstab.patch
13 URL:            http://cdcat.sourceforge.net/
14 BuildRequires:  expat-devel >= 1.95.2
15 BuildRequires:  pcre-devel >= 1.1.4
16 BuildRequires:  qmake
17 BuildRequires:  qt-devel >= 2.0.3
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The cdcat is a graphical (Qt based) multiplatform (Linux/Windows)
22 catalog program which scan your directoryes/drives you want and
23 memoryze the filesystem /including the tags of MP3's/ and store it a
24 small file. The database is stored in a gzipped XML format, so you can
25 hack it, or use it if necessary :-)
26
27 %description -l pl.UTF-8
28 Cdcat jest graficznym (opartym o Qt) wieloplatformowym (Linux/Windows)
29 programem katalogującym, który skanuje wybrane dyski i zapamiętuje
30 system plików (włączając w to znaczniki MP3) i zapisuje to w małym
31 pliku. Baza danych jest w gzipowanym pliku XML, więc można ją
32 zmieniać, albo używać w miarę potrzeby.
33
34 %prep
35 %setup -q -n CdCat-%{version}
36 %patch0 -p0
37 %patch1 -p0
38 echo 'CONFIG += thread' >> src/cdcat.pro
39
40 %build
41 cd src
42 export QTDIR=%{_prefix}
43 qmake \
44         QMAKE_CXX="%{__cxx}" \
45         QMAKE_LINK="%{__cxx}" \
46         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags} -fno-exceptions -fno-rtti"
47
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_datadir}/cdcat/translations
53
54 install -D src/cdcat $RPM_BUILD_ROOT%{_bindir}/cdcat
55 install src/lang/cdcat_*.qm $RPM_BUILD_ROOT%{_datadir}/cdcat/translations
56 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/cdcat.desktop
57 install -D cdcat.png $RPM_BUILD_ROOT%{_pixmapsdir}/cdcat.png
58
59 %clean
60 rm -fr $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Authors ChangeLog README README_IMPORT TRANSLATORS_README TODO VERSION
65 %attr(755,root,root) %{_bindir}/*
66 %dir %{_datadir}/cdcat
67 %dir %{_datadir}/cdcat/translations
68 %lang(cs) %{_datadir}/cdcat/translations/cdcat_cz.qm
69 %lang(de) %{_datadir}/cdcat/translations/cdcat_de.qm
70 %lang(el) %{_datadir}/cdcat/translations/cdcat_el.qm
71 %lang(es) %{_datadir}/cdcat/translations/cdcat_es.qm
72 %lang(fr) %{_datadir}/cdcat/translations/cdcat_fr.qm
73 %lang(hu) %{_datadir}/cdcat/translations/cdcat_hu.qm
74 %lang(id) %{_datadir}/cdcat/translations/cdcat_id.qm
75 %lang(it) %{_datadir}/cdcat/translations/cdcat_it.qm
76 %lang(pl) %{_datadir}/cdcat/translations/cdcat_pl.qm
77 %lang(pt) %{_datadir}/cdcat/translations/cdcat_pt.qm
78 %lang(sk) %{_datadir}/cdcat/translations/cdcat_sk.qm
79 %lang(sr) %{_datadir}/cdcat/translations/cdcat_sr.qm
80 %{_desktopdir}/*.desktop
81 %{_pixmapsdir}/*
This page took 0.125099 seconds and 4 git commands to generate.