]> git.pld-linux.org Git - packages/ccnet.git/commitdiff
new, version 5.1.2 auto/th/ccnet-5.1.2-1
authorElan Ruusamäe <glen@delfi.ee>
Tue, 7 Jun 2016 20:14:26 +0000 (23:14 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 7 Jun 2016 20:14:26 +0000 (23:14 +0300)
based on fedora package, 165769c

ccnet.spec [new file with mode: 0644]
codegen.patch [new file with mode: 0644]

diff --git a/ccnet.spec b/ccnet.spec
new file mode 100644 (file)
index 0000000..33f0ab3
--- /dev/null
@@ -0,0 +1,114 @@
+#
+# Conditional build:
+%bcond_without tests           # build without tests
+
+Summary:       A framework for writing networked applications in C
+Name:          ccnet
+Version:       5.1.2
+Release:       1
+License:       GPL v3
+Group:         Libraries
+Source0:       https://github.com/haiwen/ccnet/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 96e311d211c463c0dbd8cf46d48d1d6d
+Patch0:                codegen.patch
+URL:           https://github.com/haiwen/ccnet
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: glib2-devel
+BuildRequires: libevent-devel
+BuildRequires: libsearpc-devel
+BuildRequires: libtool
+BuildRequires: libuuid-devel
+BuildRequires: libzdb-devel >= 2.10.2
+BuildRequires: openssl-devel
+BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.714
+BuildRequires: sqlite-devel
+BuildRequires: vala >= 0.8
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Ccnet is a framework for writing networked applications in C. It
+provides the following basic services:
+
+- Peer identification
+- Connection Management
+- Service invocation
+- Message sending
+
+In ccnet network, there are two types of nodes, i.e., client and
+server. Server has the following functions:
+
+- User management
+- Group management
+- Cluster management
+
+%package devel
+Summary:       Development files for %{name}
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      glib2-devel
+Requires:      libevent-devel
+Requires:      libsearpc-devel
+
+%description devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
+%prep
+%setup -q
+%patch0 -p1
+
+# meh is this?
+sed -i -e 's/(DESTDIR)//' libccnet.pc.in
+
+%build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoheader}
+%{__automake} --gnu
+%{__autoconf}
+%configure \
+       --disable-static \
+       --disable-compile-demo \
+
+%{__make}
+
+%if %{with tests}
+%{__make} check
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%py_postclean
+
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libccnet.la
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc README.markdown HACKING COPYRIGHT LICENCE.txt
+%attr(755,root,root) %{_libdir}/libccnet.so.*.*.*
+%ghost %{_libdir}/libccnet.so.0
+%attr(755,root,root) %{_bindir}/ccnet
+%attr(755,root,root) %{_bindir}/ccnet-init
+%attr(755,root,root) %{_bindir}/ccnet-servtool
+%attr(755,root,root) %{_bindir}/ccnet-tool
+%{py_sitedir}/ccnet
+
+%files devel
+%defattr(644,root,root,755)
+%doc LICENCE.txt
+%{_includedir}/ccnet.h
+%{_includedir}/ccnet
+%{_libdir}/libccnet.so
+%{_pkgconfigdir}/libccnet.pc
diff --git a/codegen.patch b/codegen.patch
new file mode 100644 (file)
index 0000000..c6a3b09
--- /dev/null
@@ -0,0 +1,11 @@
+--- ccnet-5.1.2/lib/Makefile.am~       2016-05-10 05:50:39.000000000 +0300
++++ ccnet-5.1.2/lib/Makefile.am        2016-06-07 23:06:42.318060146 +0300
+@@ -86,7 +86,7 @@
+       @rm -f rpc_table.tmp
+       @touch rpc_table.tmp
+       @echo "[libsearpc]: generating rpc header files"
+-      @PYTHON@ `which searpc-codegen.py` ${top_srcdir}/lib/rpc_table.py
++      @PYTHON@ /usr/bin/searpc-codegen ${top_srcdir}/lib/rpc_table.py
+       @echo "[libsearpc]: done"
+       @mv -f rpc_table.tmp $@
This page took 0.080425 seconds and 4 git commands to generate.