]> git.pld-linux.org Git - packages/cassandra-bin.git/blame - cassandra-bin.spec
Update to 2.0.11 by Lukasz Gabrych. Enabled cqlsh.
[packages/cassandra-bin.git] / cassandra-bin.spec
CommitLineData
4e6d3cb2 1# TODO: Fix .init cassandra status does not work now.
16c24e02
MK
2# TODO: Fix .init stop routine it is now subset of PLD default one
3# TODO: Fix of data/ cassandra created dirs/files privilages (now they are all readable)
f60c3231 4# TODO: Consider adding
4e6d3cb2 5# cassandra - memlock unlimited
16c24e02 6# to /etc/security/limits.conf ?
3f05bde6 7
4e6d3cb2 8%define shname cassandra
f60c3231 9%include /usr/lib/rpm/macros.java
087ae4ed 10Summary: Cassandra database binary package
4e6d3cb2 11Summary(pl.UTF-8): Binarna redystrybucja bazy danych Cassandra
087ae4ed 12Name: cassandra-bin
93a9c726 13Version: 2.0.11
b5445178 14Release: 1
3f05bde6
MK
15License: ASF
16Group: Applications/Databases
b4f49f9b 17Source0: ftp://ftp.task.gda.pl/pub/www/apache/dist/cassandra/%{version}/apache-cassandra-%{version}-bin.tar.gz
93a9c726 18# Source0-md5: f8021f9defcdd6957ff78de7c6d5308b
087ae4ed
MK
19Source1: cassandra.in.sh
20Source2: %{shname}.init
687fc4b6 21Source3: %{name}.tmpfiles
40af29a9 22Patch0: %{name}-jamm_path_fix.patch
93a9c726 23Patch1: %{name}-cqlsh_path_fix.patch
3f05bde6 24URL: http://cassandra.apache.org/
93a9c726 25BuildRequires: python-distribute
3f05bde6 26BuildRequires: rpm-javaprov
93a9c726 27BuildRequires: rpm-pythonprov
3f05bde6 28BuildRequires: rpmbuild(macros) >= 1.300
f60c3231 29Requires(post,preun): /sbin/chkconfig
93a9c726 30Requires: python-modules
f60c3231 31Requires: rc-scripts
dd8de5bc 32Suggests: java-jna
3f05bde6
MK
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
087ae4ed
MK
37Cassandra brings together the distributed systems technologies from
38Dynamo and the data model from Google's BigTable. Like Dynamo,
39Cassandra is eventually consistent. Like BigTable, Cassandra provides
40a ColumnFamily-based data model richer than typical key/value systems.
3f05bde6
MK
41
42%description -l pl.UTF-8
4e6d3cb2
TP
43Cassandra łączy technologie systemów rozproszonych z Dynamo i model
44danych z googlowskiego BigTable. Tak jak Dynamo, Cassandra jest
087ae4ed 45ostatecznie spójna. Tak jak BigTable daje do dyspozycji model danych
4e6d3cb2 46oparty na ColumnFamily, bogatszy niż typowe systemy klucza i wartości.
3f05bde6
MK
47
48%prep
b51a24b8 49%setup -q -n apache-cassandra-%{version}
40af29a9 50%patch0 -p1
93a9c726
MK
51%patch1 -p1
52
53%build
54# current version of cqlsh supports only python 2.
55cd pylib
56%{__python} setup.py build --build-base build-2 %{?with_tests:test}
57cd ..
3f05bde6 58
3f05bde6
MK
59%install
60rm -rf $RPM_BUILD_ROOT
4e6d3cb2 61install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_sysconfdir}/%{shname},%{_bindir},%{_sbindir},%{_datadir}/%{shname}} \
687fc4b6 62 $RPM_BUILD_ROOT/var/{lib/%{shname}/{commitlog,conf,data,saved_caches},{log,run}/%{shname}} \
b4f49f9b 63 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
4e6d3cb2 64
3f05bde6 65install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/cassandra
93a9c726
MK
66
67rm bin/*.bat
68cp -p bin/{cqlsh,*sstable*,*tool,cassandra-cli} $RPM_BUILD_ROOT%{_bindir}
4e6d3cb2
TP
69cp -p bin/cassandra $RPM_BUILD_ROOT%{_sbindir}
70cp -p %{SOURCE1} lib/*.jar $RPM_BUILD_ROOT%{_datadir}/%{shname}
93a9c726
MK
71# use bundled libs for python-cql - from cqlsh doc
72cp -p %{SOURCE1} lib/cql-internal-only-1.4.1.zip $RPM_BUILD_ROOT%{_datadir}/%{shname}
73cp -p %{SOURCE1} lib/thrift-python-internal-only-0.9.1.zip $RPM_BUILD_ROOT%{_datadir}/%{shname}
4e6d3cb2 74cp -p conf/{*.properties,cassandra-env.sh,cassandra.yaml,README.txt} $RPM_BUILD_ROOT/var/lib/%{shname}/conf
3f05bde6 75
b4f49f9b 76install %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{shname}.conf
687fc4b6 77
93a9c726
MK
78cd pylib
79%{__python} setup.py \
80 build --build-base build-2 \
81 install --skip-build \
82 --optimize=2 \
83 --root=$RPM_BUILD_ROOT
84cd ..
85
3f05bde6
MK
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%pre
3f05bde6
MK
90%groupadd -g 259 -r cassandra
91%useradd -M -o -r -u 259 -d /var/lib/%{shname} -s /bin/sh -g cassandra -c "Cassandra Server" cassandra
92
f60c3231
ER
93%post
94/sbin/chkconfig --add cassandra
95%service cassandra restart
96
3f05bde6
MK
97%preun
98if [ "$1" = "0" ]; then
f60c3231
ER
99 %service cassandra stop
100 /sbin/chkconfig --del cassandra
3f05bde6
MK
101fi
102
3f05bde6
MK
103%files
104%defattr(644,root,root,755)
93a9c726 105%doc CHANGES.txt LICENSE.txt NEWS.txt NOTICE.txt
3f05bde6
MK
106%attr(754,root,root) /etc/rc.d/init.d/cassandra
107%attr(755,root,root) %{_bindir}/cassandra-cli
93a9c726 108%attr(755,root,root) %{_bindir}/cqlsh
3f05bde6 109%attr(755,root,root) %{_bindir}/nodetool
3f05bde6
MK
110%attr(755,root,root) %{_bindir}/json2sstable
111%attr(755,root,root) %{_bindir}/sstable2json
b4f49f9b 112%attr(755,root,root) %{_bindir}/sstablescrub
3f05bde6 113%attr(755,root,root) %{_bindir}/sstablekeys
b4f49f9b 114%attr(755,root,root) %{_bindir}/sstableloader
c187b9d9
MGB
115%attr(755,root,root) %{_bindir}/sstablesplit
116%attr(755,root,root) %{_bindir}/sstableupgrade
3f05bde6 117%attr(755,root,root) %{_sbindir}/cassandra
087ae4ed 118%{_datadir}/%{shname}
b4f49f9b 119%{systemdtmpfilesdir}/%{shname}.conf
3f05bde6
MK
120%attr(750,cassandra,cassandra) %dir /var/lib/%{shname}
121%attr(750,root,cassandra) %dir /var/lib/%{shname}/conf
087ae4ed
MK
122%attr(640,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.properties
123%attr(755,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.sh
3f05bde6 124%attr(640,root,cassandra) /var/lib/%{shname}/conf/*.txt
087ae4ed 125%attr(640,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.yaml
3f05bde6 126%attr(750,cassandra,cassandra) %dir /var/log/%{shname}
4e6d3cb2 127%attr(750,cassandra,cassandra) %dir /var/run/%{shname}
93a9c726
MK
128%{py_sitescriptdir}/cqlshlib
129%if "%{py_ver}" > "2.4"
130 %{py_sitescriptdir}/cassandra_pylib-0.0.0-py*.egg-info
131%endif
This page took 0.094674 seconds and 4 git commands to generate.