]> git.pld-linux.org Git - packages/cassandra-bin.git/blame - cassandra-bin.spec
- up to 2.0.6-1
[packages/cassandra-bin.git] / cassandra-bin.spec
CommitLineData
4e6d3cb2 1# TODO: Fix .init cassandra status does not work now.
16c24e02
MK
2# TODO: Fix .init stop routine it is now subset of PLD default one
3# TODO: Fix of data/ cassandra created dirs/files privilages (now they are all readable)
f60c3231 4# TODO: Consider adding
4e6d3cb2 5# cassandra - memlock unlimited
16c24e02 6# to /etc/security/limits.conf ?
3f05bde6 7
4e6d3cb2 8%define shname cassandra
f60c3231 9%include /usr/lib/rpm/macros.java
087ae4ed 10Summary: Cassandra database binary package
4e6d3cb2 11Summary(pl.UTF-8): Binarna redystrybucja bazy danych Cassandra
087ae4ed 12Name: cassandra-bin
c187b9d9 13Version: 2.0.6
b5445178 14Release: 1
3f05bde6
MK
15License: ASF
16Group: Applications/Databases
b4f49f9b 17Source0: ftp://ftp.task.gda.pl/pub/www/apache/dist/cassandra/%{version}/apache-cassandra-%{version}-bin.tar.gz
c187b9d9 18# Source0-md5: c8da1f4f546ea31ab85cfb236374863b
087ae4ed
MK
19Source1: cassandra.in.sh
20Source2: %{shname}.init
687fc4b6 21Source3: %{name}.tmpfiles
40af29a9 22Patch0: %{name}-jamm_path_fix.patch
3f05bde6
MK
23URL: http://cassandra.apache.org/
24BuildRequires: rpm-javaprov
25BuildRequires: rpmbuild(macros) >= 1.300
f60c3231
ER
26Requires(post,preun): /sbin/chkconfig
27Requires: rc-scripts
dd8de5bc 28Suggests: java-jna
3f05bde6
MK
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
087ae4ed
MK
33Cassandra brings together the distributed systems technologies from
34Dynamo and the data model from Google's BigTable. Like Dynamo,
35Cassandra is eventually consistent. Like BigTable, Cassandra provides
36a ColumnFamily-based data model richer than typical key/value systems.
3f05bde6
MK
37
38%description -l pl.UTF-8
4e6d3cb2
TP
39Cassandra łączy technologie systemów rozproszonych z Dynamo i model
40danych z googlowskiego BigTable. Tak jak Dynamo, Cassandra jest
087ae4ed 41ostatecznie spójna. Tak jak BigTable daje do dyspozycji model danych
4e6d3cb2 42oparty na ColumnFamily, bogatszy niż typowe systemy klucza i wartości.
3f05bde6
MK
43
44%prep
b51a24b8 45%setup -q -n apache-cassandra-%{version}
40af29a9 46%patch0 -p1
3f05bde6 47
3f05bde6
MK
48%install
49rm -rf $RPM_BUILD_ROOT
4e6d3cb2 50install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_sysconfdir}/%{shname},%{_bindir},%{_sbindir},%{_datadir}/%{shname}} \
687fc4b6 51 $RPM_BUILD_ROOT/var/{lib/%{shname}/{commitlog,conf,data,saved_caches},{log,run}/%{shname}} \
b4f49f9b 52 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
4e6d3cb2 53
3f05bde6 54install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/cassandra
7d92ab98 55cp -p bin/{*sstable*,*tool,cassandra-cli} $RPM_BUILD_ROOT%{_bindir}
4e6d3cb2
TP
56cp -p bin/cassandra $RPM_BUILD_ROOT%{_sbindir}
57cp -p %{SOURCE1} lib/*.jar $RPM_BUILD_ROOT%{_datadir}/%{shname}
58cp -p conf/{*.properties,cassandra-env.sh,cassandra.yaml,README.txt} $RPM_BUILD_ROOT/var/lib/%{shname}/conf
3f05bde6 59
b4f49f9b 60install %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{shname}.conf
687fc4b6 61
3f05bde6
MK
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%pre
3f05bde6
MK
66%groupadd -g 259 -r cassandra
67%useradd -M -o -r -u 259 -d /var/lib/%{shname} -s /bin/sh -g cassandra -c "Cassandra Server" cassandra
68
f60c3231
ER
69%post
70/sbin/chkconfig --add cassandra
71%service cassandra restart
72
3f05bde6
MK
73%preun
74if [ "$1" = "0" ]; then
f60c3231
ER
75 %service cassandra stop
76 /sbin/chkconfig --del cassandra
3f05bde6
MK
77fi
78
3f05bde6
MK
79%files
80%defattr(644,root,root,755)
81%doc CHANGES.txt LICENSE.txt README.txt NEWS.txt NOTICE.txt
82%attr(754,root,root) /etc/rc.d/init.d/cassandra
83%attr(755,root,root) %{_bindir}/cassandra-cli
84%attr(755,root,root) %{_bindir}/nodetool
3f05bde6
MK
85%attr(755,root,root) %{_bindir}/json2sstable
86%attr(755,root,root) %{_bindir}/sstable2json
b4f49f9b 87%attr(755,root,root) %{_bindir}/sstablescrub
3f05bde6 88%attr(755,root,root) %{_bindir}/sstablekeys
b4f49f9b 89%attr(755,root,root) %{_bindir}/sstableloader
c187b9d9
MGB
90%attr(755,root,root) %{_bindir}/sstablesplit
91%attr(755,root,root) %{_bindir}/sstableupgrade
3f05bde6 92%attr(755,root,root) %{_sbindir}/cassandra
087ae4ed 93%{_datadir}/%{shname}
b4f49f9b 94%{systemdtmpfilesdir}/%{shname}.conf
3f05bde6
MK
95%attr(750,cassandra,cassandra) %dir /var/lib/%{shname}
96%attr(750,root,cassandra) %dir /var/lib/%{shname}/conf
087ae4ed
MK
97%attr(640,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.properties
98%attr(755,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.sh
3f05bde6 99%attr(640,root,cassandra) /var/lib/%{shname}/conf/*.txt
087ae4ed 100%attr(640,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.yaml
3f05bde6 101%attr(750,cassandra,cassandra) %dir /var/log/%{shname}
4e6d3cb2 102%attr(750,cassandra,cassandra) %dir /var/run/%{shname}
This page took 0.146053 seconds and 4 git commands to generate.