]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- added link patch to eliminate linking with -lSM -lICE
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_with     xcb             # enable XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 #
8 Summary:        Cairo - multi-platform 2D graphics library
9 Summary(pl):    Cairo - wieloplatformowa biblioteka graficzna 2D
10 Name:           cairo
11 Version:        1.2.2
12 Release:        1
13 License:        LGPL v2.1 or MPL v1.1
14 Group:          Libraries
15 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  2460487b1257a5583c889b1b9d2033ec
17 Patch0:         %{name}-link.patch
18 URL:            http://cairographics.org/
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake >= 1:1.7
21 BuildRequires:  fontconfig-devel
22 BuildRequires:  freetype-devel >= 1:2.1.10
23 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
25 BuildRequires:  libpng-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 %{?with_xcb:BuildRequires:      libxcb-devel}
29 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
30 BuildRequires:  zlib-devel
31 Requires:       freetype >= 1:2.1.10
32 %{?with_glitz:Requires: glitz >= 0.5.1}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Cairo provides anti-aliased vector-based rendering for X. Paths
37 consist of line segments and cubic splines and can be rendered at any
38 width with various join and cap styles. All colors may be specified
39 with optional translucence (opacity/alpha) and combined using the
40 extended Porter/Duff compositing algebra as found in the X Render
41 Extension.
42
43 Cairo exports a stateful rendering API similar in spirit to the path
44 construction, text, and painting operators of PostScript, (with the
45 significant addition of translucence in the imaging model). When
46 complete, the API is intended to support the complete imaging model of
47 PDF 1.4.
48
49 Cairo relies on the Xc library for backend rendering. Xc provides an
50 abstract interface for rendering to multiple target types. As of this
51 writing, Xc allows Cairo to target X drawables as well as generic
52 image buffers. Future backends such as PostScript, PDF, and perhaps
53 OpenGL are currently being planned.
54
55 %description -l pl
56 Cairo obs³uguje oparty na wektorach rendering z antyaliasingiem dla X.
57 ¦cie¿ki sk³adaj± siê z odcinków i splajnów kubicznych, a renderowane
58 mog± byæ z dowoln± grubo¶ci± i ró¿nymi stylami po³±czeñ i zakoñczeñ.
59 Wszystkie kolory mog± byæ podane z opcjonaln± pó³przezroczysto¶ci±
60 (podan± przez wspó³czynnik nieprzezroczysto¶ci lub alpha) i ³±czone
61 przy u¿yciu rozszerzonego algorytmu mieszania Portera-Duffa, który
62 mo¿na znale¼æ w rozszerzeniu X Render.
63
64 Cairo eksportuje stanowe API renderuj±ce w duchu podobne do operatorów
65 konstruowania ¶cie¿ek, tekstu i rysowania z PostScriptu (ze znacznym
66 dodatkiem pó³przezroczysto¶ci w modelu obrazu). Kiedy API zostanie
67 ukoñczone, ma obs³ugiwaæ pe³ny model obrazu z PDF w wersji 1.4.
68
69 Cairo do backendowego renderowania wykorzystuje bibliotekê Xc. Xc
70 dostarcza abstrakcyjny interfejs do renderowania na wiele rodzajów
71 wyj¶æ. Aktualnie Xc pozwala Cairo tworzyæ obiekty X, a tak¿e ogólne
72 bufory obrazu. W przysz³o¶ci planowane s± takie backendy jak
73 PostScript, PDF i byæ mo¿e OpenGL.
74
75 %package devel
76 Summary:        Development files for Cairo library
77 Summary(pl):    Pliki programistyczne biblioteki Cairo
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       fontconfig-devel
81 Requires:       freetype-devel >= 1:2.1.10
82 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
83 Requires:       libpng-devel
84 %{?with_xcb:Requires:   libxcb-devel}
85 Requires:       xorg-lib-libXrender-devel >= 0.6
86
87 %description devel
88 Development files for Cairo library.
89
90 %description devel -l pl
91 Pliki programistyczne biblioteki Cairo.
92
93 %package static
94 Summary:        Static Cairo library
95 Summary(pl):    Statyczna biblioteka Cairo
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static Cairo library.
101
102 %description static -l pl
103 Statyczna biblioteka Cairo.
104
105 %package apidocs
106 Summary:        Cairo API documentation
107 Summary(pl):    Dokumentacja API Cairo
108 Group:          Documentation
109 Requires:       gtk-doc-common
110
111 %description apidocs
112 Cairo API documentation.
113
114 %description apidocs -l pl
115 Dokumentacja API Cairo. 
116
117 %prep
118 %setup -q
119 %patch0 -p1
120
121 %build
122 %{?with_apidocs:%{__gtkdocize}}
123 %{__libtoolize}
124 %{__aclocal}
125 %{__autoheader}
126 %{__autoconf}
127 %{__automake}
128 %configure \
129         %{?with_apidocs:--enable-gtk-doc} \
130         %{?with_xcb:--enable-xcb} \
131         %{?with_glitz:--enable-glitz} \
132         --enable-ps \
133         --enable-pdf \
134         --with-html-dir=%{_gtkdocdir}
135 %{__make}
136 %{?with_tests:%{__make} check}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 # COPYING contains only notes, not LGPL/MPL texts
153 %doc AUTHORS COPYING ChangeLog NEWS README TODO
154 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/lib*.so
159 %{_libdir}/lib*.la
160 %{_includedir}/*
161 %{_pkgconfigdir}/*.pc
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/lib*.a
166
167 %files apidocs
168 %defattr(644,root,root,755)
169 %{_gtkdocdir}/cairo
This page took 0.365133 seconds and 4 git commands to generate.