]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- separated -gobject* (GObject functions library) for better glib dependency tracking
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %if "%{pld_release}" == "ac"
5 %bcond_with     xcb             # XCB backend
6 %else
7 %bcond_without  xcb             # XCB backend
8 %endif
9 %bcond_with     tests           # perform tests (can fail due to out of memory)
10 #
11 Summary:        Cairo - multi-platform 2D graphics library
12 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
13 Name:           cairo
14 Version:        1.10.0
15 Release:        2
16 License:        LGPL v2.1 or MPL v1.1
17 Group:          Libraries
18 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
19 # Source0-md5:  70a2ece66cf473d976e2db0f75bf199e
20 Patch0:         %{name}-link.patch
21 URL:            http://cairographics.org/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.9.6
24 BuildRequires:  fontconfig-devel >= 2.2.95
25 BuildRequires:  freetype-devel >= 1:2.3.0
26 BuildRequires:  glib2-devel >= 1:2.0
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
28 BuildRequires:  libpng-devel >= 2:1.4.0
29 BuildRequires:  librsvg-devel >= 2.15.0
30 BuildRequires:  libspectre-devel >= 0.2.0
31 BuildRequires:  libtool >= 1.4
32 BuildRequires:  pixman-devel >= 0.18.4
33 BuildRequires:  pkgconfig >= 1:0.9
34 BuildRequires:  poppler-glib-devel >= 0.13.3
35 BuildRequires:  rpm >= 4.4.9-56
36 %if %{with xcb}
37 BuildRequires:  libxcb-devel >= 1.4
38 %endif
39 %if "%{pld_release}" == "ac"
40 BuildRequires:  xrender-devel >= 0.6
41 %else
42 BuildRequires:  xorg-lib-libX11-devel%{?with_xcb: >= 1.1}
43 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
44 %endif
45 BuildRequires:  zlib-devel
46 Requires:       freetype >= 1:2.3.0
47 Requires:       pixman >= 0.18.4
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Cairo provides anti-aliased vector-based rendering for X. Paths
52 consist of line segments and cubic splines and can be rendered at any
53 width with various join and cap styles. All colors may be specified
54 with optional translucence (opacity/alpha) and combined using the
55 extended Porter/Duff compositing algebra as found in the X Render
56 Extension.
57
58 Cairo exports a stateful rendering API similar in spirit to the path
59 construction, text, and painting operators of PostScript, (with the
60 significant addition of translucence in the imaging model). When
61 complete, the API is intended to support the complete imaging model of
62 PDF 1.4.
63
64 %description -l pl.UTF-8
65 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
66 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
67 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
68 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
69 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
70 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
71 można znaleźć w rozszerzeniu X Render.
72
73 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
74 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
75 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
76 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
77
78 %package devel
79 Summary:        Development files for Cairo library
80 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       fontconfig-devel >= 2.2.95
84 Requires:       freetype-devel >= 1:2.3.0
85 Requires:       libpng-devel >= 2:1.4.0
86 %{?with_xcb:Requires:   libxcb-devel >= 1.4}
87 Requires:       pixman-devel >= 0.18.4
88 %if "%{pld_release}" == "ac"
89 Requires:       xrender-devel >= 0.6
90 %else
91 Requires:       xorg-lib-libX11-devel%{?with_xcb: >= 1.1}
92 Requires:       xorg-lib-libXrender-devel >= 0.6
93 %endif
94
95 %description devel
96 Development files for Cairo library.
97
98 %description devel -l pl.UTF-8
99 Pliki programistyczne biblioteki Cairo.
100
101 %package static
102 Summary:        Static Cairo library
103 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description static
108 Static Cairo library.
109
110 %description static -l pl.UTF-8
111 Statyczna biblioteka Cairo.
112
113 %package gobject
114 Summary:        GObject functions library for Cairo graphics library
115 Summary(pl.UTF-8):      Biblioteka funkcji GObject dla biblioteki graficznej Cairo
116 Group:          Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description gobject
120 GObject functions library for Cairo graphics library.
121
122 %description gobject -l pl.UTF-8
123 Biblioteka funkcji GObject dla biblioteki graficznej Cairo.
124
125 %package gobject-devel
126 Summary:        Header files for Cairo GObject library
127 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Cairo GObject
128 Group:          Development/Libraries
129 Requires:       %{name}-devel = %{version}-%{release}
130 Requires:       %{name}-gobject = %{version}-%{release}
131 Requires:       glib2-devel >= 1:2.0
132
133 %description gobject-devel
134 Header files for Cairo GObject library.
135
136 %description gobject-devel -l pl.UTF-8
137 Pliki nagłówkowe biblioteki Cairo GObject.
138
139 %package gobject-static
140 Summary:        Static Cairo GObject library
141 Summary(pl.UTF-8):      Statyczna biblioteka Cairo GObject
142 Group:          Development/Libraries
143 Requires:       %{name}-gobject-devel = %{version}-%{release}
144
145 %description gobject-static
146 Static Cairo GObject library.
147
148 %description gobject-static -l pl.UTF-8
149 Statyczna biblioteka Cairo GObject.
150
151 %package trace
152 Summary:        Cairo calls tracing utility
153 Summary(pl.UTF-8):      Narzędzie do śledzenia wywołań Cairo
154 Group:          Development/Tools
155 Requires:       %{name} = %{version}-%{release}
156
157 %description trace
158 Cairo calls tracing utility.
159
160 %description trace -l pl.UTF-8
161 Narzędzie do śledzenia wywołań Cairo.
162
163 %package apidocs
164 Summary:        Cairo API documentation
165 Summary(pl.UTF-8):      Dokumentacja API Cairo
166 Group:          Documentation
167 Requires:       gtk-doc-common
168
169 %description apidocs
170 Cairo API documentation.
171
172 %description apidocs -l pl.UTF-8
173 Dokumentacja API Cairo.
174
175 %prep
176 %setup -q
177 %patch0 -p1
178
179 %build
180 %{?with_apidocs:%{__gtkdocize}}
181 %{__libtoolize}
182 %{__aclocal} -I build
183 %{__autoheader}
184 %{__autoconf}
185 %{__automake}
186 %configure \
187         --disable-silent-rules \
188         --enable-freetype \
189         %{?with_apidocs:--enable-gtk-doc} \
190         --enable-pdf \
191         --enable-png \
192         --enable-ps \
193         %{?with_xcb:--enable-xcb} \
194         --with-html-dir=%{_gtkdocdir}
195 %{__make}
196 %{?with_tests:%{__make} check}
197
198 %install
199 rm -rf $RPM_BUILD_ROOT
200
201 %{__make} install \
202         DESTDIR=$RPM_BUILD_ROOT
203
204 # LD_PRELOADable library
205 %{__rm} $RPM_BUILD_ROOT%{_libdir}/cairo/libcairo-trace.{la,a}
206
207 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %post   -p /sbin/ldconfig
213 %postun -p /sbin/ldconfig
214
215 %post   gobject -p /sbin/ldconfig
216 %postun gobject -p /sbin/ldconfig
217
218 %files
219 %defattr(644,root,root,755)
220 # COPYING contains only notes, not LGPL/MPL texts
221 %doc AUTHORS COPYING ChangeLog NEWS README
222 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
223 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
224 %attr(755,root,root) %{_libdir}/libcairo-script-interpreter.so.*.*.*
225 %attr(755,root,root) %ghost %{_libdir}/libcairo-script-interpreter.so.2
226
227 %files devel
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/libcairo.so
230 %attr(755,root,root) %{_libdir}/libcairo-script-interpreter.so
231 %{_libdir}/libcairo.la
232 %{_libdir}/libcairo-script-interpreter.la
233 %{_includedir}/cairo
234 %exclude %{_includedir}/cairo/cairo-gobject.h
235 %{_pkgconfigdir}/cairo.pc
236 %{_pkgconfigdir}/cairo-fc.pc
237 %{_pkgconfigdir}/cairo-ft.pc
238 %{_pkgconfigdir}/cairo-pdf.pc
239 %{_pkgconfigdir}/cairo-png.pc
240 %{_pkgconfigdir}/cairo-ps.pc
241 %{_pkgconfigdir}/cairo-svg.pc
242 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
243 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb-shm.pc}
244 %{_pkgconfigdir}/cairo-xlib.pc
245 %{_pkgconfigdir}/cairo-xlib-xrender.pc
246
247 %files static
248 %defattr(644,root,root,755)
249 %{_libdir}/libcairo.a
250 %{_libdir}/libcairo-script-interpreter.a
251
252 %files gobject
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/libcairo-gobject.so.*.*.*
255 %attr(755,root,root) %ghost %{_libdir}/libcairo-gobject.so.2
256
257 %files gobject-devel
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{_libdir}/libcairo-gobject.so
260 %{_libdir}/libcairo-gobject.la
261 %{_includedir}/cairo/cairo-gobject.h
262 %{_pkgconfigdir}/cairo-gobject.pc
263
264 %files gobject-static
265 %defattr(644,root,root,755)
266 %{_libdir}/libcairo-gobject.a
267
268 %files trace
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_bindir}/cairo-trace
271 %dir %{_libdir}/cairo
272 %attr(755,root,root) %{_libdir}/cairo/libcairo-trace.so*
273
274 %if %{with apidocs}
275 %files apidocs
276 %defattr(644,root,root,755)
277 %{_gtkdocdir}/cairo
278 %endif
This page took 0.063023 seconds and 4 git commands to generate.