]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- up to 1.8.6
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %if "%{pld_release}" == "ac"
6 %bcond_with     xcb             # XCB backend
7 %else
8 %bcond_without  xcb             # XCB backend
9 %endif
10 %bcond_with     tests           # perform tests (can fail due to out of memory)
11 #
12 Summary:        Cairo - multi-platform 2D graphics library
13 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
14 Name:           cairo
15 Version:        1.8.6
16 Release:        1
17 License:        LGPL v2.1 or MPL v1.1
18 Group:          Libraries
19 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  4e64139ef6f668df24450f3b81dd0771
21 Patch0:         %{name}-link.patch
22 URL:            http://cairographics.org/
23 BuildRequires:  autoconf >= 2.58
24 BuildRequires:  automake >= 1:1.8
25 BuildRequires:  fontconfig-devel
26 BuildRequires:  freetype-devel >= 1:2.3.0
27 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
29 BuildRequires:  libpng-devel
30 BuildRequires:  libtool
31 BuildRequires:  pixman-devel >= 0.12.0
32 BuildRequires:  pkgconfig
33 BuildRequires:  poppler-glib-devel >= 0.8.0
34 BuildRequires:  rpm >= 4.4.9-56
35 %if %{with xcb}
36 BuildRequires:  libxcb-devel >= 0.9.92
37 BuildRequires:  xcb-util-devel >= 0.2
38 %endif
39 %if "%{pld_release}" == "ac"
40 BuildRequires:  xrender-devel >= 0.6
41 %else
42 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
43 %endif
44 BuildRequires:  zlib-devel
45 Requires:       freetype >= 1:2.3.0
46 %{?with_glitz:Requires: glitz >= 0.5.1}
47 Requires:       pixman >= 0.12.0
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Cairo provides anti-aliased vector-based rendering for X. Paths
52 consist of line segments and cubic splines and can be rendered at any
53 width with various join and cap styles. All colors may be specified
54 with optional translucence (opacity/alpha) and combined using the
55 extended Porter/Duff compositing algebra as found in the X Render
56 Extension.
57
58 Cairo exports a stateful rendering API similar in spirit to the path
59 construction, text, and painting operators of PostScript, (with the
60 significant addition of translucence in the imaging model). When
61 complete, the API is intended to support the complete imaging model of
62 PDF 1.4.
63
64 %description -l pl.UTF-8
65 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
66 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
67 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
68 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
69 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
70 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
71 można znaleźć w rozszerzeniu X Render.
72
73 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
74 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
75 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
76 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
77
78 %package devel
79 Summary:        Development files for Cairo library
80 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       fontconfig-devel
84 Requires:       freetype-devel >= 1:2.3.0
85 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
86 Requires:       libpng-devel
87 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
88 Requires:       pixman-devel >= 0.12.0
89 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
90 %if "%{pld_release}" == "ac"
91 Requires:       xrender-devel >= 0.6
92 %else
93 Requires:       xorg-lib-libXrender-devel >= 0.6
94 %endif
95
96 %description devel
97 Development files for Cairo library.
98
99 %description devel -l pl.UTF-8
100 Pliki programistyczne biblioteki Cairo.
101
102 %package static
103 Summary:        Static Cairo library
104 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}-%{release}
107
108 %description static
109 Static Cairo library.
110
111 %description static -l pl.UTF-8
112 Statyczna biblioteka Cairo.
113
114 %package apidocs
115 Summary:        Cairo API documentation
116 Summary(pl.UTF-8):      Dokumentacja API Cairo
117 Group:          Documentation
118 Requires:       gtk-doc-common
119
120 %description apidocs
121 Cairo API documentation.
122
123 %description apidocs -l pl.UTF-8
124 Dokumentacja API Cairo.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129
130 %build
131 %{?with_apidocs:%{__gtkdocize}}
132 %{__libtoolize}
133 %{__aclocal} -I build
134 %{__autoheader}
135 %{__autoconf}
136 %{__automake}
137 %configure \
138         --enable-freetype \
139         %{?with_glitz:--enable-glitz} \
140         %{?with_apidocs:--enable-gtk-doc} \
141         --enable-pdf \
142         --enable-png \
143         --enable-ps \
144         %{?with_xcb:--enable-xcb} \
145         --with-html-dir=%{_gtkdocdir}
146 %{__make}
147 %{?with_tests:%{__make} check}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 # COPYING contains only notes, not LGPL/MPL texts
166 %doc AUTHORS COPYING ChangeLog NEWS README
167 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libcairo.so
173 %{_libdir}/libcairo.la
174 %{_includedir}/cairo
175 %{_pkgconfigdir}/cairo.pc
176 %{_pkgconfigdir}/cairo-ft.pc
177 %{_pkgconfigdir}/cairo-pdf.pc
178 %{_pkgconfigdir}/cairo-png.pc
179 %{_pkgconfigdir}/cairo-ps.pc
180 %{_pkgconfigdir}/cairo-svg.pc
181 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
182 %{_pkgconfigdir}/cairo-xlib.pc
183 %{_pkgconfigdir}/cairo-xlib-xrender.pc
184
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/libcairo.a
188
189 %if %{with apidocs}
190 %files apidocs
191 %defattr(644,root,root,755)
192 %{_gtkdocdir}/cairo
193 %endif
This page took 0.116354 seconds and 4 git commands to generate.