]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- updated BRs
[packages/cairo.git] / cairo.spec
1 # TODO: qt, drm/gallium, gl backends?
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # disable gtk-doc
5 %if "%{pld_release}" == "ac"
6 %bcond_with     xcb             # XCB backend
7 %else
8 %bcond_without  xcb             # XCB backend
9 %endif
10 %bcond_with     tests           # perform tests (can fail due to out of memory)
11 #
12 Summary:        Cairo - multi-platform 2D graphics library
13 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
14 Name:           cairo
15 Version:        1.10.0
16 Release:        2
17 License:        LGPL v2.1 or MPL v1.1
18 Group:          Libraries
19 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  70a2ece66cf473d976e2db0f75bf199e
21 Patch0:         %{name}-link.patch
22 URL:            http://cairographics.org/
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake >= 1:1.9.6
25 BuildRequires:  fontconfig-devel >= 2.2.95
26 BuildRequires:  freetype-devel >= 1:2.3.0
27 BuildRequires:  glib2-devel >= 1:2.0
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
29 BuildRequires:  libpng-devel >= 2:1.4.0
30 BuildRequires:  librsvg-devel >= 2.15.0
31 BuildRequires:  libspectre-devel >= 0.2.0
32 BuildRequires:  libtool >= 1.4
33 BuildRequires:  pixman-devel >= 0.18.4
34 BuildRequires:  pkgconfig
35 BuildRequires:  poppler-glib-devel >= 0.13.3
36 BuildRequires:  rpm >= 4.4.9-56
37 %if %{with xcb}
38 BuildRequires:  libxcb-devel >= 1.4
39 %endif
40 %if "%{pld_release}" == "ac"
41 BuildRequires:  xrender-devel >= 0.6
42 %else
43 BuildRequires:  xorg-lib-libX11-devel%{?with_xcb: >= 1.1}
44 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
45 %endif
46 BuildRequires:  zlib-devel
47 Requires:       freetype >= 1:2.3.0
48 Requires:       pixman >= 0.18.4
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Cairo provides anti-aliased vector-based rendering for X. Paths
53 consist of line segments and cubic splines and can be rendered at any
54 width with various join and cap styles. All colors may be specified
55 with optional translucence (opacity/alpha) and combined using the
56 extended Porter/Duff compositing algebra as found in the X Render
57 Extension.
58
59 Cairo exports a stateful rendering API similar in spirit to the path
60 construction, text, and painting operators of PostScript, (with the
61 significant addition of translucence in the imaging model). When
62 complete, the API is intended to support the complete imaging model of
63 PDF 1.4.
64
65 %description -l pl.UTF-8
66 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
67 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
68 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
69 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
70 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
71 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
72 można znaleźć w rozszerzeniu X Render.
73
74 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
75 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
76 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
77 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
78
79 %package devel
80 Summary:        Development files for Cairo library
81 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       fontconfig-devel >= 2.2.95
85 Requires:       freetype-devel >= 1:2.3.0
86 Requires:       libpng-devel >= 2:1.4.0
87 %{?with_xcb:Requires:   libxcb-devel >= 1.4}
88 Requires:       pixman-devel >= 0.18.4
89 %if "%{pld_release}" == "ac"
90 Requires:       xrender-devel >= 0.6
91 %else
92 Requires:       xorg-lib-libX11-devel%{?with_xcb: >= 1.1}
93 Requires:       xorg-lib-libXrender-devel >= 0.6
94 %endif
95
96 %description devel
97 Development files for Cairo library.
98
99 %description devel -l pl.UTF-8
100 Pliki programistyczne biblioteki Cairo.
101
102 %package static
103 Summary:        Static Cairo library
104 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}-%{release}
107
108 %description static
109 Static Cairo library.
110
111 %description static -l pl.UTF-8
112 Statyczna biblioteka Cairo.
113
114 %package apidocs
115 Summary:        Cairo API documentation
116 Summary(pl.UTF-8):      Dokumentacja API Cairo
117 Group:          Documentation
118 Requires:       gtk-doc-common
119
120 %description apidocs
121 Cairo API documentation.
122
123 %description apidocs -l pl.UTF-8
124 Dokumentacja API Cairo.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129
130 %build
131 %{?with_apidocs:%{__gtkdocize}}
132 %{__libtoolize}
133 %{__aclocal} -I build
134 %{__autoheader}
135 %{__autoconf}
136 %{__automake}
137 %configure \
138         --disable-silent-rules \
139         --enable-freetype \
140         %{?with_apidocs:--enable-gtk-doc} \
141         --enable-pdf \
142         --enable-png \
143         --enable-ps \
144         %{?with_xcb:--enable-xcb} \
145         --with-html-dir=%{_gtkdocdir}
146 %{__make}
147 %{?with_tests:%{__make} check}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 # COPYING contains only notes, not LGPL/MPL texts
166 %doc AUTHORS COPYING ChangeLog NEWS README
167 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
169 %attr(755,root,root) %{_libdir}/libcairo-gobject.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libcairo-gobject.so.2
171 %attr(755,root,root) %{_libdir}/libcairo-script-interpreter.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libcairo-script-interpreter.so.2
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/cairo-trace
177 %attr(755,root,root) %{_libdir}/libcairo.so
178 %attr(755,root,root) %{_libdir}/libcairo-gobject.so
179 %attr(755,root,root) %{_libdir}/libcairo-script-interpreter.so
180 %dir %{_libdir}/cairo
181 %attr(755,root,root) %{_libdir}/cairo/libcairo-trace.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/cairo/libcairo-trace.so.0
183 %attr(755,root,root) %{_libdir}/cairo/libcairo-trace.so
184 %{_libdir}/libcairo.la
185 %{_libdir}/libcairo-script-interpreter.la
186 %{_includedir}/cairo
187 %{_pkgconfigdir}/cairo.pc
188 %{_pkgconfigdir}/cairo-fc.pc
189 %{_pkgconfigdir}/cairo-ft.pc
190 %{_pkgconfigdir}/cairo-gobject.pc
191 %{_pkgconfigdir}/cairo-pdf.pc
192 %{_pkgconfigdir}/cairo-png.pc
193 %{_pkgconfigdir}/cairo-ps.pc
194 %{_pkgconfigdir}/cairo-svg.pc
195 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
196 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb-shm.pc}
197 %{_pkgconfigdir}/cairo-xlib.pc
198 %{_pkgconfigdir}/cairo-xlib-xrender.pc
199
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/libcairo.a
203 %{_libdir}/libcairo-gobject.a
204 %{_libdir}/libcairo-gobject.la
205 %{_libdir}/libcairo-script-interpreter.a
206
207 %if %{with apidocs}
208 %files apidocs
209 %defattr(644,root,root,755)
210 %{_gtkdocdir}/cairo
211 %endif
This page took 0.060835 seconds and 4 git commands to generate.