]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- move tracing stuff to -devel, release 2.
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %if "%{pld_release}" == "ac"
6 %bcond_with     xcb             # XCB backend
7 %else
8 %bcond_without  xcb             # XCB backend
9 %endif
10 %bcond_with     tests           # perform tests (can fail due to out of memory)
11 #
12 Summary:        Cairo - multi-platform 2D graphics library
13 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
14 Name:           cairo
15 Version:        1.10.0
16 Release:        2
17 License:        LGPL v2.1 or MPL v1.1
18 Group:          Libraries
19 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  70a2ece66cf473d976e2db0f75bf199e
21 Patch0:         %{name}-link.patch
22 URL:            http://cairographics.org/
23 BuildRequires:  autoconf >= 2.58
24 BuildRequires:  automake >= 1:1.8
25 BuildRequires:  fontconfig-devel
26 BuildRequires:  freetype-devel >= 1:2.3.0
27 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
29 BuildRequires:  libpng-devel >= 2:1.4.0
30 BuildRequires:  librsvg-devel >= 2.15.0
31 BuildRequires:  libspectre-devel
32 BuildRequires:  libtool
33 BuildRequires:  pixman-devel >= 0.12.0
34 BuildRequires:  pkgconfig
35 BuildRequires:  poppler-glib-devel >= 0.9.2
36 BuildRequires:  rpm >= 4.4.9-56
37 %if %{with xcb}
38 BuildRequires:  libxcb-devel >= 0.9.92
39 BuildRequires:  xcb-util-devel >= 0.2
40 %endif
41 %if "%{pld_release}" == "ac"
42 BuildRequires:  xrender-devel >= 0.6
43 %else
44 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
45 %endif
46 BuildRequires:  zlib-devel
47 Requires:       freetype >= 1:2.3.0
48 %{?with_glitz:Requires: glitz >= 0.5.1}
49 Requires:       pixman >= 0.12.0
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Cairo provides anti-aliased vector-based rendering for X. Paths
54 consist of line segments and cubic splines and can be rendered at any
55 width with various join and cap styles. All colors may be specified
56 with optional translucence (opacity/alpha) and combined using the
57 extended Porter/Duff compositing algebra as found in the X Render
58 Extension.
59
60 Cairo exports a stateful rendering API similar in spirit to the path
61 construction, text, and painting operators of PostScript, (with the
62 significant addition of translucence in the imaging model). When
63 complete, the API is intended to support the complete imaging model of
64 PDF 1.4.
65
66 %description -l pl.UTF-8
67 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
68 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
69 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
70 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
71 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
72 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
73 można znaleźć w rozszerzeniu X Render.
74
75 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
76 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
77 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
78 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
79
80 %package devel
81 Summary:        Development files for Cairo library
82 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       fontconfig-devel
86 Requires:       freetype-devel >= 1:2.3.0
87 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
88 Requires:       libpng-devel >= 2:1.4.0
89 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
90 Requires:       pixman-devel >= 0.12.0
91 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
92 %if "%{pld_release}" == "ac"
93 Requires:       xrender-devel >= 0.6
94 %else
95 Requires:       xorg-lib-libXrender-devel >= 0.6
96 %endif
97
98 %description devel
99 Development files for Cairo library.
100
101 %description devel -l pl.UTF-8
102 Pliki programistyczne biblioteki Cairo.
103
104 %package static
105 Summary:        Static Cairo library
106 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Static Cairo library.
112
113 %description static -l pl.UTF-8
114 Statyczna biblioteka Cairo.
115
116 %package apidocs
117 Summary:        Cairo API documentation
118 Summary(pl.UTF-8):      Dokumentacja API Cairo
119 Group:          Documentation
120 Requires:       gtk-doc-common
121
122 %description apidocs
123 Cairo API documentation.
124
125 %description apidocs -l pl.UTF-8
126 Dokumentacja API Cairo.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131
132 %build
133 %{?with_apidocs:%{__gtkdocize}}
134 %{__libtoolize}
135 %{__aclocal} -I build
136 %{__autoheader}
137 %{__autoconf}
138 %{__automake}
139 %configure \
140         --enable-freetype \
141         %{?with_glitz:--enable-glitz} \
142         %{?with_apidocs:--enable-gtk-doc} \
143         --enable-pdf=yes \
144         --enable-png \
145         --enable-ps \
146         %{?with_xcb:--enable-xcb} \
147         --with-html-dir=%{_gtkdocdir}
148 %{__make}
149 %{?with_tests:%{__make} check}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 # COPYING contains only notes, not LGPL/MPL texts
168 %doc AUTHORS COPYING ChangeLog NEWS README
169 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
171 %attr(755,root,root) %{_libdir}/libcairo-gobject.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libcairo-gobject.so.2
173 %attr(755,root,root) %{_libdir}/libcairo-script-interpreter.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libcairo-script-interpreter.so.2
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/cairo-trace
179 %attr(755,root,root) %{_libdir}/libcairo.so
180 %attr(755,root,root) %{_libdir}/libcairo-gobject.so
181 %attr(755,root,root) %{_libdir}/libcairo-script-interpreter.so
182 %dir %{_libdir}/cairo
183 %attr(755,root,root) %{_libdir}/cairo/libcairo-trace.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/cairo/libcairo-trace.so.0
185 %attr(755,root,root) %{_libdir}/cairo/libcairo-trace.so
186 %{_libdir}/libcairo.la
187 %{_libdir}/libcairo-script-interpreter.la
188 %{_includedir}/cairo
189 %{_pkgconfigdir}/cairo.pc
190 %{?with_glitz:%{_pkgconfigdir}/cairo-glitz.pc}
191 %{_pkgconfigdir}/cairo-fc.pc
192 %{_pkgconfigdir}/cairo-ft.pc
193 %{_pkgconfigdir}/cairo-gobject.pc
194 %{_pkgconfigdir}/cairo-pdf.pc
195 %{_pkgconfigdir}/cairo-png.pc
196 %{_pkgconfigdir}/cairo-ps.pc
197 %{_pkgconfigdir}/cairo-svg.pc
198 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
199 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb-shm.pc}
200 %{_pkgconfigdir}/cairo-xlib.pc
201 %{_pkgconfigdir}/cairo-xlib-xrender.pc
202
203 %files static
204 %defattr(644,root,root,755)
205 %{_libdir}/libcairo.a
206 %{_libdir}/libcairo-gobject.a
207 %{_libdir}/libcairo-gobject.la
208 %{_libdir}/libcairo-script-interpreter.a
209
210 %if %{with apidocs}
211 %files apidocs
212 %defattr(644,root,root,755)
213 %{_gtkdocdir}/cairo
214 %endif
This page took 0.09522 seconds and 4 git commands to generate.