]> git.pld-linux.org Git - packages/btmgr.git/blob - btmgr.spec
- flags, doc deps
[packages/btmgr.git] / btmgr.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # build documentation
4
5 Summary:        Smart Boot Manager is an OS independent boot manager
6 Name:           btmgr
7 Version:        3.7
8 Release:        0.1
9 License:        GPL v2
10 Group:          Applications/System
11 Source0:        http://downloads.sourceforge.net/btmgr/%{name}-%{version}-1.tar.gz
12 # Source0-md5:  7bfe432821c3cef48df8b3d6be800009
13 URL:            http://sourceforge.net/projects/btmgr/
14 BuildRequires:  nasm
15 BuildRequires:  sed >= 4.0
16 %if %{with doc}
17 BuildRequires:  sgml-tools
18 BuildRequires:  tetex-format-latex
19 %endif
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The main goals of SBM are to be absolutely OS independent, flexible
24 and full-featured. It has all of the features needed to boot a variety
25 of OSes from several kinds of media, while keeping its size no more
26 than 30K bytes. In another words, SBM does NOT touch any of your
27 partitions, it totally fits into the first track (the hidden track) of
28 your hard disk! SBM now supports booting from floppy, hard disk and
29 CD-ROM. There are plans to support ZIP and LS-120 in the near future.
30
31 %prep
32 %setup -q -n %{name}-%{version}-1
33
34 # allow passing defaults
35 %{__sed} -i -e '/^CC=/ s/gcc/$(HOSTCC)/' Makefile
36 %{__sed} -i -e '/^COMMON_FLAGS=/ s/-g/$(CFLAGS)/' Makefile
37 %{__sed} -i -e '/^ASM=/ s/$/ $(AFLAGS)/' Makefile
38
39 # we run docs in bcond
40 %{__sed} -i -e '/^SUBDIRS=/ s/docs//' Makefile
41 # pipe breaks error handling
42 %{__sed} -i -e '/(MAKE)/ s/|tee -a errors.log//' Makefile
43
44 %build
45 %{__make} \
46         HOSTCC="%{__cc}" \
47         CFLAGS="%{rpmcflags}" \
48         AFLAGS="-w-orphan-labels"
49
50 %{?with_doc:%{__make} -C docs}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} install \
55         PREFIX=$RPM_BUILD_ROOT%{_prefix}
56
57 %files
58 %defattr(644,root,root,755)
59 %doc AUTHORS ChangeLog CREDITS INSTALL README TODO
60 %doc(zh) README-ZH
61 %attr(755,root,root) %{_sbindir}/sbminst
62 %{_datadir}/btmgr
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
This page took 0.082167 seconds and 4 git commands to generate.