]> git.pld-linux.org Git - packages/bopm.git/blob - bopm.spec
679eb30500c34442d9b31be5d63dc65c249ebe9a
[packages/bopm.git] / bopm.spec
1 # TODO
2 # - ac that i don't know how to fix:
3 #+ autoconf
4 #configure.in:51: error: possibly undefined macro: AC_FUNC_SNPRINTF
5 #      If this token and others are legitimate, please use m4_pattern_allow.
6 #      See the Autoconf documentation.
7 #
8 #
9 # Conditional build:
10 %bcond_without  tests   # do not perform "make test"
11 %bcond_without  supervise       # install initscript instead of supervise
12 Summary:        Open proxy monitor and blocker, designed for use with ircds
13 Summary(pl.UTF-8):      Monitorowanie i blokowanie otwartych proxy do używania z ircd
14 Name:           bopm
15 Version:        3.1.3
16 Release:        3
17 License:        GPL
18 Group:          Applications/Communications
19 Source0:        http://static.blitzed.org/www.blitzed.org/bopm/files/%{name}-%{version}.tar.gz
20 # Source0-md5:  643c7090b32dfe09a38b5440b2c480e3
21 Source1:        %{name}.init
22 Source2:        %{name}.conf
23 Source3:        %{name}-supervise.tar.bz2
24 # Source3-md5:  247c0438a5e2860097d09a374a521151
25 Source4:        http://autoconf-archive.cryp.to/ac_func_snprintf.m4
26 # Source4-md5:  9a21dbeadbd731b324e7f740aadea697
27 Source5:        http://www.sfr-fresh.com/unix/www/cherokee-0.7.2.tar.gz:t/cherokee-0.7.2/m4/etr_socket_nsl.m4
28 # Source5-md5:  137b516e92db49874d3ed1dcf45ea4a9
29 Patch0:         %{name}-DESTDIR.patch
30 Patch1:         %{name}-shared.patch
31 Patch2:         %{name}-cr-connect.patch
32 Patch3:         http://www.nedworks.org/bopm/%{name}.whitelists.3.1.2.diff
33 Patch4:         http://dgl.cx/2006/09/%{name}-conf-cmd.diff
34 URL:            http://wiki.blitzed.org/BOPM
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  libtool
38 BuildRequires:  rpmbuild(macros) >= 1.268
39 %{!?with_supervise:Requires(post,preun):        /sbin/chkconfig}
40 Requires(postun):       /usr/sbin/groupdel
41 Requires(postun):       /usr/sbin/userdel
42 Requires(pre):  /bin/id
43 Requires(pre):  /usr/bin/getgid
44 Requires(pre):  /usr/sbin/groupadd
45 Requires(pre):  /usr/sbin/useradd
46 Requires:       %{name}-libs = %{version}-%{release}
47 %{?with_supervise:Requires:     daemontools >= 0.76-5}
48 %{!?with_supervise:Requires:    rc-scripts >= 0.4.0.17}
49 Provides:       group(%{name})
50 Provides:       user(%{name})
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _supervise      /etc/supervise/%{name}
54
55 %description
56 The Blitzed Open Proxy Monitor is designed to connect to an IRC server
57 and become an IRC operator. It then watches connect notices in order
58 to scan all connecting clients for open (insecure) proxies. Such
59 insecure proxies are commonly used for spamming, floods and other
60 abusive activities.
61
62 BOPM can detect WinGates, HTTP proxies, SOCKS 4/5 proxies and Cisco
63 routers with default passwords. BOPM also has support for checking
64 against a DNS-Based Blacklist (similar to MAPS RBL) and can be
65 configured to report new proxies back to the Blitzed Open Proxy
66 Monitoring project.
67
68 %description -l pl.UTF-8
69 Blitzed Open Proxy Monitor jest zaprojektowany tak, że łączy się z
70 serwerem IRC i staje operatorem. Następnie ogląda informacje o
71 połączeniach w celu skanowania wszystkich klientów pod kątem otwartych
72 (niebezpiecznych) proxy. Takie niebezpieczne proxy zwykle są używane
73 do spamowania, floodowania i innych nadużyć.
74
75 BOPM jest w stanie wykryć WinGates, proxy HTTP, proxy SOCKS 4/5 oraz
76 routery Cisco z domyślnymi hasłami. BOPM obsługuje także sprawdzanie
77 czarnych list opartych na DNS (takich jak MAPS RBL) i może być
78 skonfigurowany do zgłaszania nowych proxy z powrotem do projektu
79 Blitzed Open Proxy Monitoring.
80
81 %package libs
82 Summary:        libopm open proxy scanning library
83 Summary(pl.UTF-8):      Biblioteka libopm do szukania otwartych proxy
84 Group:          Libraries
85
86 %description libs
87 libopm open proxy scanning library.
88
89 %description libs -l pl.UTF-8
90 Biblioteka libopm do szukania otwartych proxy.
91
92 %package devel
93 Summary:        Header files for libopm library
94 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libopm
95 Group:          Development/Libraries
96 Requires:       %{name}-libs = %{version}-%{release}
97
98 %description devel
99 This is the package containing the header files for libopm library.
100
101 %description devel -l pl.UTF-8
102 Ten pakiet zawiera pliki nagłówkowe biblioteki libopm.
103
104 %package static
105 Summary:        Static libopm library
106 Summary(pl.UTF-8):      Statyczna biblioteka libopm
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Static libopm library.
112
113 %description static -l pl.UTF-8
114 Statyczna biblioteka libopm.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119 %patch1 -p1
120 %patch2 -p0
121 %patch3 -p0
122 cd src
123 %patch4 -p0
124
125 # we include contrib in %doc. cleanup it
126 find -name CVS | xargs -r rm -rf
127 rm -f contrib/bopm.spec
128
129 %build
130 install %{SOURCE4} .
131 install %{SOURCE5} .
132 %{__libtoolize}
133 %{__aclocal} -I .
134 %{__autoconf}
135 %{__autoheader}
136 %{__automake}
137 %configure \
138         --localstatedir=/var/log/%{name} \
139         --bindir=%{_sbindir}
140
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT/var/log/%{name}
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %if %{with supervise}
151 install -d $RPM_BUILD_ROOT%{_supervise}
152 tar xf %{SOURCE3} -C $RPM_BUILD_ROOT%{_supervise}
153
154 install -d $RPM_BUILD_ROOT%{_supervise}/{,log/}supervise
155 touch $RPM_BUILD_ROOT%{_supervise}/{,log/}supervise/lock
156 touch $RPM_BUILD_ROOT%{_supervise}/{,log/}supervise/status
157 mkfifo $RPM_BUILD_ROOT%{_supervise}/{,log/}supervise/control
158 mkfifo $RPM_BUILD_ROOT%{_supervise}/{,log/}supervise/ok
159
160 %else
161 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
162 %endif
163
164 install -d $RPM_BUILD_ROOT/var/run/%{name}
165 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
166 > $RPM_BUILD_ROOT/var/log/%{name}/bopm.log
167 > $RPM_BUILD_ROOT/var/log/%{name}/scan.log
168
169 rm $RPM_BUILD_ROOT%{_datadir}/bopm.conf.blitzed
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %pre
175 %groupadd -g 151 %{name}
176 %useradd -u 151 -c "BOPM Daemon" -g %{name} %{name}
177
178 %post
179 %if %{with supervise}
180 if [ -d /service/%{name}/supervise ]; then
181         svc -t /service/%{name} /service/%{name}/log
182 fi
183 if [ "$1" = 1 ]; then
184         ln -snf %{_supervise} /service/%{name}
185 fi
186 %else
187 /sbin/chkconfig --add %{name}
188 %service %{name} restart "BOPM daemon"
189 %endif
190
191 %preun
192 if [ "$1" = "0" ]; then
193 %if %{with supervise}
194         if [ -d /service/%{name}/supervise ]; then
195                 cd /service/%{name}
196                 rm /service/%{name}
197                 svc -dx . log
198         fi
199 %else
200         %service %{name} stop
201         /sbin/chkconfig --del %{name}
202 %endif
203 fi
204
205 %postun
206 if [ "$1" = "0" ]; then
207         %userremove %{name}
208         %groupremove %{name}
209 fi
210
211 %post   libs -p /sbin/ldconfig
212 %postun libs -p /sbin/ldconfig
213
214 %files
215 %defattr(644,root,root,755)
216 %doc ChangeLog INSTALL README bopm.conf.sample bopm.conf.blitzed
217 %doc contrib/ network-bopm/
218 %attr(640,root,bopm) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
219 %attr(755,root,root) %{_sbindir}/%{name}
220
221 %if %{with supervise}
222 %attr(1755,root,root) %dir %{_supervise}
223 %attr(755,root,root) %{_supervise}/run
224 %attr(700,root,root) %dir %{_supervise}/supervise
225
226 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_supervise}/supervise/*
227 %attr(1755,root,root) %dir %{_supervise}/log
228 %attr(755,root,root) %{_supervise}/log/run
229 %attr(700,root,root) %dir %{_supervise}/log/supervise
230 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_supervise}/log/supervise/*
231 %else
232 %attr(754,root,root) /etc/rc.d/init.d/%{name}
233 %endif
234
235 %attr(770,root,bopm) %dir /var/run/%{name}
236 %attr(770,root,bopm) %dir /var/log/%{name}
237 %attr(640,bopm,bopm) %ghost /var/log/%{name}/bopm.log
238 %attr(640,bopm,bopm) %ghost /var/log/%{name}/scan.log
239
240 %files libs
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_libdir}/libopm.so.*.*.*
243 %attr(755,root,root) %ghost %{_libdir}/libopm.so.0
244
245 %files devel
246 %defattr(644,root,root,755)
247 %{_includedir}/opm.h
248 %{_includedir}/opm_common.h
249 %{_includedir}/opm_error.h
250 %{_includedir}/opm_types.h
251 %{_libdir}/libopm.la
252 %{_libdir}/libopm.so
253
254 %files static
255 %defattr(644,root,root,755)
256 %{_libdir}/libopm.a
This page took 0.053201 seconds and 3 git commands to generate.