]> git.pld-linux.org Git - packages/bmpx.git/commitdiff
- compilation fixes merged.
authorPaweł Sikora <pluto@pld-linux.org>
Sat, 29 Aug 2009 08:47:58 +0000 (08:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bmpx-c++.patch -> 1.1
    bmpx-invalid-conversion.patch -> 1.2
    bmpx.spec -> 1.99

bmpx-c++.patch [new file with mode: 0644]
bmpx-invalid-conversion.patch [deleted file]
bmpx.spec

diff --git a/bmpx-c++.patch b/bmpx-c++.patch
new file mode 100644 (file)
index 0000000..0281c35
--- /dev/null
@@ -0,0 +1,70 @@
+--- bmpx-0.40.13/src/sanity.cc.constcastfix    2007-10-18 19:17:08.000000000 +0200
++++ bmpx-0.40.13/src/sanity.cc 2007-11-29 16:05:38.000000000 +0100
+@@ -72,9 +72,9 @@ C_FUNCTION
+ gchar *
+ sanity_check_gtk (void)
+ {
+-  return gtk_check_version (GTK_REQUIRED_MAJOR_VER,
+-                            GTK_REQUIRED_MINOR_VER,
+-                            GTK_REQUIRED_MICRO_VER);
++  return const_cast<gchar *>(gtk_check_version (GTK_REQUIRED_MAJOR_VER,
++                                              GTK_REQUIRED_MINOR_VER,
++                                              GTK_REQUIRED_MICRO_VER));
+ }
+ static gchar *
+--- bmpx-0.40.14/src/ui-part-library.cc.orig   2008-03-05 22:31:06.000000000 +0100
++++ bmpx-0.40.14/src/ui-part-library.cc        2009-08-29 09:56:40.906222237 +0200
+@@ -509,8 +509,8 @@
+       if( node != NODE_BRANCH )
+       {
+         // Clone this node as one child row
+-        UID uid (Bmp::AlbumArtist ((*i_toplevel)[mStoreArtistCR.artist]).bmpx_album_artist_id);
+         Bmp::AlbumArtist aa ((*i_toplevel)[mStoreArtistCR.artist]);
++        UID uid (aa.bmpx_album_artist_id);
+         UidIterMapIter uid_i = mUidIterMap.find (uid);
+         if( uid_i != mUidIterMap.end() )
+--- bmpx-0.40.14/src/ui-part-library.hh.orig   2008-03-05 22:31:06.000000000 +0100
++++ bmpx-0.40.14/src/ui-part-library.hh        2009-08-29 09:47:47.032596592 +0200
+@@ -464,7 +464,7 @@
+           void
+           print (const char* func)
+           {
+-            printf ("Func: %s\nSize: %llu\n", func, guint64 (mQueue.size()));
++            printf ("Func: %s\nSize: %Zd\n", func, guint64 (mQueue.size()));
+             for (Queue::const_iterator i = mQueue.begin(); i != mQueue.end(); ++i)
+             {
+               if (i == mPosition)
+--- bmpx-0.40.14/src/ui-part-playlist.hh.orig  2008-03-05 22:31:06.000000000 +0100
++++ bmpx-0.40.14/src/ui-part-playlist.hh       2009-08-29 09:49:56.605846457 +0200
+@@ -256,7 +256,7 @@
+           void
+           print (const char* func)
+           {
+-            printf ("Func: %s\nSize: %llu\n", func, guint64 (mQueue.size()));
++            printf ("Func: %s\nSize: %Zd\n", func, guint64 (mQueue.size()));
+             for (Queue::const_iterator i = mQueue.begin(); i != mQueue.end(); ++i)
+             {
+               if (i == mPosition)
+--- bmpx-0.40.14/src/uri.cc.orig       2008-04-06 01:49:24.000000000 +0200
++++ bmpx-0.40.14/src/uri.cc    2009-08-29 09:45:15.116765917 +0200
+@@ -40,6 +40,7 @@
+ #include <glibmm.h>
+ #include <iostream>
+ #include <cstring>
++#include <cstdio>
+ #include "debug.hh"
+ #include "uri.hh"
+--- bmpx-0.40.14/widgets/popup.cc.orig 2008-03-05 22:31:12.000000000 +0100
++++ bmpx-0.40.14/widgets/popup.cc      2009-08-29 09:40:10.893479372 +0200
+@@ -308,7 +308,7 @@
+               if (m_location == ARROW_TOP)
+               {
+-                      Cairo::Matrix matrix = { 1, 0, 0, -1, 0, h };
++                      Cairo::Matrix matrix( 1, 0, 0, -1, 0, h );
+                       cr->set_matrix (matrix);
+               }
diff --git a/bmpx-invalid-conversion.patch b/bmpx-invalid-conversion.patch
deleted file mode 100644 (file)
index 0ff489b..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -up bmpx-0.40.13/src/sanity.cc.constcastfix bmpx-0.40.13/src/sanity.cc
---- bmpx-0.40.13/src/sanity.cc.constcastfix    2007-10-18 19:17:08.000000000 +0200
-+++ bmpx-0.40.13/src/sanity.cc 2007-11-29 16:05:38.000000000 +0100
-@@ -72,9 +72,9 @@ C_FUNCTION
- gchar *
- sanity_check_gtk (void)
- {
--  return gtk_check_version (GTK_REQUIRED_MAJOR_VER,
--                            GTK_REQUIRED_MINOR_VER,
--                            GTK_REQUIRED_MICRO_VER);
-+  return const_cast<gchar *>(gtk_check_version (GTK_REQUIRED_MAJOR_VER,
-+                                              GTK_REQUIRED_MINOR_VER,
-+                                              GTK_REQUIRED_MICRO_VER));
- }
- static gchar *
index e8c17783a25132c7ba221da74b39e5f205768504..00ca1de6d0bdbd03e7a62f8132eee28672cdd748 100644 (file)
--- a/bmpx.spec
+++ b/bmpx.spec
@@ -13,8 +13,8 @@ Source0:      http://files.backtrace.info/releases/0.40/%{name}-%{version}.tar.bz2
 # Source0-md5: c741e05a82a82b14b6775d44a7c93c15
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-libsoup24.patch
-Patch2:                %{name}-invalid-conversion.patch
-Patch3:                %{name}-sidplay.patch
+Patch2:                %{name}-sidplay.patch
+Patch3:                %{name}-c++.patch
 URL:           http://bmpx.backtrace.info/
 BuildRequires: alsa-lib-devel >= 1.0.9
 BuildRequires: autoconf >= 2.60
This page took 0.042644 seconds and 4 git commands to generate.