]> git.pld-linux.org Git - packages/bluez.git/commitdiff
up to 5.68
authorJan Palus <atler@pld-linux.org>
Sat, 1 Jul 2023 22:17:57 +0000 (00:17 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 1 Jul 2023 22:17:57 +0000 (00:17 +0200)
- update obex patch to follow new bluez logic when absolute path ends
  with '/' (use entire path as folder name then) and otherwise behave
  the same as before

0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
bluez.spec

index f79d3ad728c5297ece1cc0a084e732b18e3769b0..1f3b4d30396bc75866f18dfa6fd7e0580b797e78 100644 (file)
@@ -13,11 +13,10 @@ diff --git a/obexd/src/manager.c b/obexd/src/manager.c
 index f84384ae4..285c07c37 100644
 --- a/obexd/src/manager.c
 +++ b/obexd/src/manager.c
-@@ -650,14 +650,14 @@ static void agent_reply(DBusPendingCall *call, void *user_data)
-                               DBUS_TYPE_STRING, &name,
+@@ -645,16 +645,19 @@
                                DBUS_TYPE_INVALID)) {
                /* Splits folder and name */
--              const char *slash = strrchr(name, '/');
+               const char *slash = strrchr(name, '/');
 +              gboolean is_relative = !g_path_is_absolute(name);
                DBG("Agent replied with %s", name);
 -              if (!slash) {
@@ -26,13 +25,17 @@ index f84384ae4..285c07c37 100644
 +                      agent->new_name = g_path_get_basename(name);
                        agent->new_folder = NULL;
                } else {
--                      agent->new_name = g_strdup(slash + 1);
+-                      if (strlen(slash) == 1)
++                      if (slash && strlen(slash) == 1) {
+                               agent->new_name = NULL;
+-                      else
+-                              agent->new_name = g_strdup(slash + 1);
 -                      agent->new_folder = g_strndup(name, slash - name);
-+                      agent->new_name = g_path_get_basename(name);
-+                      agent->new_folder = g_path_get_dirname(name);
++                              agent->new_folder = g_strndup(name, slash - name);
++                      } else {
++                              agent->new_name = g_path_get_basename(name);
++                              agent->new_folder = g_path_get_dirname(name);
++                      }
                }
        }
  
--- 
-2.14.1
-
index e9b70ea218e47f0cfde9561acd684701ecc04c20..63f7fc8d6d2a4e36feb6ddb145fa063800cfcbca 100644 (file)
@@ -8,12 +8,12 @@
 Summary:       Bluetooth utilities
 Summary(pl.UTF-8):     NarzÄ™dzia Bluetooth
 Name:          bluez
-Version:       5.66
+Version:       5.68
 Release:       1
 License:       GPL v2+
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
-# Source0-md5: 3f9496fedf878fba985e56713ed7752e
+# Source0-md5: 00a72fed12e706b2d8bb40786154d3aa
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 # Scripts for automatically btattach-ing serial ports connected to Broadcom HCIs
This page took 0.076254 seconds and 4 git commands to generate.