]> git.pld-linux.org Git - packages/bjorb.git/blob - bjorb.spec
- missing PreR/R added.
[packages/bjorb.git] / bjorb.spec
1 Summary:        Bjorb - secure TCP relay software
2 Name:           bjorb
3 Version:        0.5.5p1
4 Release:        0.1
5 License:        see COPYRIGHT, modified is not distributable
6 Group:          Networking/Daemons
7 Source0:        http://people.FreeBSD.org/~foxfair/distfiles/%{name}-%{version}.tar.gz
8 # Source0-md5:  abea77967a1a0fd2dcd1b407d652b3bf
9 Source1:        %{name}.init
10 Patch0:         %{name}-fbsd_patches.patch
11 Patch1:         %{name}-Makefile.in.patch
12 Patch2:         %{name}-sysconfdir.patch
13 URL:            http://www.hitachi-ms.co.jp/bjorb/
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  openssl-devel
16 PreReq:         rc-scripts
17 Requires(post,preun):   /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Bjorb is secure TCP relay software. Bjorb provides you, secure
22 end-to-end connection over insecure network such as Internet.
23 Features:
24  1. Encrypt/decrypt any "static port" TCP connection with SSL.
25  2. Restrcit access by IP address.
26  3. Server side certification.
27  4. Client side certification.
28
29 %define _sysconfdir /etc/%{name}        
30
31 %prep
32 %setup -q
33 %patch0 -p1
34 %patch1 -p1
35 %patch2 -p1
36
37 %build
38 cd src
39 %{__autoconf}
40 %configure2_13
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 cd src
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/{bjorb.conf.sample,bjorb.conf}
49 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
50 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 /sbin/chkconfig --add %{name}
57 if [ -f /var/lock/subsys/%{name} ]; then
58         /etc/rc.d/init.d/%{name} restart 1>&2
59 else
60         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start Bjorb daemon."
61 fi
62
63 %preun
64 if [ "$1" = "0" ]; then
65         if [ -f /var/lock/subsys/%{name} ]; then
66                 /etc/rc.d/init.d/%{name} stop 1>&2
67         fi
68         /sbin/chkconfig --del %{name}
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc ChangeLog COPYRIGHT README doc/sample/bjorb.conf.doc doc/sample/bjorb.conf.sample
74 %lang(ja) %doc ChangeLog.jp COPYRIGHT.jp README.jp doc/features.jp doc/bjorb.conf.5.jp.txt
75 %attr(755,root,root) %{_sbindir}/*
76 %attr(754,root,root) /etc/rc.d/init.d/%{name}
77 %dir %{_sysconfdir}
78 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
This page took 0.037943 seconds and 3 git commands to generate.