]> git.pld-linux.org Git - packages/bioapi.git/commitdiff
- add patches from gentoo
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 16 Jan 2011 22:45:04 +0000 (22:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bioapi-build.patch -> 1.1
    bioapi-enroll-ret.patch -> 1.1
    bioapi-gcc44.patch -> 1.1
    bioapi-no-delete.patch -> 1.1
    bioapi.spec -> 1.12

bioapi-build.patch [new file with mode: 0644]
bioapi-enroll-ret.patch [new file with mode: 0644]
bioapi-gcc44.patch [new file with mode: 0644]
bioapi-no-delete.patch [new file with mode: 0644]
bioapi.spec

diff --git a/bioapi-build.patch b/bioapi-build.patch
new file mode 100644 (file)
index 0000000..9d679fe
--- /dev/null
@@ -0,0 +1,42 @@
+http://code.google.com/p/bioapi-linux/issues/detail?id=4
+
+--- a/addins/pwbsp/Makefile.in
++++ b/addins/pwbsp/Makefile.in
+@@ -87,7 +87,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include/ \
++AM_CPPFLAGS = -I${top_srcdir}/include/ \
+               -I${top_srcdir}/imports/cdsa/v2_0/inc/
+ CXX = @CXX@
+@@ -111,7 +111,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libpwbsp.ver
+ LEX = @LEX@
+ LEXLIB = @LEXLIB@
+ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
+--- a/addins/qtpwbsp/Makefile.in
++++ b/addins/qtpwbsp/Makefile.in
+@@ -96,7 +96,7 @@ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+-CPPFLAGS = -I${top_srcdir}/include \
++AM_CPPFLAGS = -I${top_srcdir}/include \
+               -I${top_srcdir}/imports/cdsa/v2_0/inc \
+               ${QT_CXXFLAGS}
+@@ -121,7 +121,7 @@ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
++AM_LDFLAGS = -Wl,--version-script=${srcdir}/libqtpwbsp.ver \
+               ${QT_LIBS}
+ LEX = @LEX@
diff --git a/bioapi-enroll-ret.patch b/bioapi-enroll-ret.patch
new file mode 100644 (file)
index 0000000..e077c13
--- /dev/null
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/236654
+
+make sure we return 0 when things work
+
+patch by kouyu
+
+--- bioapi-linux/apps/NonGUI_Sample/main.c
++++ bioapi-linux/apps/NonGUI_Sample/main.c
+@@ -234,6 +234,7 @@
+     }
+     
+     OutputToFile(userName, EnrolledTemplate);
++    return 0;
+   }
+ }
diff --git a/bioapi-gcc44.patch b/bioapi-gcc44.patch
new file mode 100644 (file)
index 0000000..85b5eff
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur bioapi-linux.orig/framework/mds_util_api/mds_app_util.c bioapi-linux/framework/mds_util_api/mds_app_util.c
+--- bioapi-linux.orig/framework/mds_util_api/mds_app_util.c    2007-07-14 08:06:14.000000000 +0300
++++ bioapi-linux/framework/mds_util_api/mds_app_util.c 2009-07-25 23:26:55.000000000 +0300
+@@ -28,7 +28,7 @@
+       /* Linux-Port: added "const" keyword for Linux version */
+ #if defined (UNIX)
+       const BioAPI_UUID MDSUTIL_Uuid = ref_h_layer_uuid_init;
+-#elif
++#else
+       BioAPI_UUID MDSUTIL_Uuid = ref_h_layer_uuid_init;
+ #endif
diff --git a/bioapi-no-delete.patch b/bioapi-no-delete.patch
new file mode 100644 (file)
index 0000000..b5664d1
--- /dev/null
@@ -0,0 +1,15 @@
+do not delete the installed symlink -- let the package manager handle that
+
+--- bioapi-linux/apps/mod_install/install.c
++++ bioapi-linux/apps/mod_install/install.c
+@@ -496,10 +496,6 @@
+                                                       }
+                                                       else if ( Action == INSTALL_ACTION_UNINSTALL )
+                                                       {
+-/* Linux-Port: Added the Linux branch */
+-#if defined (LINUX) || defined (SOLARIS)
+-                                                              DeleteFile(szDstPath);
+-#endif
+                                                               printf( "Module uninstalled successfully.\n" );
+                                                       }
+                                                       else if ( Action == INSTALL_ACTION_REFRESH )
index e22b13ba4c0f11c5502ea0170b6f9fc431136d31..1ebcf8502404921acb3cafbb39486cc0ba9ef9c6 100644 (file)
@@ -13,6 +13,10 @@ License:     BSD
 Group:         Applications/Networking
 Source0:       http://bioapi-linux.googlecode.com/files/%{name}_%{version}.tar.gz
 # Source0-md5: 9bcfb8505a9e4379aa5012300afd3f8c
+Patch0:                %{name}-build.patch
+Patch1:                %{name}-enroll-ret.patch
+Patch2:                %{name}-gcc44.patch
+Patch3:                %{name}-no-delete.patch
 URL:           http://code.google.com/p/bioapi-linux/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1.6
@@ -86,6 +90,10 @@ Przykładowa aplikacja BioAPI w Qt.
 
 %prep
 %setup -q -n %{name}-linux
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
@@ -99,18 +107,17 @@ Przykładowa aplikacja BioAPI w Qt.
 %else
        --without-Qt-dir \
 %endif
-       --includedir=%{_includedir}/%{name} 
+       --includedir=%{_includedir}/%{name}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name},/var/lib/bioapi}
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install imports/cdsa/v2_0/inc/cssmtype.h \
+cp -p imports/cdsa/v2_0/inc/cssmtype.h \
         $RPM_BUILD_ROOT%{_includedir}/%{name}
 
 mv $RPM_BUILD_ROOT%{_bindir}/Sample $RPM_BUILD_ROOT%{_bindir}/BioAPI-Sample
This page took 0.053698 seconds and 4 git commands to generate.