]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
Rel 2; silence one debug message
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_without  lmdb            # LMDB storage support for addzone zones
10 %bcond_without  doh             # DNS over HTTPS support
11 %bcond_with     static_libs     # static libraries
12 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
13 %bcond_with     tests           # unit tests
14 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
15 %bcond_with     hip             # HIP RR support
16
17 %if "%{pld_release}" == "ac"
18 %bcond_with     epoll           # enable epoll support
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll           # disable epoll support
25 %endif
26
27 %define         ver     9.18.9
28 %if 0
29 %define         pverdot .P0
30 %define         pverdir -P0
31 %else
32 %define         pverdot %{nil}
33 %define         pverdir %{nil}
34 %endif
35 Summary:        BIND - DNS name server
36 Summary(de.UTF-8):      BIND - DNS-Namenserver
37 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
38 Summary(fr.UTF-8):      BIND - serveur de noms DNS
39 Summary(pl.UTF-8):      BIND - serwer nazw DNS
40 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
41 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
42 Summary(tr.UTF-8):      DNS alan adı sunucusu
43 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
44 Summary(zh_CN.UTF-8):   Internet 域名服务器
45 Name:           bind
46 Version:        %{ver}%{pverdot}
47 Release:        2
48 Epoch:          7
49 License:        MPL 2.0
50 Group:          Networking/Daemons
51 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
52 # Source0-md5:  542ba7a0ae0cb2de151186bd7de4e9cb
53 Source1:        named.init
54 Source2:        named.sysconfig
55 Source3:        named.logrotate
56 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
57 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
58 Source6:        %{name}-hip.tar.gz
59 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
60 Source7:        https://www.internic.net/domain/named.root
61 # Source7-md5:  f51ae5c1e6f61ef1e45cc4bf0be60414
62 Source8:        %{name}-127.0.0.zone
63 Source9:        %{name}-localhost.zone
64 Source10:       %{name}-named.conf
65 Source11:       %{name}.tmpfiles
66 Source12:       named.service
67
68 Patch2:         debug.patch
69 Patch3:         jemalloc.patch
70 Patch4:         %{name}-ac-libs.patch
71 Patch5:         %{name}-edns-client-subnet.patch
72 URL:            https://www.isc.org/software/bind
73 BuildRequires:  autoconf >= 2.60
74 BuildRequires:  automake
75 BuildRequires:  bison
76 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
77 BuildRequires:  flex
78 %{?with_kerberos5:BuildRequires:        heimdal-devel}
79 BuildRequires:  jemalloc-devel
80 BuildRequires:  json-c-devel >= 0.11
81 BuildRequires:  libatomic-devel
82 BuildRequires:  libcap-devel
83 BuildRequires:  libidn2-devel
84 # note, there is no kyua in PLD yet (work in progress)
85 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
86 BuildRequires:  libtool
87 BuildRequires:  libuv-devel >= 1.37.0
88 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
89 BuildRequires:  libxml2-devel >= 1:2.6.0
90 %{?with_lmdb:BuildRequires:     lmdb-devel}
91 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
92 %{?with_doh:BuildRequires:      nghttp2-devel >= 1.6.0}
93 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
94 BuildRequires:  pkgconfig
95 BuildRequires:  python3-devel >= 1:3.2
96 BuildRequires:  python3-sphinx_rtd_theme
97 BuildRequires:  readline-devel
98 BuildRequires:  rpm >= 4.4.9-56
99 BuildRequires:  rpmbuild(macros) >= 1.647
100 BuildRequires:  sphinx-pdg
101 BuildRequires:  tar >= 1:1.22
102 BuildRequires:  xz
103 BuildRequires:  zlib-devel
104 %if %{with dnstap}
105 BuildRequires:  fstrm-devel
106 BuildRequires:  protobuf-c-devel
107 %endif
108 Requires(post,preun):   /sbin/chkconfig
109 Requires(postun):       /usr/sbin/groupdel
110 Requires(postun):       /usr/sbin/userdel
111 Requires(pre):  /bin/id
112 Requires(pre):  /usr/bin/getgid
113 Requires(pre):  /usr/sbin/groupadd
114 Requires(pre):  /usr/sbin/useradd
115 Requires(pre):  fileutils
116 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
117 Requires:       psmisc >= 20.1
118 Requires:       rc-scripts >= 0.2.0
119 Requires:       systemd-units >= 38
120 Requires:       uname(release) >= 2.2.18
121 Provides:       group(named)
122 Provides:       nameserver
123 Provides:       user(named)
124 Obsoletes:      caching-nameserver
125 Obsoletes:      openldap-schema-bind < 7:9.18.0
126 Obsoletes:      python3-isc < 7:9.18.0
127 Conflicts:      bind-chroot
128 Conflicts:      logrotate < 3.8.0
129 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
130
131 %description
132 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
133 (Domain Name System) protocols. BIND includes a DNS server (named),
134 which resolves host names to IP addresses, and a resolver library
135 (routines for applications to use when interfacing with DNS). A DNS
136 server allows clients to name resources or objects and share the
137 information with other network machines. The named DNS server can be
138 used on workstations as a caching name server, but is generally only
139 needed on one machine for an entire network. Note that the
140 configuration files for making BIND act as a simple caching nameserver
141 are included in the caching-nameserver package.
142
143 Install the bind package if you need a DNS server for your network. If
144 you want bind to act a caching name server, you will also need to
145 install the caching-nameserver package.
146
147 %description -l de.UTF-8
148 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
149 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
150 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
151 Recher des Netzwerks erforderlich.
152
153 %description -l es.UTF-8
154 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
155 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
156 un servidor de nombres caché, pero generalmente sólo hace falta en una
157 máquina para toda la red.
158
159 %description -l fr.UTF-8
160 Contient le serveur de noms named, utilisé pour définir les
161 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
162 utilisé sur les stations de travail comme serveur de nom en cache mais
163 n'est souvent nécessaire que sur une machine pour un réseau entier.
164
165 %description -l pl.UTF-8
166 Pakiet ten zawiera demona named, który służy do zmieniania nazw
167 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
168 roboczych jako bufor odwołań do serwisu nazw (caching name server),
169 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
170 program na fragment sieci.
171
172 %description -l pt_BR.UTF-8
173 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
174 IP (e vice-versa). Pode ser usado em estações de trabalho como um
175 servidor de nomes cache, mas geralmente só é necessário em uma máquina
176 para toda a rede.
177
178 %description -l ru.UTF-8
179 BIND (Berkeley Internet Name Domain) является реализацией протоколов
180 DNS (Domain Name System). BIND включает DNS сервер (named) и
181 библиотеку "резолвера" (подпрограммы для приложений, через которые
182 происходят обращения к DNS). DNS сервер named может быть использован
183 на рабочих станциях как кеширующий сервер, но обычно запускается на
184 одной машине в локальной сети и используется остальными машинами (этим
185 достигается намного более эффективное кеширование).
186
187 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
188 кеширующего сервера, включены в пакет caching-nameserver.
189
190 %description -l tr.UTF-8
191 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
192 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
193 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
194 için sadece bir makina üzerinde kurulur.
195
196 %description -l uk.UTF-8
197 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
198 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
199 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
200 сервер named може бути використаний на робочих станціях як кешируючий
201 сервер, але звичайно запускається на одній машині в локальній мережі і
202 використовується іншими (цим досягається більша ефективність
203 використання кешу).
204
205 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
206 кешируючого серверу, включені в пакет caching-nameserver.
207
208 %package plugins
209 Summary:        Plugins for Bind DNS name server
210 Summary(pl.UTF-8):      Wtyczki dla serwera nazw DNS Bind
211 Group:          Networking/Utilities
212 Requires:       %{name} = %{epoch}:%{version}-%{release}
213
214 %description plugins
215 Plugins for extending of query processing functionality of Bind DNS name
216 server.
217
218 %description plugins -l pl.UTF-8
219 Wtyczki rozszerzające funkcjonalność przetwarzania zapytań przez serwer
220 nazw DNS Bind.
221
222 %package utils
223 Summary:        DNS utils - host, dig, dnsquery, nslookup
224 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
225 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
226 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
227 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
228 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
229 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
230 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
231 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
232 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
233 Group:          Networking/Utilities
234 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
235 Requires:       iconv
236
237 %description utils
238 Bind-utils contains a collection of utilities for querying DNS (Domain
239 Name Service) name servers to find out information about Internet
240 hosts. These tools will provide you with the IP addresses for given
241 host names, as well as other information about registered domains and
242 network addresses.
243
244 You should install bind-utils if you need to get information from DNS
245 name servers.
246
247 %description utils -l de.UTF-8
248 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
249 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
250 Informationen über registrierte Domains und Netzwerk-Adressen.
251
252 %description utils -l es.UTF-8
253 Conjunto de utilitarios para consulta a servidores de nombres. Estas
254 herramientas permiten la determinación de direcciones IP para nombres
255 de máquinas informados y busca información sobre dominios registrados
256 y direcciones de red.
257
258 %description utils -l fr.UTF-8
259 Ensemble d'utilitaires pour interroger les serveurs de noms et
260 rechercher des hôtes. Ces outils vous permettent de déterminer les
261 adresses IP pour des noms d'hôtes donnés, et trouver des informations
262 sur les noms de domaine déclarés et les adresses réseau.
263
264 %description utils -l pl.UTF-8
265 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
266 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
267 i ich adresach IP.
268
269 %description utils -l pt_BR.UTF-8
270 Conjunto de utilitários para consulta a servidores DNS. Estas
271 ferramentas permitem a determinação de endereços IP para nomes de
272 máquinas informados e busca informações sobre domínios registrados e
273 endereços de rede. Você deveria instalar este pacote se necessitar
274 obter informações de servidores DNS.
275
276 %description utils -l ru.UTF-8
277 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
278 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
279 доменному имени (и наоборот) и другую информацию о зарегистрированных
280 доменах и сетевых адресах.
281
282 %description utils -l tr.UTF-8
283 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
284 için kullanılan araçlar bulunmaktadır.
285
286 %description utils -l uk.UTF-8
287 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
288 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
289 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
290 домени та адреси.
291
292 %package libs
293 Summary:        DNS libraries
294 Summary(pl.UTF-8):      Biblioteki DNS
295 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
296 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
297 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
298 Group:          Libraries
299 Requires:       json-c >= 0.11
300 Requires:       libuv >= 1.37.0
301 Requires:       libxml2 >= 1:2.6.0
302 %{?with_doh:Requires:   nghttp2-libs >= 1.6.0}
303
304 %description libs
305 The bind-libs package contains all libraries required for running BIND
306 and bind utils.
307
308 %description libs -l pl.UTF-8
309 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
310 lub programów z pakietu bind-utils.
311
312 %description libs -l ru.UTF-8
313 Библиотеки, необходимые для работы bind.
314
315 %description libs -l uk.UTF-8
316 Бібліотеки, необхідні для роботи bind.
317
318 %package devel
319 Summary:        DNS development includes
320 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
321 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
322 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
323 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
324 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
325 Group:          Development/Libraries
326 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
327
328 %description devel
329 The bind-devel package contains all the include files and symlinks
330 required for DNS (Domain Name Service) development for BIND.
331
332 You should install bind-devel if you want to develop bind DNS
333 applications. If you install bind-devel, you'll also need to install
334 bind-libs.
335
336 %description devel -l es.UTF-8
337 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
338 para el bind.
339
340 %description devel -l pl.UTF-8
341 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
342 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
343 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
344 pakiet.
345
346 %description devel -l pt_BR.UTF-8
347 Todos os arquivos de cabeçalho e bibliotecas necessários para o
348 desenvolvimento com o bind.
349
350 %description devel -l ru.UTF-8
351 Все хедеры и библиотеки, необходимые для написания программ с
352 использованием BIND 9.x.x.
353
354 %description devel -l uk.UTF-8
355 Всі хедери та бібліотеки, необхідні для розробки програм з
356 використанням BIND 9.x.x.
357
358 %package static
359 Summary:        DNS static libs
360 Summary(pl.UTF-8):      Biblioteki statyczne DNS
361 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
362 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
363 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
364 Group:          Development/Libraries
365 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
366
367 %description static
368 Static bind libraries.
369
370 %description static -l pl.UTF-8
371 Statyczne biblioteki binda.
372
373 %description static -l pt_BR.UTF-8
374 Bibliotecas estáticas para desenvolvimento DNS.
375
376 %description static -l ru.UTF-8
377 Статические библиотеки, необходимые для написания программ с
378 использованием BIND.
379
380 %description static -l uk.UTF-8
381 Статичні бібліотеки, необхідні для розробки програм з використанням
382 BIND.
383
384 %prep
385 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
386
387 %patch2 -p1
388 %patch3 -p1
389 %patch4 -p1
390 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
391 %{?with_edns_cli:%patch5 -p0}
392
393 %build
394 %{__libtoolize}
395 %{__aclocal}
396 %{__autoconf}
397 %{__automake}
398 %configure \
399         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
400         LDFLAGS="%{rpmldflags}" \
401         %{?with_dnstap:--enable-dnstap} \
402         %{!?with_doh:--disable-doh} \
403         %{!?with_epoll:--disable-epoll --disable-devpoll} \
404         --enable-full-report \
405         --enable-largefile \
406         %{?with_static_libs:--enable-static} \
407         %{?with_kerberos5:--with-gssapi} \
408         --with-jemalloc=yes \
409         --with-libidn2 \
410         --with-libxml2 \
411         %{?with_ssl:--with-openssl} \
412         %{?with_geoip:--with-maxminddb} \
413         --with-lmdb%{!?with_lmdb:=no} \
414         --with-tuning \
415         --disable-silent-rules
416
417 %{__make}
418 %{__make} -C doc/arm html
419
420 %{?with_hip:%{__make} -C bind-hip}
421
422 %if %{with tests}
423 %if %{with system_tests}
424 %{__make} test-force
425 %else
426 sh unit/unittest.sh
427 %endif
428 %endif
429
430 %install
431 rm -rf $RPM_BUILD_ROOT
432 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
433         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
434         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
435         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
436
437 %{__make} install \
438         DESTDIR=$RPM_BUILD_ROOT
439
440 %{__rm} $RPM_BUILD_ROOT%{_libdir}/bind/filter-*.la
441
442 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
443 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
444 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
445 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
446
447 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
448 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
449 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
450 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
451 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
452 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
453 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
454 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
455
456 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
457 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
458 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
459 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
460
461 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
462
463 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
464 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
465
466 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
467
468 # we don't want Makefiles in documentation...
469 rm -rf _doc
470 cp -a doc _doc
471 %{__rm} _doc/misc/Makefile*
472
473 %clean
474 rm -rf $RPM_BUILD_ROOT
475
476 %pre
477 if [ -f %{_sysconfdir}/named.boot ]; then
478         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
479         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
480         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
481 fi
482 %groupadd -g 58 named
483 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
484
485 %post
486 /sbin/chkconfig --add named
487 %service named restart
488 %systemd_post named.service
489
490 %preun
491 if [ "$1" = "0" ]; then
492         %service named stop
493         /sbin/chkconfig --del named
494 fi
495 %systemd_preun named.service
496
497 %postun
498 if [ "$1" = "0" ]; then
499         %userremove named
500         %groupremove named
501 fi
502 %systemd_reload
503
504 %post   libs -p /sbin/ldconfig
505 %postun libs -p /sbin/ldconfig
506
507 %triggerpostun -- %{name} < 7:9.9.2.P2-2
508 %systemd_trigger named.service
509
510 %files
511 %defattr(644,root,root,755)
512 %doc README.md %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
513 %doc _doc/misc/* _doc/arm/_build/html/*.html
514
515 %{systemdunitdir}/named.service
516 %attr(754,root,root) /etc/rc.d/init.d/named
517 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
518 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
519 %{_sysconfdir}/named.conf
520 %{_sysconfdir}/bind.keys
521
522 %attr(755,root,root) %{_bindir}/dnssec-*
523 %attr(755,root,root) %{_bindir}/named-*
524 %attr(755,root,root) %{_bindir}/nsec3hash
525 %attr(755,root,root) %{_sbindir}/ddns-confgen
526 %attr(755,root,root) %{_sbindir}/named
527 %attr(755,root,root) %{_sbindir}/rndc
528 %attr(755,root,root) %{_sbindir}/rndc-confgen
529 %attr(755,root,root) %{_sbindir}/tsig-keygen
530
531 %{_mandir}/man1/dnssec-*.1*
532 %{_mandir}/man1/named-*.1*
533 %{_mandir}/man1/nsec3hash.1*
534 %{_mandir}/man5/named.conf.5*
535 %{_mandir}/man5/rndc.conf.5*
536 %{_mandir}/man8/ddns-confgen.8*
537 %{_mandir}/man8/named.8*
538 %{_mandir}/man8/rndc.8*
539 %{_mandir}/man8/rndc-confgen.8*
540 %{_mandir}/man8/tsig-keygen.8*
541 %lang(ja) %{_mandir}/ja/man8/named*
542
543 %{systemdtmpfilesdir}/%{name}.conf
544
545 %attr(770,root,named) %dir %{_var}/lib/named
546 %attr(770,root,named) %dir %{_var}/lib/named/D
547 %attr(770,root,named) %dir %{_var}/lib/named/M
548 %attr(770,root,named) %dir %{_var}/lib/named/S
549 %attr(770,root,named) %dir %{_var}/lib/named/dev
550 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
551 %attr(750,root,named) %dir %{_var}/lib/named/etc
552 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
553 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
554 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
555 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
556 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
557 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
558
559 %config(noreplace,missingok) %{_var}/log/named
560 %config(noreplace,missingok) %{_var}/log/named.stats
561
562 %attr(770,root,named) %dir %{_var}/run/named
563
564 %files plugins
565 %defattr(644,root,root,755)
566 %dir %{_libdir}/bind
567 %attr(755,root,root) %{_libdir}/bind/filter-a.so
568 %attr(755,root,root) %{_libdir}/bind/filter-aaaa.so
569 %{_mandir}/man8/filter-a.8*
570 %{_mandir}/man8/filter-aaaa.8*
571
572 %files utils
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_bindir}/arpaname
575 %attr(755,root,root) %{_bindir}/delv
576 %attr(755,root,root) %{_bindir}/dig
577 %attr(755,root,root) %{_bindir}/host
578 %attr(755,root,root) %{_bindir}/named-rrchecker
579 %attr(755,root,root) %{_bindir}/mdig
580 %attr(755,root,root) %{_bindir}/nslookup
581 %attr(755,root,root) %{_bindir}/nsupdate
582 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
583 %{_mandir}/man1/arpaname.1*
584 %{_mandir}/man1/delv.1*
585 %{_mandir}/man1/dig.1*
586 %{_mandir}/man1/host.1*
587 %{_mandir}/man1/mdig.1*
588 %{_mandir}/man1/named-rrchecker.1*
589 %{_mandir}/man1/nslookup.1*
590 %{_mandir}/man1/nsupdate.1*
591
592 %lang(fi) %{_mandir}/fi/man1/host.1*
593
594 %lang(fr) %{_mandir}/fr/man1/host.1*
595
596 %lang(hu) %{_mandir}/hu/man1/host.1*
597
598 %lang(ja) %{_mandir}/ja/man1/dig.1*
599 %lang(ja) %{_mandir}/ja/man1/host.1*
600 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
601 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
602
603 %lang(pl) %{_mandir}/pl/man1/host.1*
604
605 %files libs
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
608 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
609 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
610 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
611 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
612 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
613 %attr(755,root,root) %{_libdir}/libns-%{version}.so
614
615 %files devel
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/libbind9.so
618 %attr(755,root,root) %{_libdir}/libdns.so
619 %attr(755,root,root) %{_libdir}/libirs.so
620 %attr(755,root,root) %{_libdir}/libisc.so
621 %attr(755,root,root) %{_libdir}/libisccc.so
622 %attr(755,root,root) %{_libdir}/libisccfg.so
623 %attr(755,root,root) %{_libdir}/libns.so
624 %{_libdir}/libbind9.la
625 %{_libdir}/libdns.la
626 %{_libdir}/libirs.la
627 %{_libdir}/libisc.la
628 %{_libdir}/libisccc.la
629 %{_libdir}/libisccfg.la
630 %{_libdir}/libns.la
631 %{_includedir}/bind9
632 %{_includedir}/dns
633 %{_includedir}/dst
634 %{_includedir}/irs
635 %{_includedir}/isc
636 %{_includedir}/isccc
637 %{_includedir}/isccfg
638 %{_includedir}/ns
639
640 %if %{with static_libs}
641 %files static
642 %defattr(644,root,root,755)
643 %{_libdir}/libbind9.a
644 %{_libdir}/libdns.a
645 %{_libdir}/libirs.a
646 %{_libdir}/libisc.a
647 %{_libdir}/libisccc.a
648 %{_libdir}/libisccfg.a
649 %{_libdir}/libns.a
650 %endif
This page took 0.10137 seconds and 4 git commands to generate.