]> git.pld-linux.org Git - packages/belle-sip.git/commitdiff
- up to 1.6.3; disable some error checking to get it build auto/th/belle-sip-1.6.3-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 26 Sep 2018 13:37:59 +0000 (15:37 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 26 Sep 2018 13:37:59 +0000 (15:37 +0200)
belle-sip.spec
build.patch [new file with mode: 0644]

index ddbfc6398a30d8405f9a00652e71f44dfdb383e4..70d13b0e134fffe30149eef0485f08b630b466bc 100644 (file)
@@ -8,13 +8,14 @@
 Summary:       SIP (RFC3261) object-oriented implementation in C
 Summary(pl.UTF-8):     Implementacja SIP (RFC3261) w C
 Name:          belle-sip
-Version:       1.4.2
+Version:       1.6.3
 Release:       1
 License:       GPL v2+
 Group:         Libraries
-Source0:       http://download-mirror.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
-# Source0-md5: dbb58649225adefbad87241141fbea93
+Source0:       https://linphone.org/releases/sources/belle-sip/%{name}-%{version}.tar.gz
+# Source0-md5: 90c40812d98671ad2f40621542500bc6
 Patch0:                antlr_jar.patch
+Patch1:                build.patch
 URL:           http://www.linphone.org/
 %{?with_tests:BuildRequires:   CUnit >= 2.0}
 BuildRequires: autoconf >= 2.63
@@ -61,8 +62,9 @@ Static %{name} library.
 Statyczna biblioteka %{name}.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}-0
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -71,7 +73,7 @@ Statyczna biblioteka %{name}.
 %{__autoheader}
 %{__automake}
 %configure \
-       CFLAGS="%{rpmcflags} -Wno-error=pragmas" \
+       CFLAGS="%{rpmcflags} -Wno-error=pragmas -Wno-error=cast-function-type -Wno-implicit-fallthrough -Wno-error=array-bounds" \
        --disable-silent-rules \
        %{!?with_static_libs:--disable-static}
 
@@ -95,7 +97,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS NEWS README
+%doc AUTHORS NEWS README.md
 %attr(755,root,root) %{_libdir}/libbellesip.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libbellesip.so.0
 
diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..e42fc46
--- /dev/null
@@ -0,0 +1,20 @@
+--- belle-sip-1.6.3-0/src/belle_sdp_impl.c~    2016-12-06 15:34:34.000000000 +0100
++++ belle-sip-1.6.3-0/src/belle_sdp_impl.c     2018-09-26 15:32:00.385709065 +0200
+@@ -1053,7 +1053,7 @@ void belle_sdp_media_description_append_
+               current_ptime=belle_sdp_mime_parameter_get_ptime(mime_parameter);
+       }
+       if (current_ptime>0){
+-              char  ptime[10];
++              char  ptime[11];
+               snprintf(ptime,sizeof(ptime),"%i",current_ptime);
+               belle_sdp_media_description_set_attribute_value(media_description,"ptime",ptime);
+       }
+@@ -1062,7 +1062,7 @@ void belle_sdp_media_description_append_
+               current_max_ptime=belle_sdp_mime_parameter_get_max_ptime(mime_parameter);
+       }
+       if (current_max_ptime>0){
+-              char  max_ptime[10];
++              char  max_ptime[11];
+               snprintf(max_ptime,sizeof(max_ptime),"%i",current_max_ptime);
+               belle_sdp_media_description_set_attribute_value(media_description,"maxptime",max_ptime);
+       }
This page took 0.124784 seconds and 4 git commands to generate.