]> git.pld-linux.org Git - packages/belle-sip.git/blob - belle-sip.spec
feb800a4c55c4694eea627d654a9559cac826fc0
[packages/belle-sip.git] / belle-sip.spec
1 # TODO: tunnel? (BR: pkgconfig(tunnel) or TunnelConfig.cmake)
2 #
3 # Conditional build:
4 %bcond_without  dnssd           # MDNS/DNSSD support
5 %bcond_without  static_libs     # static library
6 %bcond_with     tests           # enable tests
7 #
8 Summary:        SIP (RFC3261) object-oriented implementation in C
9 Summary(pl.UTF-8):      Implementacja SIP (RFC3261) w C
10 Name:           belle-sip
11 Version:        4.5.20
12 Release:        2
13 License:        GPL v2+
14 Group:          Libraries
15 #Source0Download: https://gitlab.linphone.org/BC/public/belle-sip/-/tags
16 Source0:        https://gitlab.linphone.org/BC/public/belle-sip/-/archive/%{version}/%{name}-%{version}.tar.bz2
17 # Source0-md5:  57b680975c7c78955bc06b5331f651bf
18 Patch0:         antlr_jar.patch
19 Patch1:         %{name}-pc.patch
20 URL:            http://www.linphone.org/technical-corner/belle-sip
21 %{?with_tests:BuildRequires:    CUnit >= 2.0}
22 BuildRequires:  bctoolbox-devel >= 0.5.0
23 BuildRequires:  cmake >= 3.1
24 BuildRequires:  java-antlr3 >= 3.2
25 BuildRequires:  jre
26 BuildRequires:  libantlr3c-devel >= 3.4
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.605
30 BuildRequires:  zlib-devel >= 1.2.3
31 Requires:       bctoolbox >= 0.5.0
32 Requires:       libantlr3c >= 3.4
33 Requires:       zlib >= 1.2.3
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Belle-sip is a SIP (RFC3261) implementation written in C, with an
38 object oriented API.
39
40 %description -l pl.UTF-8
41 Belle-sip to implementacja SIP (RFC3261) napisana w C z API
42 zorientowanym obiektowo.
43
44 %package devel
45 Summary:        Header files for %{name} library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       bctoolbox-devel >= 0.5.0
50 Requires:       libantlr3c-devel >= 3.4
51
52 %description devel
53 Header files for %{name} library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki %{name}.
57
58 %package static
59 Summary:        Static %{name} library
60 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static %{name} library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka %{name}.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74
75 %build
76 install -d builddir
77 cd builddir
78 %cmake .. \
79         %{?with_dnssd:-DENABLE_MDNS=ON} \
80         %{!?with_static_libs:-DENABLE_STATIC=OFF} \
81         %{!?with_tests:-DENABLE_TESTS=OFF}
82
83 %{__make}
84
85 %{?with_tests:%{__make} test}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} -C builddir install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 # disable completeness check incompatible with split packaging
94 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_libdir}/cmake/BelleSIP/BelleSIPTargets.cmake
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS.md CHANGELOG.md README.md
105 %attr(755,root,root) %{_libdir}/libbellesip.so.1
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libbellesip.so
110 %{_includedir}/belle-sip
111 %{_pkgconfigdir}/belle-sip.pc
112 %{_libdir}/cmake/BelleSIP
113
114 %if %{with static_libs}
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libbellesip.a
118 %endif
This page took 0.148422 seconds and 3 git commands to generate.