]> git.pld-linux.org Git - packages/belle-sip.git/blob - belle-sip.spec
f05f83536e0f1c3ee988ac9d9beae3278a8a63ae
[packages/belle-sip.git] / belle-sip.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_with     tests           # enable tests
5 #
6 Summary:        SIP (RFC3261) object-oriented implementation in C
7 Summary(pl.UTF-8):      Implementacja SIP (RFC3261) w C
8 Name:           belle-sip
9 Version:        1.3.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
14 # Source0-md5:  ae9e8be12f62552a5376edd66b0265d9
15 Patch0:         antlr_jar.patch
16 URL:            http://www.linphone.org/
17 %{?with_tests:BuildRequires:    CUnit >= 2.0}
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  java-antlr3 >= 3.2
21 BuildRequires:  jre
22 BuildRequires:  libantlr3c-devel >= 3.2
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:2
25 BuildRequires:  polarssl-devel >= 1.2
26 BuildRequires:  pkgconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Belle-sip is a SIP (RFC3261) implementation written in C, with an
31 object oriented API.
32
33 %description -l pl.UTF-8
34 Belle-sip to implementacja SIP (RFC3261) napisana w C z API
35 zorientowanym obiektowo.
36
37 %package devel
38 Summary:        Header files for %{name} library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for %{name} library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki %{name}.
48
49 %package static
50 Summary:        Static %{name} library
51 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static %{name} library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka %{name}.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64
65 %build
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 %configure \
72         CFLAGS="%{rpmcflags} -Wno-error=pragmas" \
73         --disable-silent-rules \
74         %{!?with_static_libs:--disable-static}
75
76 %{__make}
77
78 %{?with_tests:%{__make} test}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbellesip.la
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS NEWS README
97 %attr(755,root,root) %{_libdir}/libbellesip.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libbellesip.so.0
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libbellesip.so
103 %{_includedir}/%{name}
104 %{_pkgconfigdir}/%{name}.pc
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libbellesip.a
110 %endif
This page took 0.061984 seconds and 2 git commands to generate.