]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- s#%%{_var}/cache/beagle/index#%{_var}/cache/beagle/indexes#
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.7
25 Release:        5
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  d4c8e93db23c9b7d06104ce97a182502
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-kill_exec_a.patch
33 Patch3:         %{name}-configure.patch
34 Patch4:         %{name}-gtk-sharp.patch
35 Patch5:         %{name}-galago05.patch
36 URL:            http://beaglewiki.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
40 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
41 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
42 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
43 #BuildRequires: dotnet-gst-sharp-devel
44 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.9.0
45 %{?with_epiphany:BuildRequires: epiphany-devel >= 2.15.3}
46 BuildRequires:  gtk+2-devel >= 2:2.9.4
47 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
48 BuildRequires:  libexif-devel >= 0.6.13
49 BuildRequires:  librsvg-devel >= 1:2.15.0
50 BuildRequires:  libpng-devel
51 BuildRequires:  libtool
52 BuildRequires:  libxml2-devel >= 1:2.6.26
53 BuildRequires:  mono-csharp >= 1.1.13.8
54 # not used atm
55 #BuildRequires: mozilla-devel
56 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.9.2}
57 BuildRequires:  pkgconfig
58 BuildRequires:  perl-XML-Parser
59 BuildRequires:  python-devel
60 %if %{with sqlite3}
61 BuildRequires:  sqlite3-devel >= 3.3.4
62 %else
63 BuildRequires:  sqlite-devel
64 %endif
65 BuildRequires:  wv-devel >= 1.2.1
66 BuildRequires:  xorg-lib-libXScrnSaver-devel
67 BuildRequires:  zip
68 # GUI BRs
69 %if %{with gui}
70 BuildRequires:  dotnet-gnome-sharp-devel >= 2.15.0
71 BuildRequires:  gnome-vfs2-devel >= 2.15.2
72 %endif
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       dotnet-gmime-sharp >= 2.2.3
75 %if %{with sqlite3}
76 Requires:       sqlite3
77 %else
78 Requires:       sqlite
79 %endif
80 ExcludeArch:    alpha i386 sparc sparc64
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 Beagle is an indexing sub-system and search aggregator built on top of
85 Lucene.Net.
86
87 %description -l pl
88 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
89 bazie Lucene.Net.
90
91 %package libs
92 Summary:        Beagle libraries
93 Summary(pl):    Bibiloteki Beagle
94 Group:          Libraries
95
96 %description libs
97 Beagle libraries.
98
99 %description libs -l pl
100 Bibiloteki Beagle.
101
102 %package devel
103 Summary:        Beagle development files
104 Summary(pl):    Pliki programistyczne Beagle
105 Group:          Development/Libraries
106 Requires:       %{name}-libs = %{version}-%{release}
107
108 %description devel
109 Beagle development files.
110
111 %description devel -l pl
112 Pliki programistyczne Beagle.
113
114 %package static
115 Summary:        Beagle static libraries
116 Summary(pl):    Statyczne biblioteki Beagle
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119
120 %description static
121 Beagle static libraries.
122
123 %description static -l pl
124 Statyczne biblioteki Beagle.
125
126 %package apidocs
127 Summary:        libbeagle API documentation
128 Summary(pl):    Dokumentacja API libbeagle
129 Group:          Documentation
130 Requires:       gtk-doc-common
131
132 %description apidocs
133 libbeagle API documentation.
134
135 %description apidocs -l pl
136 Dokumentacja API libbeagle.
137
138 %package crawl-system
139 Summary:        Beagle crawl system
140 Summary(pl):    System przeszukuj±cy beagle-crawl
141 Group:          Applications/System
142 Requires:       crondaemon
143 Provides:       group(beagleindex)
144 Provides:       user(beagleindex)
145
146 %description crawl-system
147 Beagle crawl system.
148
149 %description crawl-system -l pl
150 System przeszukuj±cy beagle-crawl.
151
152 %package evolution
153 Summary:        Beagle Evolution backend
154 Summary(pl):    Backend Beagle dla Evolution
155 Group:          X11/Applications/Networking
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       dotnet-evolution-sharp >= 0.11.1
158 Requires:       evolution >= 2.7.3
159
160 %description
161 Beagle Evolution backend.
162
163 %description evolution -l pl
164 Backend Beagle dla Evolution.
165
166 %package -n epiphany-extension-beagle
167 Summary:        Epiphany extension - beagle
168 Summary(pl):    Rozszerzenie dla Epiphany - beagle
169 Group:          X11/Applications/Networking
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       epiphany-extensions >= 2.15.1
172
173 %description -n epiphany-extension-beagle
174 Epiphany extension that allows Beagle to index every page the user
175 views.
176
177 %description -n epiphany-extension-beagle -l pl
178 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
179 odwiedzan± stronê.
180
181 %package -n python-%{name}
182 Summary:        Beagle Python bindings
183 Summary(pl):    Wi±zania jêzyka Python dla Beagle
184 Group:          Libraries/Python
185 Requires:       %{name} = %{version}-%{release}
186 %pyrequires_eq  python-libs
187
188 %description -n python-%{name}
189 Beagle Python bindings.
190
191 %description -n python-%{name} -l pl
192 Wi±zania jêzyka Python dla Beagle.
193
194 %package search-gui
195 Summary:        GNOME based Beagle GUI
196 Summary(pl):    Bazowane na GNOME GUI dla Beagle
197 Group:          Libraries/Python
198 Requires:       %{name} = %{version}-%{release}
199 Requires:       gtk+2 >= 2:2.9.4
200
201 %description search-gui
202 GNOME based Beagle GUI.
203
204 %description search-gui -l pl
205 Bazowane na GNOME GUI dla Beagle.
206
207 %prep
208 %setup -q
209 %patch0 -p1
210 %patch1 -p1
211 %patch2 -p1
212 %patch3 -p1
213 %patch4 -p1
214 %patch5 -p1
215
216 %build
217 %{__libtoolize}
218 %{__aclocal}
219 %{__autoconf}
220 %{__automake}
221 %configure \
222         --enable-static \
223         %{?with_apidocs:--enable-gtk-doc} \
224         --with-html-dir=%{_gtkdocdir} \
225         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
226         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
227         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
228
229 %{__make} \
230         MOZILLA_HOME=%{_libdir}/mozilla \
231         pythondir=%{py_sitedir}
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
236
237 %{__make} install \
238         DESTDIR=$RPM_BUILD_ROOT \
239         pythondir=%{py_sitedir}
240
241 # Kill useless files
242 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
243         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
244
245 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
246 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
247
248 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
249
250 %find_lang %{name}
251
252 %clean
253 rm -rf $RPM_BUILD_ROOT
254
255 %pre crawl-system
256 %groupadd -g 166 -r -f beagleindex
257 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
258
259 %postun crawl-system
260 if [ "$1" = "0" ]; then
261         %userremove beagleindex
262         %groupremove beagleindex
263 fi
264
265 %post   libs -p /sbin/ldconfig
266 %postun libs -p /sbin/ldconfig
267
268 %files -f %{name}.lang
269 %defattr(644,root,root,755)
270 %doc AUTHORS COPYING ChangeLog NEWS README
271 %attr(755,root,root) %{_bindir}/beagle-config
272 %attr(755,root,root) %{_bindir}/beagled
273 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
274 %attr(755,root,root) %{_bindir}/beagle-extract-content
275 %attr(755,root,root) %{_bindir}/beagle-index-info
276 %attr(755,root,root) %{_bindir}/beagle-index-url
277 %attr(755,root,root) %{_bindir}/beagle-info
278 %attr(755,root,root) %{_bindir}/beagle-ping
279 %attr(755,root,root) %{_bindir}/beagle-query
280 %attr(755,root,root) %{_bindir}/beagle-shutdown
281 %attr(755,root,root) %{_bindir}/beagle-status
282 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
283 %attr(755,root,root) %{_libdir}/%{name}/*.exe
284 %dir %{_libdir}/%{name}
285 %dir %{_libdir}/%{name}/Backends
286 %{_libdir}/%{name}/Filters
287 %{_libdir}/%{name}/*.dll*
288 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
289 %{_mandir}/man*/*
290
291 %files libs
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
294
295 %files devel
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/*.so
298 %{_includedir}/libbeagle
299 %{_libdir}/*.la
300 %{_pkgconfigdir}/*
301
302 %files static
303 %defattr(644,root,root,755)
304 %{_libdir}/*.a
305
306 %if %{with apidocs}
307 %files apidocs
308 %defattr(644,root,root,755)
309 %{_gtkdocdir}/beagle
310 %endif
311
312 %files crawl-system
313 %defattr(644,root,root,755)
314 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
315 %dir %{_sysconfdir}/beagle
316 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
317 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
318 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
319 %attr(755,root,root) %{_sbindir}/*
320
321 %if %{with evolution}
322 %files evolution
323 %defattr(644,root,root,755)
324 %{_libdir}/%{name}/Backends/Evolution*
325 %endif
326
327 %if %{with epiphany}
328 %files -n epiphany-extension-beagle
329 %defattr(644,root,root,755)
330 %doc epiphany-extension/README
331 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
332 %{_libdir}/epiphany/1.8/extensions/*.xml
333 %endif
334
335 %if %{with python}
336 %files -n python-%{name}
337 %defattr(644,root,root,755)
338 %attr(755,root,root) %{py_sitedir}/*.so
339 %endif
340
341 %if %{with gui}
342 %files search-gui
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_bindir}/beagle-search
345 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
346 %attr(755,root,root) %{_bindir}/beagle-settings
347 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
348 %{_pixmapsdir}/*.png
349 %{_desktopdir}/*.desktop
350 %endif
This page took 0.061671 seconds and 3 git commands to generate.