]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- updated for 0.3.8
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #       - add qyoto based settings (requires new packages)
5 #       - replace epiphany-extension hack
6 #
7 %include        /usr/lib/rpm/macros.mono
8 #
9 # Conditional build:
10 %bcond_without  apidocs         # don't build API documentation
11 %bcond_with     avahi           # enable Avahi support
12 %bcond_without  evolution       # don't include evolution support
13 %bcond_without  galago          # build without galago support
14 %bcond_without  gsf             # build without libgsf support
15 %bcond_without  gui             # don't build GNOME based GUI
16 %bcond_without  python          # don't build python libraries
17 %bcond_without  epiphany        # don't build epiphany extension
18 %bcond_without  thunderbird     # use Thunderbird backend
19 #
20 %if !%{with gui}
21 %undefine       with_evolution
22 %endif
23 #
24 Summary:        Beagle - An indexing subsystem
25 Summary(pl.UTF-8):      Beagle - podsystem indeksujący
26 Name:           beagle
27 Version:        0.3.7
28 Release:        0.1
29 License:        Various
30 Group:          Libraries
31 Source0:        http://ftp.gnome.org/pub/GNOME/sources/beagle/0.3/%{name}-%{version}.tar.bz2
32 # Source0-md5:  4845f674f540eeb24c09a1be1a5e2459
33 Patch0:         %{name}-desktop.patch
34 Patch1:         %{name}-crawl.patch
35 Patch2:         %{name}-configure.patch
36 URL:            http://beagle-project.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  chmlib-devel
40 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.13.3}
41 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
42 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
43 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.8.1}
44 #BuildRequires: dotnet-gst-sharp-devel
45 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
46 BuildRequires:  dotnet-ndesk-dbus-glib-sharp-devel >= 0.3.0
47 BuildRequires:  dotnet-ndesk-dbus-sharp-devel >= 0.6.0
48 %if %{with epiphany}
49 BuildRequires:  epiphany-devel >= 2.22.0
50 %endif
51 BuildRequires:  gtk+2-devel >= 2:2.10.10
52 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
53 BuildRequires:  libexif-devel >= 0.6.13
54 BuildRequires:  libpng-devel
55 BuildRequires:  librsvg-devel >= 1:2.16.1
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel >= 1:2.6.27
58 BuildRequires:  mono-csharp >= 1.1.13.5
59 BuildRequires:  perl-XML-Parser
60 BuildRequires:  pkgconfig
61 BuildRequires:  python-devel
62 %{?with_python:BuildRequires:   python-pygtk-devel >= 2:2.10.4}
63 BuildRequires:  sqlite3-devel >= 3.3.4
64 BuildRequires:  wv-devel >= 1.2.4
65 BuildRequires:  xorg-lib-libXScrnSaver-devel
66 BuildRequires:  zip
67 # GUI BRs
68 %if %{with gui}
69 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
70 BuildRequires:  gnome-vfs2-devel >= 2.18.0.1
71 %endif
72 Requires:       dotnet-gmime-sharp >= 2.2.3
73 Requires:       dotnet-gsf-sharp
74 Requires:       sqlite3
75 Obsoletes:      beagle-libs
76 Obsoletes:      beagle-static
77 Obsoletes:      python-beagle
78 # sr@Latn vs. sr@latin
79 Conflicts:      glibc-misc < 6:2.7
80 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
81 ExcludeArch:    i386
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 Beagle is an indexing sub-system and search aggregator built on top of
86 Lucene.Net.
87
88 %description -l pl.UTF-8
89 Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
90 bazie Lucene.Net.
91
92 %package debug
93 Summary:        Debug files for the Mono part of Beagle
94 Summary(pl.UTF-8):      Pliki debugujące dla części Mono Beagle'a
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97
98 %description debug
99 Debug files for the Mono part of Beagle.
100
101 %description -l pl.UTF-8
102 Pliki debugujące dla części Mono Beagle'a.
103
104 %package devel
105 Summary:        Beagle development files
106 Summary(pl.UTF-8):      Pliki programistyczne Beagle
107 Group:          Development/Libraries
108 Requires:       %{name} = %{version}-%{release}
109
110 %description devel
111 Beagle development files.
112
113 %description devel -l pl.UTF-8
114 Pliki programistyczne Beagle.
115
116 %package apidocs
117 Summary:        libbeagle API documentation
118 Summary(pl.UTF-8):      Dokumentacja API libbeagle
119 Group:          Documentation
120 Requires:       gtk-doc-common
121
122 %description apidocs
123 libbeagle API documentation.
124
125 %description apidocs -l pl.UTF-8
126 Dokumentacja API libbeagle.
127
128 %package crawl-system
129 Summary:        Beagle crawl system
130 Summary(pl.UTF-8):      System przeszukujący beagle-crawl
131 Group:          Applications/System
132 Requires:       crondaemon
133 Provides:       group(beagleindex)
134 Provides:       user(beagleindex)
135
136 %description crawl-system
137 Beagle crawl system.
138
139 %description crawl-system -l pl.UTF-8
140 System przeszukujący beagle-crawl.
141
142 %package search-gui
143 Summary:        GNOME based Beagle GUI
144 Summary(pl.UTF-8):      Oparty na GNOME graficzny interfejs dla Beagle
145 Group:          Libraries/Python
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       gtk+2 >= 2:2.10.10
148
149 %description search-gui
150 GNOME based Beagle GUI.
151
152 %description search-gui -l pl.UTF-8
153 Oparty na GNOME graficzny interfejs dla Beagle.
154
155 %package startup
156 Summary:        Automatic startup integration for Beagle
157 Summary(pl.UTF-8):      Integracja funkcji automatycznego startu Beagle
158 Group:          X11/Applications
159 Requires:       %{name} = %{version}-%{release}
160 Obsoletes:      beagle-gnome
161
162 %description startup
163 Automatic session startup integration for Beagle.
164
165 %description startup -l pl.UTF-8
166 Integracja funkcji automatycznego startu Beagle.
167
168 %package webinterface
169 Summary:        A web interface for Beagle
170 Summary(pl.UTF-8):      Interfejs sieciowy dla Beagle
171 Group:          Applications
172 Requires:       %{name} = %{version}-%{release}
173
174 %description webinterface
175 An AJAX interface that allows users to search for data through their
176 web browser.
177
178 %description webinterface -l pl.UTF-8
179 AJAX-owy interfejs pozwalający użytkownikom wyszukiwać dane za pomocą
180 przeglądarki internetowej.
181
182 %package evolution
183 Summary:        Beagle Evolution backend
184 Summary(pl.UTF-8):      Backend Beagle dla Evolution
185 Group:          X11/Applications/Networking
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       dotnet-evolution-sharp >= 0.11.1
188 Requires:       evolution >= 2.10.0
189
190 %description evolution
191 Beagle Evolution backend.
192
193 %description evolution -l pl.UTF-8
194 Backend Beagle dla Evolution.
195
196 %package thunderbird
197 Summary:        Beagle Mozilla Thunderbird backend
198 Summary(pl.UTF-8):      Backend Beagle dla Mozilli Thunderbird
199 Group:          X11/Applications/Networking
200 Requires:       %{name} = %{version}-%{release}
201
202 %description thunderbird
203 Beagle Mozilla Thunderbird backend.
204
205 %description thunderbird -l pl.UTF-8
206 Backend Beagle dla Mozilli Thunderbird.
207
208 %package -n epiphany-extension-beagle
209 Summary:        Epiphany extension - beagle
210 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - beagle
211 Group:          X11/Applications/Networking
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       epiphany-extensions >= 2.22.0
214
215 %description -n epiphany-extension-beagle
216 Epiphany extension that allows Beagle to index every page the user
217 views.
218
219 %description -n epiphany-extension-beagle -l pl.UTF-8
220 Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
221 odwiedzaną stronę.
222
223 %package -n mozilla-firefox-extension-beagle
224 Summary:        Mozilla Firefox extension - beagle
225 Summary(pl.UTF-8):      Rozszerzenie dla przeglądarki Mozilla Firefox - beagle
226 Group:          X11/Applications/Networking
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       mozilla-firefox >= 2.0.0.1-2
229
230 %description -n mozilla-firefox-extension-beagle
231 Mozilla Firefox extension that allows Beagle to index every page the
232 user views.
233
234 %description -n mozilla-firefox-extension-beagle -l pl.UTF-8
235 Rozszerzenie dla przeglądarki Mozilla Firefox sprawiające, że Beagle
236 indeksuje każdą odwiedzaną stronę.
237
238 %prep
239 %setup -q
240 %patch0 -p1
241 #%patch1 -p1
242 #%patch2 -p1
243
244 %build
245 %{__intltoolize}
246 %{__libtoolize}
247 %{__aclocal}
248 %{__autoconf}
249 %{__automake}
250 %configure \
251         --disable-static \
252         %{?with_apidocs:--enable-gtk-doc} \
253         --with-html-dir=%{_gtkdocdir} \
254         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
255         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
256         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
257         --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird \
258         --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi
259
260 %{__make}
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
265
266 %{__make} install \
267         DESTDIR=$RPM_BUILD_ROOT \
268         pythondir=%{py_sitedir} \
269         monodocdir=%{_libdir}/monodoc/sources
270
271 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*glue.la
272
273 dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
274 install -d $dest $dest/chrome
275 install firefox-extension/{chrome.manifest,install.rdf} $dest
276 cp -r firefox-extension/chrome/* $dest/chrome
277
278 %if %{with epiphany}
279 install -d $RPM_BUILD_ROOT%{_libdir}/epiphany/2.22/extensions
280 sed -e "s|\@localedir\@|\%{_localedir}|g" \
281         < epiphany-extension/beagle.py.in > epiphany-extension/beagle.py
282 install epiphany-extension/beagle.py $RPM_BUILD_ROOT%{_libdir}/epiphany/2.22/extensions/beagle.py
283 install epiphany-extension/beagle.ephy-extension.in $RPM_BUILD_ROOT%{_libdir}/epiphany/2.22/extensions/beagle.ephy-extension
284 %endif
285
286 %if %{with thunderbird}
287 tdest=$RPM_BUILD_ROOT%{_libdir}/mozilla-thunderbird/extensions/\{b656ef18-fd76-45e6-95cc-8043f26361e7\}
288 install -d $tdest
289 install thunderbird-extension/{chrome.manifest,install.rdf} $tdest
290 cp -r thunderbird-extension/{chrome,components,defaults} $tdest
291 %endif
292
293 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
294         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
295 %find_lang %{name}
296
297 %clean
298 rm -rf $RPM_BUILD_ROOT
299
300 %pre crawl-system
301 %groupadd -g 166 -r -f beagleindex
302 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
303
304 %postun crawl-system
305 if [ "$1" = "0" ]; then
306         %userremove beagleindex
307         %groupremove beagleindex
308 fi
309
310 %files -f %{name}.lang
311 %defattr(644,root,root,755)
312 %doc AUTHORS COPYING ChangeLog NEWS README
313 %attr(755,root,root) %{_bindir}/beagle-config
314 %attr(755,root,root) %{_bindir}/beagle-doc-extractor
315 %attr(755,root,root) %{_bindir}/beagle-extract-content
316 %attr(755,root,root) %{_bindir}/beagle-index-info
317 %attr(755,root,root) %{_bindir}/beagle-info
318 %attr(755,root,root) %{_bindir}/beagle-ping
319 %attr(755,root,root) %{_bindir}/beagle-query
320 %attr(755,root,root) %{_bindir}/beagle-shutdown
321 %attr(755,root,root) %{_bindir}/beagle-static-query
322 %attr(755,root,root) %{_bindir}/beagle-status
323 %attr(755,root,root) %{_bindir}/beagled
324 %attr(755,root,root) %{_bindir}/blocate
325 %attr(755,root,root) %{_libdir}/%{name}/*.exe
326 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
327 %dir %{_libdir}/%{name}
328 %dir %{_libdir}/%{name}/Backends
329 %dir %{_libdir}/%{name}/Filters
330 %{_libdir}/%{name}/*.dll
331 %{_libdir}/%{name}/*.dll.config
332 %{_libdir}/%{name}/Filters/*.dll
333 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
334 %{_mandir}/man1/beagle-config.1*
335 %{_mandir}/man1/beagle-query.1*
336 %{_mandir}/man1/beagle-search.1*
337 %{_mandir}/man1/beagle-shutdown.1*
338 %{_mandir}/man1/beagle-status.1*
339 %{_mandir}/man1/beagled.1*
340
341 %files debug
342 %defattr(644,root,root,755)
343 %{_libdir}/%{name}/Backends/*.mdb
344 %{_libdir}/%{name}/Filters/*.mdb
345 %{_libdir}/%{name}/*.mdb
346
347 %files devel
348 %defattr(644,root,root,755)
349 %{_pkgconfigdir}/beagle-0.0.pc
350 %{_pkgconfigdir}/beagle-ui-0.0.pc
351 %{_pkgconfigdir}/beagle-daemon.pc
352
353 %if %{with apidocs}
354 %files apidocs
355 %defattr(644,root,root,755)
356 %{_libdir}/monodoc/sources/*
357 %endif
358
359 %files crawl-system
360 %defattr(644,root,root,755)
361 %dir %{_sysconfdir}/beagle
362 %dir %{_sysconfdir}/beagle/config-files
363 %dir %{_sysconfdir}/beagle/crawl-rules
364 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/blocate.conf
365 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/query-mapping.xml
366 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/BeagleSearch.xml
367 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Daemon.xml
368 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/FilesQueryable.xml
369 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/GoogleBackends.xml
370 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/config-files/Networking.xml
371 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-applications
372 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-documentation
373 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-manpages
374 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-monodoc
375 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/crawl-rules/crawl-windows
376 # XXX: samples not here
377 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/external-filters.xml.sample
378 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/beagle-crawl-system
379 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
380 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
381 %attr(755,root,root) %{_sbindir}/beagle-build-index
382 %attr(755,root,root) %{_sbindir}/beagle-dump-index
383 %attr(755,root,root) %{_sbindir}/beagle-manage-index
384 %attr(755,root,root) %{_sbindir}/beagle-master-delete-button
385 %{_mandir}/man1/beagle-dump-index.1*
386 %{_mandir}/man8/beagle-build-index.8*
387 %{_mandir}/man8/beagle-extract-content.8*
388 %{_mandir}/man8/beagle-manage-index.8*
389 %{_libdir}/%{name}/Backends/GoogleBackends*.dll
390
391 %if %{with gui}
392 %files search-gui
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
395 %attr(755,root,root) %{_bindir}/beagle-search
396 %attr(755,root,root) %{_bindir}/beagle-settings
397 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
398 %{_mandir}/man8/beagle-imlogviewer.8*
399 %{_desktopdir}/*.desktop
400 %endif
401
402 %files startup
403 %defattr(644,root,root,755)
404 %{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
405 %{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
406
407 %files webinterface
408 %defattr(644,root,root,755)
409 %{_datadir}/%{name}
410
411 %if %{with evolution}
412 %files evolution
413 %defattr(644,root,root,755)
414 %{_libdir}/%{name}/Backends/Evolution*.dll
415 %endif
416
417 %if %{with thunderbird}
418 %files thunderbird
419 %defattr(644,root,root,755)
420 %{_libdir}/%{name}/Backends/Thunderbird*.dll
421 %{_libdir}/mozilla-thunderbird/extensions/{b656ef18-fd76-45e6-95cc-8043f26361e7}
422 %endif
423
424 %if %{with epiphany}
425 %files -n epiphany-extension-beagle
426 %defattr(644,root,root,755)
427 %attr(755,root,root) %{_libdir}/epiphany/2.22/extensions/beagle.py
428 %{_libdir}/epiphany/2.22/extensions/*.ephy-extension
429 %endif
430
431 %files -n mozilla-firefox-extension-beagle
432 %defattr(644,root,root,755)
433 %{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
This page took 0.082029 seconds and 3 git commands to generate.