]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- applied upstream
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.9
25 Release:        1
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  a4d3a7f22fda739f2245b61e77a6a899
30 Source1:        %{name}-autostart.desktop
31 Patch0:         %{name}-desktop.patch
32 Patch1:         %{name}-crawl.patch
33 Patch2:         %{name}-kill_exec_a.patch
34 Patch3:         %{name}-configure.patch
35 Patch4:         %{name}-galago05.patch
36 URL:            http://beaglewiki.org/Main_Page
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.11.1}
40 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel >= 0.5.0}
41 BuildRequires:  dotnet-gmime-sharp-devel >= 2.2.3
42 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
43 #BuildRequires: dotnet-gst-sharp-devel
44 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
45 %if %{with epiphany} 
46 BuildRequires:  epiphany-devel >= 2.14.0
47 BuildRequires:  epiphany-devel < 2.15.0
48 %endif
49 BuildRequires:  gtk+2-devel >= 2:2.10.2
50 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
51 BuildRequires:  libexif-devel >= 0.6.13
52 BuildRequires:  librsvg-devel >= 1:2.16.0
53 BuildRequires:  libpng-devel
54 BuildRequires:  libtool
55 BuildRequires:  libxml2-devel >= 1:2.6.26
56 BuildRequires:  mono-csharp >= 1.1.16.1
57 # not used atm
58 #BuildRequires: mozilla-devel
59 %{?with_python:BuildRequires:   python-pygtk-devel >= 2.9.6}
60 BuildRequires:  pkgconfig
61 BuildRequires:  perl-XML-Parser
62 BuildRequires:  python-devel
63 %if %{with sqlite3}
64 BuildRequires:  sqlite3-devel >= 3.3.4
65 %else
66 BuildRequires:  sqlite-devel
67 %endif
68 BuildRequires:  wv-devel >= 1.2.1
69 BuildRequires:  xorg-lib-libXScrnSaver-devel
70 BuildRequires:  zip
71 # GUI BRs
72 %if %{with gui}
73 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
74 BuildRequires:  gnome-vfs2-devel >= 2.15.92
75 %endif
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       dotnet-gmime-sharp >= 2.2.3
78 %if %{with sqlite3}
79 Requires:       sqlite3
80 %else
81 Requires:       sqlite
82 %endif
83 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
84 ExcludeArch:    i386
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %description
88 Beagle is an indexing sub-system and search aggregator built on top of
89 Lucene.Net.
90
91 %description -l pl
92 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
93 bazie Lucene.Net.
94
95 %package libs
96 Summary:        Beagle libraries
97 Summary(pl):    Bibiloteki Beagle
98 Group:          Libraries
99
100 %description libs
101 Beagle libraries.
102
103 %description libs -l pl
104 Bibiloteki Beagle.
105
106 %package devel
107 Summary:        Beagle development files
108 Summary(pl):    Pliki programistyczne Beagle
109 Group:          Development/Libraries
110 Requires:       %{name}-libs = %{version}-%{release}
111
112 %description devel
113 Beagle development files.
114
115 %description devel -l pl
116 Pliki programistyczne Beagle.
117
118 %package static
119 Summary:        Beagle static libraries
120 Summary(pl):    Statyczne biblioteki Beagle
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description static
125 Beagle static libraries.
126
127 %description static -l pl
128 Statyczne biblioteki Beagle.
129
130 %package apidocs
131 Summary:        libbeagle API documentation
132 Summary(pl):    Dokumentacja API libbeagle
133 Group:          Documentation
134 Requires:       gtk-doc-common
135
136 %description apidocs
137 libbeagle API documentation.
138
139 %description apidocs -l pl
140 Dokumentacja API libbeagle.
141
142 %package crawl-system
143 Summary:        Beagle crawl system
144 Summary(pl):    System przeszukuj±cy beagle-crawl
145 Group:          Applications/System
146 Requires:       crondaemon
147 Provides:       group(beagleindex)
148 Provides:       user(beagleindex)
149
150 %description crawl-system
151 Beagle crawl system.
152
153 %description crawl-system -l pl
154 System przeszukuj±cy beagle-crawl.
155
156 %package evolution
157 Summary:        Beagle Evolution backend
158 Summary(pl):    Backend Beagle dla Evolution
159 Group:          X11/Applications/Networking
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       dotnet-evolution-sharp >= 0.11.1
162 Requires:       evolution >= 2.7.92
163
164 %description
165 Beagle Evolution backend.
166
167 %description evolution -l pl
168 Backend Beagle dla Evolution.
169
170 %package thunderbird
171 Summary:        Beagle Mozilla Thunderbird backend
172 Summary(pl):    Backend Beagle dla Mozilli Thunderbird
173 Group:          X11/Applications/Networking
174 Requires:       %{name} = %{version}-%{release}
175
176 %description thunderbird
177 Beagle Mozilla Thunderbird backend.
178
179 %description thunderbird -l pl
180 Backend Beagle dla Mozilli Thunderbird.
181
182 %package -n epiphany-extension-beagle
183 Summary:        Epiphany extension - beagle
184 Summary(pl):    Rozszerzenie dla Epiphany - beagle
185 Group:          X11/Applications/Networking
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       epiphany-extensions >= 2.15.2
188
189 %description -n epiphany-extension-beagle
190 Epiphany extension that allows Beagle to index every page the user
191 views.
192
193 %description -n epiphany-extension-beagle -l pl
194 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
195 odwiedzan± stronê.
196
197 %package -n python-%{name}
198 Summary:        Beagle Python bindings
199 Summary(pl):    Wi±zania jêzyka Python dla Beagle
200 Group:          Libraries/Python
201 Requires:       %{name} = %{version}-%{release}
202 %pyrequires_eq  python-libs
203
204 %description -n python-%{name}
205 Beagle Python bindings.
206
207 %description -n python-%{name} -l pl
208 Wi±zania jêzyka Python dla Beagle.
209
210 %package search-gui
211 Summary:        GNOME based Beagle GUI
212 Summary(pl):    Bazowane na GNOME GUI dla Beagle
213 Group:          Libraries/Python
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       gtk+2 >= 2:2.10.2
216
217 %description search-gui
218 GNOME based Beagle GUI.
219
220 %description search-gui -l pl
221 Bazowane na GNOME GUI dla Beagle.
222
223 %package startup
224 Summary:        Automatic startup integration for Beagle
225 Summary(pl):    Integracja funkcji automatycznego startu Beagle
226 Group:          X11/Applications
227 Requires:       %{name} = %{version}-%{release}
228
229 %description startup
230 Automatic session startup integration for Beagle.
231
232 %description startup -l pl
233 Integracja funkcji automatycznego startu Beagle.
234
235 %prep
236 %setup -q
237 %patch0 -p1
238 %patch1 -p1
239 %patch2 -p1
240 %patch3 -p1
241 %patch4 -p1
242
243 %build
244 %{__libtoolize}
245 %{__aclocal}
246 %{__autoconf}
247 %{__automake}
248 %configure \
249         --enable-static \
250         %{?with_apidocs:--enable-gtk-doc} \
251         --with-html-dir=%{_gtkdocdir} \
252         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
253         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
254         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
255
256 %{__make} \
257         MOZILLA_HOME=%{_libdir}/mozilla \
258         pythondir=%{py_sitedir}
259
260 %install
261 rm -rf $RPM_BUILD_ROOT
262 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
263 install -d $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart
264
265 %{__make} install \
266         DESTDIR=$RPM_BUILD_ROOT \
267         pythondir=%{py_sitedir}
268
269 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart
270
271 # Kill useless files
272 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
273         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
274
275 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
276 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
277
278 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
279
280 %find_lang %{name}
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %pre crawl-system
286 %groupadd -g 166 -r -f beagleindex
287 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
288
289 %postun crawl-system
290 if [ "$1" = "0" ]; then
291         %userremove beagleindex
292         %groupremove beagleindex
293 fi
294
295 %post   libs -p /sbin/ldconfig
296 %postun libs -p /sbin/ldconfig
297
298 %files -f %{name}.lang
299 %defattr(644,root,root,755)
300 %doc AUTHORS COPYING ChangeLog NEWS README
301 %attr(755,root,root) %{_bindir}/beagle-config
302 %attr(755,root,root) %{_bindir}/beagled
303 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
304 %attr(755,root,root) %{_bindir}/beagle-extract-content
305 %attr(755,root,root) %{_bindir}/beagle-index-info
306 %attr(755,root,root) %{_bindir}/beagle-index-url
307 %attr(755,root,root) %{_bindir}/beagle-info
308 %attr(755,root,root) %{_bindir}/beagle-ping
309 %attr(755,root,root) %{_bindir}/beagle-query
310 %attr(755,root,root) %{_bindir}/beagle-shutdown
311 %attr(755,root,root) %{_bindir}/beagle-status
312 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
313 %attr(755,root,root) %{_libdir}/%{name}/*.exe
314 %dir %{_libdir}/%{name}
315 %dir %{_libdir}/%{name}/Backends
316 %dir %{_libdir}/%{name}/Filters
317 %{_libdir}/%{name}/*.dll
318 %{_libdir}/%{name}/*.dll.config
319 %{_libdir}/%{name}/Filters/*.dll
320 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
321 %{_mandir}/man*/*
322
323 %files libs
324 %defattr(644,root,root,755)
325 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
326
327 %files devel
328 %defattr(644,root,root,755)
329 %attr(755,root,root) %{_libdir}/*.so
330 %{_includedir}/libbeagle
331 %{_libdir}/*.la
332 %{_pkgconfigdir}/*
333
334 %files static
335 %defattr(644,root,root,755)
336 %{_libdir}/*.a
337
338 %if %{with apidocs}
339 %files apidocs
340 %defattr(644,root,root,755)
341 %{_gtkdocdir}/beagle
342 %endif
343
344 %files crawl-system
345 %defattr(644,root,root,755)
346 %attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
347 %dir %{_sysconfdir}/beagle
348 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
349 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
350 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
351 %attr(755,root,root) %{_sbindir}/*
352
353 %if %{with evolution}
354 %files evolution
355 %defattr(644,root,root,755)
356 %{_libdir}/%{name}/Backends/Evolution*.dll
357 %endif
358
359 %files thunderbird
360 %defattr(644,root,root,755)
361 %{_libdir}/%{name}/Backends/Thunderbird*.dll
362
363 %if %{with epiphany}
364 %files -n epiphany-extension-beagle
365 %defattr(644,root,root,755)
366 %doc epiphany-extension/README
367 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
368 %{_libdir}/epiphany/1.8/extensions/*.xml
369 %endif
370
371 %if %{with python}
372 %files -n python-%{name}
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{py_sitedir}/*.so
375 %endif
376
377 %if %{with gui}
378 %files search-gui
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_bindir}/beagle-contactviewer
381 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
382 %attr(755,root,root) %{_bindir}/beagle-search
383 %attr(755,root,root) %{_bindir}/beagle-settings
384 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
385 %{_pixmapsdir}/*.png
386 %{_desktopdir}/*.desktop
387 %endif
388
389 %files startup
390 %defattr(644,root,root,755)
391 %{_sysconfdir}/xdg/autostart/beagle-autostart.desktop
This page took 0.113795 seconds and 3 git commands to generate.