]> git.pld-linux.org Git - packages/bcc-bpf.git/commitdiff
up to 0.7.0
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 30 Dec 2018 19:39:48 +0000 (21:39 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Sun, 30 Dec 2018 20:34:15 +0000 (22:34 +0200)
bcc-bpf.spec

index da320f3c9e0227a950a42929246a0abf8577a32a..650a72f1aa5596eff1f364ca578d44d0e5f4b4ca 100644 (file)
@@ -1,43 +1,67 @@
+#
+# Conditional build:
+%bcond_without lua             # build without tests
+
+# luajit is not available for some architectures
+%ifnarch %{ix86} %{x8664} %{arm} mips ppc
+%undefine      with_lua
+%endif
+
 Summary:       Tools for BPF-based Linux IO analysis, networking, monitoring, and more
 Name:          bcc-bpf
-Version:       0.2.0
+Version:       0.7.0
 Release:       0.1
 License:       Apache v2.0
-Group:         Development/Languages
-URL:           https://github.com/iovisor/bcc
-Source0:       https://github.com/iovisor/bcc/archive/v%{version}.tar.gz
-# Source0-md5: eed71341f397c72a50b45b376060b17d
+Group:         Applications
+Source0:       https://github.com/iovisor/bcc/archive/v%{version}/bcc-%{version}.tar.gz
+# Source0-md5: 79a445aa6542bcc260fd38af3402a77d
+URL:           https://iovisor.github.io/bcc/
 BuildRequires: bison
 BuildRequires: cmake >= 2.8.7
 BuildRequires: elfutils-libelf-devel-static
 BuildRequires: flex
 BuildRequires: gcc
 BuildRequires: libstdc++-devel
+%{?with_lua:BuildRequires: pkgconfig(luajit)}
 BuildRequires: python-devel
+ExclusiveArch: %{ix86} %{x8664} power64
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Python bindings for BPF Compiler Collection (BCC). Control a BPF
-program from userspace.
+BCC is a toolkit for creating efficient kernel tracing and
+manipulation programs, and includes several useful tools and examples.
+It makes use of extended BPF (Berkeley Packet Filters), formally known
+as eBPF, a new feature that was first added to Linux 3.15. BCC makes
+BPF programs easier to write, with kernel instrumentation in C (and
+includes a C wrapper around LLVM), and front-ends in Python and LUA.
+
+It is suited for many tasks, including performance analysis and
+network traffic control.
 
 %package libs
+Summary:       Shared Library for BPF Compiler Collection (BCC)
+Group:         Libraries
+
 %description libs
 Shared Library for BPF Compiler Collection (BCC)
 
 %package -n python-%{name}
 Summary:       Python bindings to %{name}
-Summary:       libraries for %{name}
+Group:         Libraries/Python
 
 %description -n python-%{name}
 Python bindings for BPF Compiler Collection (BCC)
 
 %package tools
 Summary:       Tools for BPF Compiler Collection (BCC)
+Group:         Applications
 
 %description tools
 Command line tools for BPF Compiler Collection (BCC)
 
 %package -n lua-%{name}
 Summary:       LUA bindings to %{name}
+Group:         Applications
 
 %description -n lua-%{name}
 Standalone tool to run BCC tracers written in Lua
@@ -53,7 +77,6 @@ cd build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
This page took 0.117692 seconds and 4 git commands to generate.