]> git.pld-linux.org Git - packages/banshee.git/blob - banshee.spec
- added patch from BGO #410116 to fix spurious trailing commas on
[packages/banshee.git] / banshee.spec
1 # ToDo:
2 #       - make some proper bconds for other it
3 #
4 %include /usr/lib/rpm/macros.mono
5 #
6
7 Summary:        A Mono/GStreamer Based Music Player
8 Summary(pl.UTF-8):      Oparty na Mono/GStreamerze odtwarzacz muzyki
9 Name:           banshee
10 Version:        0.12.1
11 Release:        0.2
12 License:        GPL
13 Group:          Applications/Multimedia
14 Source0:        http://banshee-project.org/files/banshee/%{name}-%{version}.tar.gz
15 # Source0-md5:  6bcfe0a4ca92e6cce86244938f004b8c
16 Patch0:         %{name}-spurious_trailing_comma.patch
17 URL:            http://banshee-project.org/
18 BuildRequires:  GConf2-devel
19 BuildRequires:  autoconf >= 2.13
20 BuildRequires:  automake
21 BuildRequires:  dbus-devel >= 0.93
22 BuildRequires:  dbus-glib-devel >= 0.71
23 BuildRequires:  dotnet-avahi-devel
24 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
25 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
26 BuildRequires:  gnome-desktop-devel >= 2.16.0
27 BuildRequires:  gstreamer-cdparanoia
28 BuildRequires:  gstreamer-devel >= 0.10.3
29 BuildRequires:  gstreamer-gnomevfs
30 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.3
31 BuildRequires:  gtk+2-devel >= 2.10.3
32 BuildRequires:  hal-devel >= 0.5.2
33 BuildRequires:  intltool >= 0.35
34 BuildRequires:  libmusicbrainz-devel >= 2.1.1
35 BuildRequires:  libtool
36 BuildRequires:  mono-csharp >= 1.1.13
37 BuildRequires:  monodoc
38 BuildRequires:  nautilus-cd-burner-devel >= 2.16.0
39 BuildRequires:  pkgconfig
40 BuildRequires:  sqlite3-devel
41 Requires:       gstreamer-cdparanoia >= 0.10.3
42 Requires:       gstreamer-gnomevfs >= 0.10.3
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Banshee is a brand spankin' new audio player based on the GStreamer
47 media library and is developed on the Open Source Mono .NET Platform,
48 written in C#.
49
50 %description -l pl.UTF-8
51 Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
52 multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
53 C#.
54
55 %prep
56 %setup -q
57 %patch -p1
58
59 %build
60 %{__aclocal} -I build/m4/banshee -I build/m4/shamrock
61 %{__libtoolize}
62 %{__automake}
63 %{__autoconf}
64 %configure \
65         --disable-dev-tests \
66         --disable-helix \
67         --disable-ipod \
68         --disable-njb \
69         --disable-vlc \
70         --enable-gstreamer \
71         --enable-avahi \
72         --disable-schemas-install \
73         --disable-docs
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 #mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
84
85 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{la,a}
86
87 %find_lang %{name}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 %update_desktop_database_post
94 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
95 for S in $SCHEMAS; do
96         %gconf_schema_install $S
97 done
98
99 %preun
100 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
101 for S in $SCHEMAS; do
102         %gconf_schema_install $S
103 done
104
105 %postun
106 %update_desktop_database_postun
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc AUTHORS COPYING ChangeLog NEWS README
111 %{_sysconfdir}/gconf/schemas/*.schemas
112 %attr(755,root,root) %{_bindir}/banshee
113 %{_datadir}/banshee
114 %{_pkgconfigdir}/banshee.pc
115 %dir %{_libdir}/banshee
116 %{_libdir}/banshee/*.dll
117 %attr(755,root,root) %{_libdir}/banshee/*.so
118 %{_libdir}/banshee/*.exe
119 %{_libdir}/banshee/*.mdb
120 %{_libdir}/banshee/*.config
121 %{_libdir}/banshee/Banshee.Dap
122 %{_libdir}/banshee/Banshee.MediaEngine
123 %{_libdir}/banshee/Banshee.Plugins
124 #%{_libdir}/monodoc/sources/*
125 %{_desktopdir}/banshee.desktop
126 %{_iconsdir}/hicolor/*/*/*
127 %{_datadir}/dbus-1/services/org.gnome.Banshee.service
This page took 0.068279 seconds and 4 git commands to generate.